Connect Virtualbox vm to linux bridge interface

Host: manajaro
Guest: manjaro live iso

In my old (current) setup I’m using virtualbox bridged network for most VMs, and I’m using a mikrotik between my laptop and whatever network I connect to in order to route each vm where it should. (Including various VPNs.). With my new setup (jumping from windows to manjaro as host) I’m hoping the host will do all the routing, so I don’t need to bring an extra router around.

I had the idea that I could use a bridge interface on the host to do this, but I get no communication between the guest and host.
What I have done is:
start advanced network configuration
[+] bridge [create]
connection name: Bridge0
interface name: bridge0
disable STP (there is no risk of this bridge to come in loop situations)
IPv4 settings: Method=manual
address =

In virtualbox, vm network setting
attached to=Bridged adapter
Name: bridge0
advanced > promiscuous mode = Allow all

In the VM (manjaro live iso)
start Advanced Network Configuration
settings for wired connection 1
IPv4 Settings

With firewall off at both the host and guest, I’d now expected the two to be able to ping each other. Why are they not?

Edit: Two vm’s connected to the same linux bridge, can communicate. None of the communicates with the host.


I finally got this solved… I tried so many things, so not sure which one were necessary. I’ll revert them and report back when I know whats needed.

These are the commands I needed to run in order to make localhost talk to local bridge:

modprobe dummy
ip link add dum0 type dummy
ip link set dum0 master br0
ip link set dum0 up

These are in addition to whats described done in the gui.

I find it strange thou, that there’s a need for a dummy interface connected to the bridge, when the ip is assign to the bridge itself.