Connect Android phone via mtp

Desktop profile: kde.

I tried to connect an Android phone via mtp, but it failed. The error message is as follows:

$ mtpfs
Listing raw device(s)
Device 0 (VID=12d1 and PID=107e) is a Huawei P9 Plus.
   Found 1 device(s):
   Huawei: P9 Plus (12d1:107e) @ bus 1, dev 14
Attempting to connect device
libusb_claim_interface() reports device is busy, likely in use by GVFS or KDE MTP device handling alreadyLIBMTP PANIC: Unable to initialize device
Unable to open raw device 0

It shows that my device is busy and may be occupied by GVFS or KDE MTP. I tried to kill them, but it didn’t work.

I have the following questions:

  1. I cannot see any device mount points under the /run/user/1000/gvfs folder. This is an empty folder. How to deal with this?
  2. How to solve the problem of GVFS or KDE MTP occupying my device?
  3. How can I directly use GVFS or KDE MTP to access my device? The operation of the command line environment is required, and the operation of the GUI environment is not required.
1 Like

Make sure the gvfs-mtp package is installed. It adds and activates the service gvfs-mtp-volume-monitor.service and that should have to give you access to Dolphin to mount it, or trough the System Tray notifications and disk & devices actions to mount and open.

Usually the mtp should happen in mtp:/device_name/*storage once the path
is activated …
Make sure your mobile is set for USB storage when connected to PC.

1 Like

Dolphin can access my phone normally, and the gvfs-mtp package has been installed, but gvfs-mtp-volume-monitor.service does not exist.

$ sudo systemctl start gvfs-mtp-volume-monitor
Failed to start gvfs-mtp-volume-monitor.service: Unit gvfs-mtp-volume-monitor.service not found.

gvfs is still an empty folder.

Is a user unit, and usually should not be loaded, but unloaded … i think because is using dbus org.gtk.vfs.MTPVolumeMonitor
Once you connect the device trough USB there should be a notification and the option to mount it.

Do you have the same issue trough KDE Connect ?

There is no problem with the KDE Connect link. It can accurately detect the SD card and internal memory in my Android device.