Conky questions, transparency XFCE

Hello

I saw that in recent updates Conky stopped working, I have read all the forums here and rewrote some of my old conky files to work with the new updated version, placing them in my
/home/trevor/.config/conky/

Now they work pretty well, but I’m stumped with the transparency,
If I use :
own_window_type = ‘desktop’ the window is transparent but disappears when I click anywhere
own_window_type = ‘override’ the window is not transparent but stays put
own_window_type = ‘normal’ the window is transparent but has the taskbar and border showing on it

any ideas?
Thanks

As I’m using XFCE I have the compositor in windows tweaks on
I don’t use a theme, just have the conky window ‘sitting’ on my desktop wallpaper

This the complete config :

conky.config = {
alignment = ‘bottom_right’,
background = false,
border_width = 0,
cpu_avg_samples = 2,
default_color = ‘white’,
default_outline_color = ‘white’,
default_shade_color = ‘white’,
double_buffer = true,
draw_borders = false,
draw_graph_borders = true,
draw_outline = false,
draw_shades = false,
extra_newline = false,
font = ‘Noto Sans Mono:size=10’,
gap_x = -1470,
gap_y = 60,
minimum_height = 50,
minimum_width = 50,
net_avg_samples = 2,
no_buffers = true,
out_to_console = false,
out_to_ncurses = false,
out_to_stderr = false,
out_to_x = true,

own_window = true,
own_window_transparent = true,
own_window_argb_visual = true,
own_window_argb_value = 0,
own_window_class = 'Conky',
own_window_type = 'override',

show_graph_range = false,
show_graph_scale = false,
stippled_borders = 0,
update_interval = 1.0,
uppercase = false,
use_spacer = 'none',
use_xft = true,
color2 = 'yellow',
color3 = 'FFA300',

}

conky.text = [[
##${color grey}Info:$color ${scroll 32 Conky $conky_version - $sysname $nodename $kernel $machine}
##$hr
${color2}${font Noto Sans Mono:size=12}Terminal Commandes$font
${color2}${hr}${color2}
Bashtop${alignr}${color}bashtop${color2}
Discord${alignr}${color}cordless${color2}
Telegram${alignr}${color}tg${color2}
]]

These settings are working for me on XFCE

 own_window = true,
 own_window_type = 'desktop',
 own_window_argb_visual = true,
 own_window_transparent = true,

Conky - Enable real transparency - ArchWiki

Thanks

But no luck, as soon as I use ‘desktop’ it becomes transparent, but disappears when I click anywhere

try adding this:

own_window_hints = 'undecorated,below,sticky,skip_taskbar,skip_pager',

from Gotham theme posted here - Conky On Latest Manjaro KDE

2 Likes

OH you are good :grinning: :grinning:

That seems to works just nicely, added that and reset ‘override’ back to ‘desktop’

Many thanks

Now to try and rewrite my clock config … :cold_face: :cold_face:

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.