Conky broken after updating Manjaro i3

I had a working conky desktop calendar up until a recent Manjaro update about a week or so ago…
screenshot removed
Basically the bottom of the Conky window is chopped off.
I run Manjaro 6.9.3 with i3.

I’ve tried setting minimum_height = 500, doesn’t work.
To see what’s going on, I’ve tried drawing a border around the Conky window. Interestingly, parts of the two vertical sides are drawn, but not the horizontal sides.
Setting window type to desktop or normal does not fix the issue but instead brings the Conky to the foreground.
Did something change in X11 with the update? Not sure if that’s the problem…
Also tried changing double buffer to true or false, no different…

screenshot removed

I did see some stuff on the web with similar complaints, but there weren’t clear solutions, or the information was a decade old, or just didn’t work.

Would appreciate some help.

Have you tried using a different font; or adjusting the font size?

font = 'Cantarell:size=8',

I’ve tried decreasing the font size, but I don’t like it.
I guess that is a workaround, but I’d rather fix the window size… it should respond to minimum_height and minimum_width, but it doesn’t.

There’s no minimum_width in your screenshot.

Are there maximum_width/height settings that can be used?

Setting all those parameters (minimum_width, maximum_width) does not change anything. There is no maximum_height.

I feel like the window as defined by minimum_height, minimum_width is bigger than the window that gets created in X, hence the clipping…

Well then, all I can suggest is to try a few other fonts/sizes until you find one you like;
beyond that :man_shrugging:

A remote possibility might be to adjust your font scaling, if you have a similar feature in i3.

Please do not post pictures of text. Use copy paste!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.