Confusing Printer on KDE System Settings

I just installed a shiney new Manjaro KDE.
One thing to do is get printer installed.
I click in the lower left and type “print”

It takes me to System Settings / Hardware / Printers

Click here to add new printer!

But these screens, and indeed, the choices after are not documented or supported well for the new user.

In fact, when I search I am confronted with the idea I must have done something wrong because almost everything states I need to install CUPS.

So, what is the expected or intended way to make this happen please?
And where can I find info on which options to chose for set up of my printer?

I can’t find info on this anywhere, and the big HELP button does not seem to work.

Thanx!

Please post the output of systemctl status cups

$ systemctl status cups
● cups.service - CUPS Scheduler
     Loaded: loaded (/usr/lib/systemd/system/cups.service; enabled; vendor preset: disable>
     Active: active (running) since Thu 2021-01-07 11:11:28 EST; 13h ago
TriggeredBy: ● cups.socket
             ● cups.path
       Docs: man:cupsd(8)
   Main PID: 474 (cupsd)
     Status: "Scheduler is running..."
      Tasks: 2 (limit: 19132)
     Memory: 6.2M
     CGroup: /system.slice/cups.service
             └─474 /usr/bin/cupsd -l

Jan 07 11:11:28 FLYputer systemd[1]: Starting CUPS Scheduler...
Jan 07 11:11:28 FLYputer systemd[1]: Started CUPS Scheduler.

@mbb did that help you?

…to help me?

Thanx!

As an interesting part of this process I will offer this:
Most new users would not think to try and install a printer by treating it as a program or application.
In my case, for a Brother MFC-9130CW, I found an AUR to install. I haven’t checked that it is up and working yet because the more important part of this, (I humbly believe,) is how a user intuitively goes through the process in manjaro. So I want to try and get some guidance here on how to properly add a (network) printer to a newly installed Manjaro KDE OS.

For your question on guidance: majaro printing on the wiki explaining how to install and configure printing.

@Hanzel thank you for the response.

In the latest stable of Manjaro KDE, I think 20.2?, it is the process that is gumming things up.

I am sure that going about it as you describe, will end up working. But I am trying to understand, and also make it easier for others experiencing the same thing. (By way of documenting the proper steps.) If you (or a new user) do the somewhat “trained” thing of clicking in the bottom left “M”, and typing “print” you end up going down a rabbit trail!

Either this user interface is meant to be used, and can be documented and supported, or it probably should not be “built-in” to the stable. **Not complaining BTW. I would like to see a different option than the CUPS interface.

I supplied screen shots so others more knowledgeable than I would understand the conflict or direct me through the proper process, since others are likely to go down this same path.

Thank you for trying to solve my issue. Thankfully, I have not absolutely needed a printer so far, but I would like to set it up in a clean way, as intended. Or to find out this “trail” was not intended to be there and is just compounding a new-user’s confusion.

Maybe I have posted in the wrong place? Thanx again.

I have buggered it up from a clean install now.

image

These are the many commands I tried based on helps around the net that looked reasonable. One of the challenges is DATES these helps were posted, and that the newest Manjaro KDE Stable edition probably has some changes to it.

systemctl status cups
sudo gpasswd -a xxxusernamexxx sys
sudo systemctl enable --now org.cups.cupsd.service
sudo pacman -S system-config-printer
pamac install manjaro-printer
sudo systemctl enable --now cups.socket
sudo systemctl enable --now cups.path
pamac remove manjaro-printer

Now for the hard part…

I had pinged my printer after checking to see what its IP address was.
I got a response!
But later I found that the printer must have been mis-configured or otherwise confused because I turned it off and on and some things started happening in the different setups.

I ended up with a printer found, but that wouldn’t print a test page, giving errors about it was not reachable.

I believe I have it installed now as a driverless in ipp everywhere…

So, I am not sure how to help others.
Mine prints for now but I have no idea what I did or did not do that worked over time.
Lastly, I believe there should be a NEW printer “How To” for the latest Manjaro KDE, so new users do not have to go down this path.

If anyone knows how to clean up the mess I made, so that I can install the printer correctly, I would really appreciate it. Otherwise I wonder if it is always just half-broken with the way it now is.

Here is what @mbb had asked for previously, but with my latest changes.
$ systemctl status cups
● cups.service - CUPS Scheduler
Loaded: loaded (/usr/lib/systemd/system/cups.service; enabled; vendor preset: disable>
Active: active (running) since Sat 2021-01-09 20:25:37 EST; 1h 23min ago
TriggeredBy: ● cups.socket
● cups.path
Docs: man:cupsd(8)
Main PID: 479 (cupsd)
Status: “Scheduler is running…”
Tasks: 2 (limit: 19132)
Memory: 6.6M
CGroup: /system.slice/cups.service
└─479 /usr/bin/cupsd -l

Jan 09 20:25:37 FLYputer systemd[1]: Starting CUPS Scheduler...
Jan 09 20:25:37 FLYputer systemd[1]: Started CUPS Scheduler.

Hi! Sorry for the delay. The output is correct. However, cups.service should be disabled, because it is triggered by cups.socket. So:

sudo systemctl disable --now cups.service && sudo systemctl enable --now cups.socket

That’s exactly what you should do, when you find your model there. Those are printer drivers which will be downloaded directly from the manufacturer and properly installed.

After installing the AUR drivers you open the Printer Configuration Utility and add it. If it is a Wireless printer, I advise you to give it a static IP, so you avoid “not reachable” problems.

I am not in the sys group. Why would you do that? To print, you need to be in the lp group (I think). You can check in which groups you are with groups

See above

This should be already installed, but it doesn’t hurt to reinstall.

This is a metapackage which installs every printer package available in the repos. I personally only have fraction of those (I don’t have gutenprint, for example). Anyway, it doesn’t hurt to have installed, you’ll just have more driver options when adding the printer.

See above

I have this disabled. Not sure of what it does.

This may remove some packages which are needed.

This seems ok. The difference to my setup is that cups.service isn’t triggered by cups.path

There is also a systemd unit file /lib/systemd/system/cups.path which starts CUPS when the /var/cache/cups/org.cups.cupsd file is newly created (not when it is already there).

(source)

Well, I went through what you gave to me and I was OK until I got to:
"After installing the AUR drivers you open the Printer Configuration Utility and add it. "

This seemed to be installed several times, so I tried to figure out the difference.

I could not. (noob)

So I deleted all of the printer stuff thru the gui pamac, and started over.

This is my output so we have something to work with:
$ systemctl status cups
● cups.service - CUPS Scheduler
Loaded: loaded (/usr/lib/systemd/system/cups.service; disabled; vendor preset: disabl>
Active: active (running) since Mon 2021-01-11 22:02:32 EST; 5min ago
TriggeredBy: ● cups.socket
Docs: man:cupsd(8)
Main PID: 122518 (cupsd)
Status: “Scheduler is running…”
Tasks: 3 (limit: 19132)
Memory: 7.2M
CGroup: /system.slice/cups.service
├─122518 /usr/bin/cupsd -l
└─122521 /usr/lib/cups/notifier/dbus dbus://

Jan 11 22:02:32 FLYputer systemd[1]: Starting CUPS Scheduler...
Jan 11 22:02:32 FLYputer systemd[1]: Started CUPS Scheduler.

The 9130 installs.
In fact the 9130 is “Discovered”
But as soon as I set it up it is not able to be found!

When I do the printer config it shows the discovered printer.
I pick that, because I do not know how to use the others like ipp https, etc.

I did set the printer (on the printer) to be a static IP.
I also checked the group to see I am in the lp group.

So now what do you think I should do?

  1. I really want to have this a clean install, like it should be as I just installed the Stable on a clean SSD.
  2. I noticed I have two 9130 drivers to choose from and they both look exactly the same!
  3. If a printer is “Discovered” shoudln’t it just work, since it was discovered?
  4. This is going to mess new users up, having all of these printer config options show up:
    image

I appreciate your help.

Thanx

==================
UPDATE

I completely reset my printer’s network. (Because I could not get a response from a ping)
I set it to static again.
Ping returns now to the IP address.

I open the FIRST listed printer config (Has the word YOUR in it. Seems to be a KDE settings window)
image

and it lists TWO discovered Network Printers!

Now, DRIVERLESS sounds better with what we have gone through, but how could I know! And why are there two!?
If I click on the “fully driverless” it is greyed out and wants connection info, which I do not know about.
The top one seems to be ready to let m ego forward with IPP network printer via DNS-SD, so I am going to use it.
It asks for a driver, but it has two recommended already! Both exactly the same!

I picked the first one and FINISHED.
All looks good!
So I pull down Maintenance and select Test Print

image

Unable to locate printer!!!

Seriously, this seems awfully complicated. Is it just me?!

I go to PING and no response. (Did it go to sleep and now isn’t responding?!)

I don’t know!

I removed the printer and now I am trying the second Printer Config (without the word YOUR in it)
First step is to UNLOCK.

Dropdown for Network Printer shows a Brother (My printer) and this one uses AppSocket

It searches for drivers again. This time no recommendations so I have to go into Brother.
Only one for mine now, so I select it and I am prompted with Test Page? I select it.

Nothing.
Now I notice my PING is failing:
image

I am not sure why when I ask for 213 I get a response from 198, but still. This is anything but simple.

I am pretty sure I making things hard on myself, but beside wanting to get this right in my fancy new install of Manjaro KDE, I still want to point out that this will be confusing to new users, and printing is usually a basic need.

Last thing before giving up… Turn the printer off and back on. Ug! That feels like many days on Windows!

PING starts to give returns.

I have no idea what to do.

Thanx!

Hi! Sorry for the delay again.

It doesn’t matter which program you use to install the printer because they use the same backend. I personally use the second one you showed.

The OfficeJet you see above is a wireless printer. If I right-click on it and then click properties, I can see the IP address. This address can be changed if needed.

When adding the printer I get 2 different driver options (excluding the FAX). I installed the HPLIP one. But this is an HP, which has its own Linux utility, which installs the driver for me. In your case, you should have a driver available after installing it from AUR.

The way I see it, you’re doing it correctly. Verify the IP address before printing a test page. I see no reason for it not to work.

It seems to be working now.
Very frustrating, but glad it is up.
Guess I will give it another go in a year or so, when I install a fresh new version!

Thank you for sticking with me! Hopefully others will find value in it.

1 Like

You don’t need it. Just keep Manjaro updated and you’ll always have the latest version.

Oh yes. I will be good by just keeping things updated, which I will do.

But, about once a year I do a completely fresh install. And actually, I plan to get a new desktop unit built in the coming months. When that happens I install fresh, and add the apps and configs I want from scratch. This helps me learn a little, and it gets me back to a very clean and -as intended-out-of-the-box install. That is important because who even knows everything I mucked with, during just this little journey trying to get printers working.

So, I will expect to have to figure it all out at that time, too.

But I do appreciate your help @mbb and others. Thanx!

1 Like