Confused about BIOS or EFI; not getting a menu to indicate choice on install

Hi people,

I bought a second hand Fujitsu Lifebook E544 with Win10 on it - originally Win7 going by the stickers. I’m trying to install Manjaro 21.2 Xfce while keeping Windows for possible emergency use.

There is one 500GB harddrive that has two NTFS paritions on it, I assume the big one with Win10 itself, and the small 50MB one with boot stuff.

In my first attempt I chose the ‘Install alongside’ option in Calamares – installation went all the way till just at the end, where it complained, I believe, that there was no place to install Grub or something of the sort (sorry, didn’t note it down).

In my second attempt I went for Manual partitioning following forum. (assuming UEFI), which gave me a system that on starting up the computer goes straight to Manjaro (which works nicely!) - no Grub menu, no option to pick Windows.

I subsequently removed this Manjaro install and used fixparts from the Live USB to make that 50MB NTFS partition bootable again. Now Win10 boots automatically again: back to square one.

Thing is, I don’t know much about boot stuff, and I’m confused whether the boot system is in fact BIOS or UEFI. Calamares claims “This system was started with an EFI boot environment” and “This device has a MBR parition table”. However the actual menu when you hit F2 just after starting the computer is called BIOS menu, looks like any oldschool BIOS menu, and nowhere mentions an EFI or UEFI option. Also, the file C:\Windows\Panther\setupact.log lists “Detected boot environment: BIOS”.

When I assume it’s BIOS and in Calamares I try a Manual paritioning without a boot partition mounted at /boot/efi, Calamares complains that I should have one.

Something to note: when I boot to my Installation Live USB, I am not getting any menu with choices; I’m just seeing the black screen with scrolling terminal-style messages then it goes to the graphical desktop. Perhaps EFI is being picked here without me seeing it? I now notice a topic (forum. also about a Fujitsu Lifebook with a similar problem, where the answer is “you need to boot the installer stick in BIOS mode”. But how?

Any advice much appreciated, thanks!

Hi, welcome to Manjaro :blush:
there is a 2020 BIOS upgrade (1.15) for your notebook that you should install first. You can find it at the following link: BIOS-Download
The corresponding installation instructions are included in the BIOS download. Please follow them exactly to avoid a defect, and remember that the notebook is plugged in and not running on battery power during the BIOS/UEFI upgrade. It is a UEFI, which means you can turn off the BIOS Compatibility Mode (CSM) in the BIOS/UEFI menu once the upgrade is completed properly. After that, you should be able to install Manjaro and Windows in UEFI Mode. Remember to keep “Secure Boot” off, otherwise Manjaro won’t boot. Check that in your BIOS/UEFI Setup.


First some clarification:

  • BIOS is a firmware interface for the motherboard. Originally, it could only be navigated through keyboard.
    Recent versions allows for mouse navigation and introduces (U)EFI.
  • “MBR bootloading” uses the Master Boot Record, located at the beginning of a drive.
    In old BIOS, only MBR bootloading is supported. In more recent ones, which provide an option for choosing the boot mode, “Legacy” must be selected.
  • “EFI bootloading” uses a EFI partition on a drive.
    EFI is not supported on old BIOS. In more recent ones, the boot mode must be set to EFI or UEFI.

When booting a liveUSB, you may the choice of how the system boots it: the Legacy way or the UEFI way. This is usually configured in the BIOS, similarly to how installed systems shall be booted.
Then, once the liveUSB is booted in a given mode, the installation will also occur in that same mode. In your case, in order to install Manjaro is Legacy mode – since this is how Windows currently seems to be installed – you must first boot the liveUSB in Legacy mode.

1 Like

Thanks LinKostik for the link, and thanks maycne.sonahoz for the explanation!

The BIOS present was indeed an older version; I updated it to 1.15 without a hitch.

However, there’s no change as far as my issue is concerned: still getting the exact same behavior. Note that when I install under the assumption of an UEFI environment (for Calamares says “This system was started with an EFI boot environment”) when I then check with efibootmgr it gives

BootOrder: 0000,001A,001D,001C,0018,0019,0017,001B,0001,0016
Boot0000* Manjaro
Boot0001* Windows Boot Manager
Boot0010  BIOS Setup       
Boot0011  Boot Menu

and when right after switching on the laptop I hit F12 I get into the firmware’s ‘Boot Menu’ which reads

1. Manjaro
2. CD/DVD Drive: so and so
3. Drive4 HDD: so and so
4. Network
5. Windows Boot Manager

When I choose either 1 or 5 I get a “Warning. Boot Failure” message. When I choose 3, Manjaro boots up (as it does when I leave F12 alone). So, still no way to choose between the OSes.

Understood (on the assumption we want a non-UEFI boot environment), but I don’t know how to boot the liveUSB in Legacy mode. As said, I’m not getting any boot options when I boot from the liveUSB pendrive. I tried booting from the same pendrive on two other laptops and there a menu (Grub I think?) does appear. It has options such as changing time and keyboard layout and using free or proprietary drivers, but nothing about (U)EFI; so I doubt that would help even if it did pop up on the Fujitsu.

Any further ideas? cheers

While you see the “bios screen”, you should press the button for the “boot menu”, usualy something like F1, F12 or similar.

If you want to install as UEFI/GPT, you would select an entry that starts with

UEFI: <your installation media>

If you would want to install as Legacy / MBR:

<your installation media>

Of course, if you want to install as UEFI/GPT, but do not see that entry in the “manual bios boot menu” (upon pressing a “special button”) but do not see the media with a pre-fixed UEFI, then the media is not supported for UEFI/GPT installations which may be because:

  1. You have not disable Legacy/CRM support
  2. The installation media is NTFS (needs vfat or fat32)
  3. or both of it

Also be aware that for UEFI/GPT installation, you will need the first partition to be bios_boot (size: 2 MB).
Check for its existence by:

sudo gdisk -l /dev/sda

Hope this helps

Thank you very much, it helped me a little to sort out the problems in my project.

Thanks @sea for the further clarifications. I get what everyone is saying but I’m still confused by my system’s situation – but closing in on the issue, I hope.

First, just a thought: could it make a difference that I am installing from the ‘Minimal’ Live USB version? As in: perhaps that one is for UEFI booting only?

Second, another thought, following from

I just checked point 2 in gparted and it turns out the Live USB’s file system is iso9660, apparently a file system for optical disc media. Hmm, maybe that’s the culprit?

Well, when I get to the boot menu via F12 none of the possible entries have “UEFI:” in front of them. Whether I enable or disable the ‘Compatibility Support Module’ in the BIOS menu (via F2) makes no difference. But then is this CSM really the ‘Legacy’ option people are referring to? It is listed as providing “backward compatibility services for legacy BIOS services, like int10/13, dependent OS.[sic]” Is that about EFI-or-not at all? Also whether CSM is enabled or disabled, or whatever I do, Calamares always says "This system was started with an EFI boot environment”.

Curiously if not bewilderingly, I have now on two occasions gotten a Manjaro boot menu when booting from the LiveUSB. This menu has an option “Detect EFI bootloaders” which results in “No EFI files detected”. Later when booting again from the LiveUSB and without having changed any BIOS boot option, I did not get this menu anymore, and went straight to the Live system as before.

Summary for now:

  • from the info Windows gives (see original post) plus from the fact that Calamares says MBR not GPT plus from the fact that there nowhere is an “UEFI:etc.” install suggestion, I’d guess the whole thing should run in ‘legacy’, non-EFI, BIOS mode, and Manjaro should be installed thus, and the MBR updated accordingly
  • I haven’t found any way to make Calamares state anything other than "This system was started with an EFI boot environment” and then insist on a UEFI-like install; when I go along with that, I seem to end up with an UEFI-like Manjaro install that passes all the checks for an EFI-using system listed at www.unixarena. com/2018/05/how-to-find-linux-is-under-bios-or-uefi-mode.html (pardon the chopped-up link, I can’t seem to post links yet :/) but that is entirely disconnected from the Windows install, in the sense that I cannot choose between them.
  • Let me mention that Win10 came installed on the laptop, but I don’t have any install disks or suchlike to re-install it if that would be necessary.

I hope that makes some sense; finding it hard to wrap my head around. More attempts later, perhaps with a newly written Live USB, especially if you guys confirm the suspicion that the issue may be there. Thanks all!

Your Windows is installed in BIOS/Legacy mode. You should install Manjaro (or any other Linux) in the same mode if you want to get dual boot in Grub.

To install Manjaro in the BIOS/Legacy mode, you have to boot the installation USB in BIOS/Legacy mode. Manjaro’s installation USB supports both modes (BIOS and UEFI) and it’s up to you (the user) in what mode to boot. As user Sea stated, you have to find the boot menu of your machine (F12, F10 or similar) and select the correct boot mode. Another option is to enter your BIOS/UEFI and manually set the boot mode to “only legacy” or similar.

About Windows, you can download the installation ISO directly from Microsoft: Google “Windows 10 download” and probably the first result will get you to the Microsoft download page. License key is not needed anymore. Microsoft has the fingerprint of your machine (as you have a license that is already activated) and it will detect that when Windows connects to internet.

1 Like

Well, mostly solved, but a few more questions (in bold below).

I did not manage to get Manjaro installed alongside the initial Win10 (with both accessible). I made an attempt from within Windows to convert from MBR to GPT (there’s a MBR2GP tool), but this too ran into errors and the rabbit hole was getting to deep.

So I took @cfinnberg 's lead and made myself a Win10 install USB drive – I had no idea it can be downloaded these days. Installed a brand new Win10 instance from it, nuking the old one, with CSM disabled in the BIOS. As intended, this gave a working install in UEFI + GPT mode. (It’s also a leaner Win install than the original, so no loss.)

Then I took a freshly burned Manjaro Live USB to it. First attempt to install, with custom partitioning, failed when I tried to hook /boot/EFI to Windows’s 100MB boot partition, but Calamares wanted 300MB. (Was that the right thing to try though?) Second attempt: just the ‘install alongside’ option. This worked without error messages.

On starting up the laptop after that, I still get nothing that looks like a Grub menu. With no input, Manjaro boots directly, albeit with very minimal messages: a blank screen, then just the “/dev/sda5: clean …/… files …/… blocks” message, then a blinking cursor for a number seconds, then Manjaro comes on fine. Should I worry about the usual colorful lines of system output not being displayed?

If right after switching on the laptop I hit F12, I get to the BIOS’es own boot menu; when I pick Windows Boot Manager, Win10 now does boot fine! So pragmatically, the issue is mostly solved: Manjaro starts by default; and I can access Win if I need to.

However, quickly hitting F12 (with an annoyingly loud beep) is a bit clumsy, so if there is a way to get a proper Grub-like boot menu – also for setting Manjaro’s boot options, kernel choice or whatever – I’d appreciate any hints. Thanks all!

Try first with
sudo update-grub

If that doesn’t find your Windows, can you provide the output of these commands?

  • sudo efibootmgr -v
  • sudo lsblk -f
  • sudo fdisk -l

With this we can probably guess what the problem is.

Thanks @cfinnberg for the follow-up. Running update-grub gives

Generating grub configuration file ...
Found theme: /usr/share/grub/themes/manjaro/theme.txt
Found linux image: /boot/vmlinuz-5.15-x86_64
Found initrd image: /boot/intel-ucode.img /boot/initramfs-5.15-x86_64.img
Found initrd fallback image: /boot/initramfs-5.15-x86_64-fallback.img
Warning: os-prober will be executed to detect other bootable partitions.
Its output will be used to detect bootable binaries on them and create new boot entries.
Found Windows Boot Manager on /dev/sda1@/EFI/Microsoft/Boot/bootmgfw.efi
Adding boot menu entry for UEFI Firmware Settings ...
Found memtest86+ image: /boot/memtest86+/memtest.bin

That sounded promising to me, but there was no change in boot behaviour: still no grub-like menu on the horizon. It’s almost as if grub might actually be running but it doesn’t show, only black and a cursor, and then the default option gets chosen behind the scenes. Similar to how I did not get a boot menu from the Live USB (except on two occasions but no idea why it did show up then). I can’t find any combo of firmware boot options that changes this either…

Below the output of the commands you suggested; I don’t see any glaring issues with it but what do I know.

$ sudo efibootmgr -v
BootCurrent: 0000
Timeout: 2 seconds
BootOrder: 001A,001C,0000,0001,0017,001D,0018,0019,001B,0016
Boot0000* Manjaro	HD(1,GPT,127290bb-5ed7-4a4b-8e03-3c12d37eab94,0x800,0x32000)/File(\EFI\Manjaro\grubx64.efi)
Boot0001* Windows Boot Manager	HD(1,GPT,127290bb-5ed7-4a4b-8e03-3c12d37eab94,0x800,0x32000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.}...t................
Boot0010  BIOS Setup       	FvFile(721c8b66-426c-4e86-8e99-3457c46ab0b9)
Boot0011  Boot Menu	FvFile(86488440-41bb-42c7-93ac-450fbf7766bf)
Boot0012  Diagnostic Screen	FvFile(a7d8d9a6-6ab0-4aeb-ad9d-163e59a7a380)
Boot0013  Recovery and Utility	FvFile(0b150fda-3bdd-4406-9859-448177476993)
Boot0014  Diagnostic Program	FvFile(29f85733-2b1a-4821-8f61-2614778c0c73)
Boot0015  Diagnostic Progrogram ROM	VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,c0f527e7c05f4d498df59dc81ac2cfdd00)
Boot0016  Floppy Disk Drive:	VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,6ff015a28830b543a8b8641009461e49)
Boot0017* Drive4 HDD:	VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,91af625956449f41a7b91f4f892ab0f604)
Boot0018* Drive0 HDD:	VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,91af625956449f41a7b91f4f892ab0f600)
Boot0019* Drive2 HDD:	VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,91af625956449f41a7b91f4f892ab0f602)
Boot001A* CD/DVD Drive:	VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,23e6a6e08bae6940adb9a7b5c5f00628)
Boot001B* NETWORK:	VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,78a84aaf2b2afc4ea79cf5cc8f3d3803)
Boot001C* USB HDD:	VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,33e821aaaf33bc4789bd419f88c50803)
Boot001D* USB CD/DVD:	VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,d630a9056829ce41861e8c380ff2225a)
Boot001E* ATA HDD:	VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,91af625956449f41a7b91f4f892ab0f6)
Boot001F* Erase Disk	FvFile(43f9b080-c902-4737-b306-487050f7caa5)

$ sudo lsblk -f
│    vfat   FAT32       BE9D-ACD2                              70.8M    26% /boot/efi
│    ntfs               F200A7F000A7BA4D                                    
│    ntfs               7EBEB43EBEB3ED31                                    
     ext4   1.0         a405bda3-23ca-4c1a-a24d-10d4e36ebd01  327.5G     4% /

$ sudo fdisk -l
Disk /dev/sda: 465.76 GiB, 500107862016 bytes, 976773168 sectors
Disk model: ST500LM000-1EJ16
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: FBE8EEAC-AF63-48C9-8D11-238A175435B6

Device         Start       End   Sectors   Size Type
/dev/sda1       2048    206847    204800   100M EFI System
/dev/sda2     206848    239615     32768    16M Microsoft reserved
/dev/sda3     239616 205098255 204858640  97.7G Microsoft basic data
/dev/sda4  975710208 976769023   1058816   517M Windows recovery environment
/dev/sda5  205098257 975709807 770611551 367.5G Linux filesystem

Partition 5 does not start on physical sector boundary.
Partition table entries are not in disk order.

So this gives a clear signal that both systems are installed in UEFI mode and Manjaro’s Grub is able to “see” Windows and has added it to Grub’s menu.

Ok, that’s strange. Manjaro defaults to hide the Grub menu but it shows it if there is more systems detected (as it is your case). At first I thought that Grub might have some problem detecting Windows and that should be why it didn’t show up in Grub menu (and why the menu didn’t show up either).

But the fact that we now know that Windows is actually detected (and Grub menu should show up) and the fact that not even liveUSB’s Grub menu shows up is different.

Have you tried to press ESC -key in moments where Grub menu should show up? I want to know if there is some kind of incompatibility of Grub with your computer or it is just that Grub menu is hidden by default (despite you having two installed systems).

OK, I now tried hitting Esc at the moment you suggested. I also experimented with setting GRUB_TIMEOUT_STYLE=menu in /etc/default/grub, as suggested somewhere. Result: a black screen. When after a spot of enjoying the darkness I hit enter, Manjaro boots up (still with no more output than the single /dev/sda5: clean etc. line).

This result seems to confirm that grub is indeed running, but its visual output is somehow being blacked out. I queried the Web a bit to see if this is a Fujitsu specific issue, but did not find any leads yet.

Any thoughts? Perhaps I should open a new topic as the issue has shifted.

(As an aside, I also have issues with the Elantech touchpad sometimes not being recognized, and my Bluetooth headphones too - other Bluetooth stuff works. Kind of erratically. No idea if these could be related to the grub issue at all…)

Some more browsing (see end of post; still not allowed to link) led to a (partial) solution. In /etc/default/grub I uncommented the line #GRUB_TERMINAL_OUTPUT=console. Then ran update-grub and rebooted. With this, the non-graphical Grub menu does show up at boot time :slight_smile:

When I run the videoinfo command from there, it lists no video modes.

The console menu is perfectly adequate, so pragmatically my issue is solved.

Curious whether I could nonetheless get graphical Grub output I tried other suggested edits to /etc/default/grub: replacing auto in GRUB_GFXMODE=auto by my screen resolution; or adding GRUB_VIDEO_BACKEND=efi_gop or GRUB_VIDEO_BACKEND=efi_uga. This all still results in a black screen. In the latter case, when I pick Manjaro in the dark, there follows a message “error: no suitable video mode found // booting in blind mode”, after which I still get the single /dev/sda5: clean etc. line with a blinking cursor, and then the usual boot to the graphical desktop.

I believe at some point while experimenting with suitable BIOS options for the Manjaro Live USB I did see a graphical Manjaro/grub boot menu. So perhaps there is some combo of firmware boot options that would allow a graphical Grub menu. Not really a priority though to figure it out, and maybe it messes up something else (I don’t know, maybe it only works in Legacy BIOS mode or something).

Thanks @cfinnberg and everybody else for getting me on the right track! And thanks Manjaro devs and community for all your efforts :pray:t3: :smiley:

PS chopped links addressing the ‘invisible Grub menu’ issue:
askubuntu. com/questions/1142167/grub-menu-working-but-hidden-cant-make-it-visible
unix.stackexchange. com/questions/659828/grub-selection-menu-is-working-but-not-visible