Conflicting.. how to resolve?

When encounter this, how to solve ?

:: installing db (6.2.32-1) breaks dependency 'db=5.3.28' required by lib32-db
pacman log
$ sudo pacman -Syu --noconfirm
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
:: Starting full system upgrade...
:: Replace appstream-qt with extra/appstream-qt5? [Y/n] 
:: Replace at-spi2-atk with extra/at-spi2-core? [Y/n] 
:: Replace atk with extra/at-spi2-core? [Y/n] 
:: Replace attica with extra/attica5? [Y/n] 
:: Replace bashrc-manjaro with core/bash? [Y/n] 
:: Replace bluez-qt with extra/bluez-qt5? [Y/n] 
:: Replace breeze with extra/breeze5? [Y/n] 
:: Replace crda with core/wireless-regdb? [Y/n] 
:: Replace frameworkintegration with extra/frameworkintegration5? [Y/n] 
:: Replace kactivities with extra/kactivities5? [Y/n] 
:: Replace kactivities with extra/plasma-activities? [Y/n] 
:: Replace kactivities-stats with extra/kactivities-stats5? [Y/n] 
:: Replace kactivities-stats with extra/plasma-activities-stats? [Y/n] 
:: Replace karchive with extra/karchive5? [Y/n] 
:: Replace kauth with extra/kauth5? [Y/n] 
:: Replace kbookmarks with extra/kbookmarks5? [Y/n] 
:: Replace kcalendarcore with extra/kcalendarcore5? [Y/n] 
:: Replace kcmutils with extra/kcmutils5? [Y/n] 
:: Replace kcodecs with extra/kcodecs5? [Y/n] 
:: Replace kcompletion with extra/kcompletion5? [Y/n] 
:: Replace kconfig with extra/kconfig5? [Y/n] 
:: Replace kconfigwidgets with extra/kconfigwidgets5? [Y/n] 
:: Replace kcontacts with extra/kcontacts5? [Y/n] 
:: Replace kcoreaddons with extra/kcoreaddons5? [Y/n] 
:: Replace kcrash with extra/kcrash5? [Y/n] 
:: Replace kdbusaddons with extra/kdbusaddons5? [Y/n] 
:: Replace kdeclarative with extra/kdeclarative5? [Y/n] 
:: Replace kded with extra/kded5? [Y/n] 
:: Replace kdesu with extra/kdesu5? [Y/n] 
:: Replace kdnssd with extra/kdnssd5? [Y/n] 
:: Replace kdoctools with extra/kdoctools5? [Y/n] 
:: Replace kdsoap with extra/kdsoap-qt5? [Y/n] 
:: Replace kfilemetadata with extra/kfilemetadata5? [Y/n] 
:: Replace kgamma5 with extra/kgamma? [Y/n] 
:: Replace kglobalaccel with extra/kglobalaccel5? [Y/n] 
:: Replace kguiaddons with extra/kguiaddons5? [Y/n] 
:: Replace kholidays with extra/kholidays5? [Y/n] 
:: Replace ki18n with extra/ki18n5? [Y/n] 
:: Replace kiconthemes with extra/kiconthemes5? [Y/n] 
:: Replace kidletime with extra/kidletime5? [Y/n] 
:: Replace kimageformats with extra/kimageformats5? [Y/n] 
:: Replace kio with extra/kio5? [Y/n] 
:: Replace kitemmodels with extra/kitemmodels5? [Y/n] 
:: Replace kitemviews with extra/kitemviews5? [Y/n] 
:: Replace kjobwidgets with extra/kjobwidgets5? [Y/n] 
:: Replace knewstuff with extra/knewstuff5? [Y/n] 
:: Replace knotifications with extra/knotifications5? [Y/n] 
:: Replace knotifyconfig with extra/knotifyconfig5? [Y/n] 
:: Replace kpackage with extra/kpackage5? [Y/n] 
:: Replace kparts with extra/kparts5? [Y/n] 
:: Replace kpeople with extra/kpeople5? [Y/n] 
:: Replace kpty with extra/kpty5? [Y/n] 
:: Replace kservice with extra/kservice5? [Y/n] 
:: Replace ksysguard with extra/plasma-systemmonitor? [Y/n] 
:: Replace ktexteditor with extra/ktexteditor5? [Y/n] 
:: Replace ktextwidgets with extra/ktextwidgets5? [Y/n] 
:: Replace kunitconversion with extra/kunitconversion5? [Y/n] 
:: Replace kwallet with extra/kwallet5? [Y/n] 
:: Replace kwayland with extra/kwayland5? [Y/n] 
:: Replace kwidgetsaddons with extra/kwidgetsaddons5? [Y/n] 
:: Replace kwindowsystem with extra/kwindowsystem5? [Y/n] 
:: Replace kxmlgui with extra/kxmlgui5? [Y/n] 
:: Replace lib32-at-spi2-atk with multilib/lib32-at-spi2-core? [Y/n] 
:: Replace lib32-atk with multilib/lib32-at-spi2-core? [Y/n] 
:: Replace libkcddb with extra/libkcddb5? [Y/n] 
:: Replace libqaccessibilityclient with extra/libqaccessibilityclient-qt5? [Y/n] 
:: Replace modemmanager-qt with extra/modemmanager-qt5? [Y/n] 
:: Replace networkmanager-qt with extra/networkmanager-qt5? [Y/n] 
:: Replace oxygen with extra/oxygen5? [Y/n] 
:: Replace plasma-framework with extra/libplasma? [Y/n] 
:: Replace plasma-framework with extra/plasma-framework5? [Y/n] 
:: Replace plasma-integration with extra/plasma5-integration? [Y/n] 
:: Replace plasma5-themes-breath with extra/plasma6-themes-breath? [Y/n] 
:: Replace plasma5-themes-breath-migration with extra/plasma6-themes-breath-migration? [Y/n] 
:: Replace prison with extra/prison5? [Y/n] 
:: Replace purpose with extra/purpose5? [Y/n] 
:: Replace qqc2-desktop-style with extra/qqc2-desktop-style5? [Y/n] 
:: Replace sdl with extra/sdl12-compat? [Y/n] 
:: Replace solid with extra/solid5? [Y/n] 
:: Replace sonnet with extra/sonnet5? [Y/n] 
:: Replace steam-manjaro with multilib/steam? [Y/n] 
:: Replace syndication with extra/syndication5? [Y/n] 
:: Replace syntax-highlighting with extra/syntax-highlighting5? [Y/n] 
:: Replace threadweaver with extra/threadweaver5? [Y/n] 
resolving dependencies...
:: There are 2 providers available for dbus-units:
:: Repository core
   1) dbus-broker-units  2) dbus-daemon-units

Enter a number (default=1): 
:: There are 2 providers available for qt6-multimedia-backend:
:: Repository extra
   1) qt6-multimedia-ffmpeg  2) qt6-multimedia-gstreamer

Enter a number (default=1): 
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: installing db (6.2.32-1) breaks dependency 'db=5.3.28' required by lib32-db

Moderator edit: In the future, please use proper formatting: [HowTo] Post command output and file content as formatted text

lib32-db is an AUR package that you likely should not have.

It is certainly the reason you are having this dependency problem.

AUR (en) - lib32-db

Maintainer: None

Last Updated: 2022-12-22 05:52 (UTC)

suggest using

pamac remove --orphans

to remove all orphan packages before updating

Also:

Pacnews not been merged for a year or so …? Community repo was deprecated about a year ago.

pacdiff -o
2 Likes