Conflict when trying to update system (libgedit-amtk and amtk)

I made another post about this topic, that problem is solved (ffmpeg), but this problem occurred. What should i do? Should I remove one of those package?

Sudo pacman -Syu
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
:: Starting full system upgrade...
:: Replace i3-gaps with extra/i3-wm? [Y/n] n
:: Replace kactivities with extra/kactivities5? [Y/n] y
:: Replace karchive with extra/karchive5? [Y/n] y
:: Replace kauth with extra/kauth5? [Y/n] y
:: Replace kbookmarks with extra/kbookmarks5? [Y/n] y
:: Replace kcmutils with extra/kcmutils5? [Y/n] y
:: Replace kcodecs with extra/kcodecs5? [Y/n] y
:: Replace kcompletion with extra/kcompletion5? [Y/n] y
:: Replace kconfig with extra/kconfig5? [Y/n] y
:: Replace kconfigwidgets with extra/kconfigwidgets5? [Y/n] y
:: Replace kcontacts with extra/kcontacts5? [Y/n] y
:: Replace kcoreaddons with extra/kcoreaddons5? [Y/n] y
:: Replace kcrash with extra/kcrash5? [Y/n] y
:: Replace kdbusaddons with extra/kdbusaddons5? [Y/n] y
:: Replace kdeclarative with extra/kdeclarative5? [Y/n] y
:: Replace kded with extra/kded5? [Y/n] y
:: Replace kglobalaccel with extra/kglobalaccel5? [Y/n] y
:: Replace kguiaddons with extra/kguiaddons5? [Y/n] y
:: Replace ki18n with extra/ki18n5? [Y/n] y
:: Replace kiconthemes with extra/kiconthemes5? [Y/n] y
:: Replace kio with extra/kio5? [Y/n] y
:: Replace kitemmodels with extra/kitemmodels5? [Y/n] y
:: Replace kitemviews with extra/kitemviews5? [Y/n] y
:: Replace kjobwidgets with extra/kjobwidgets5? [Y/n] y
:: Replace knotifications with extra/knotifications5? [Y/n] y
:: Replace kpackage with extra/kpackage5? [Y/n] y
:: Replace kparts with extra/kparts5? [Y/n] y
:: Replace kpeople with extra/kpeople5? [Y/n] y
:: Replace kpty with extra/kpty5? [Y/n] y
:: Replace kservice with extra/kservice5? [Y/n] y
y:: Replace ktextwidgets with extra/ktextwidgets5? [Y/n] 
:: Replace kwallet with extra/kwallet5? [Y/n] y
:: Replace kwidgetsaddons with extra/kwidgetsaddons5? [Y/n] y
:: Replace kwindowsystem with extra/kwindowsystem5? [Y/n] y
:: Replace kxmlgui with extra/kxmlgui5? [Y/n] y
y
:: Replace modemmanager-qt with extra/modemmanager-qt5? [Y/n] y
:: Replace purpose with extra/purpose5? [Y/n] y
:: Replace qqc2-desktop-style with extra/qqc2-desktop-style5? [Y/n] y
:: Replace solid with extra/solid5? [Y/n] y
:: Replace sonnet with extra/sonnet5? [Y/n] y
:: Replace threadweaver with extra/threadweaver5? [Y/n] y
resolving dependencies...
looking for conflicting packages...
:: libgedit-amtk and amtk are in conflict. Remove amtk? [y/N] n
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: libgedit-amtk and amtk are in conflict


Yes. You can’t have both.

Also, FYI, you don’t have to actually type ‘y’ or ‘n’ if the letter you want is capitalized. That’s the default if you only press enter.

1 Like

Specifically, remove amtk. This package has already been removed from the Unstable and Testing channels.

1 Like

Remove the amtk package:

sudo pacman -R amtk

Perform update again;
Choose Y to replace all packages requested:

sudo pacman -Syu

Enjoy Manjaro.

Cheers. :partying_face:

1 Like

Now we need 3 more people to reiterate everything 3 more times, but with more sentences and paragraphs.

Guys, best if someone just goes to his home and types it on his pc.

1 Like

That often happens, too. Still, better to have additional confirmation when you haven’t a clue, right? :wink:

You would do that for him? What a champ. :trophy:

1 Like

Had to add -Rdd but now i can perform an update Thanks for every comment!

Understood.

I’m glad it all worked out for you. Cheers.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.