Configure Brother wifi printer on Plasma desktop

I have a Brother MFC-L2710DW printer. Connected by WIFI on my LAN home network. It prints as expected in other OSes.
I installed the corresponding driver from AUR.
I made a few attempts at adding the printer through the printer wizard; the printer is detected in the network printer section, and I am presented with drivers that look right. I tried a couple of them, but when I print, I get errors.
One driver prints reams of empty pages
Another driver makes the printer say it is out of memory.
How to do this right?
See screenshot

nmcli                                                                              ✔ 
enp3s0: connected to Wired connection 1
        "Realtek RTL8111/8168/8411"
        ethernet (r8169), A8:5E:45:E2:87:3C, hw, mtu 1500
        ip4 default
        route4 metric 100
        route4 default via metric 100
        inet6 fe80::32bc:998d:a1d:2054/64
        route6 fe80::/64 metric 1024

lo: connected (externally) to lo
        loopback (unknown), 00:00:00:00:00:00, sw, mtu 65536
        inet6 ::1/128

enp0s20f0u3u1: unavailable
        "Realtek RTL8153"
        ethernet (r8152), 00:E0:4C:68:51:92, hw, mtu 1500

DNS configuration:
        domains: Home
        interface: enp3s0

lines 1-25

sudo arp-scan -l                                                           ✔  31s  
Interface: enp3s0, type: EN10MB, MAC: a8:5e:45:e2:87:3c, IPv4:
WARNING: Cannot open MAC/Vendor file ieee-oui.txt: Permission denied
WARNING: Cannot open MAC/Vendor file mac-vendor.txt: Permission denied
Starting arp-scan 1.10.0 with 256 hosts (        00:b8:c2:4c:c2:45       (Unknown)        1c:bf:c0:f3:75:2d       (Unknown)      00:b8:c2:4d:c1:3d       (Unknown)      28:80:23:40:00:43       (Unknown)        3a:65:1f:18:4a:2c       (Unknown: locally administered)

5 packets received by filter, 0 packets dropped by kernel
Ending arp-scan 1.10.0: 256 hosts scanned in 1.875 seconds (136.53 hosts/sec). 5 responded

inxi -F                                                                            ✔ 
  Host: shmuel-manjaro Kernel: 6.4.6-1-MANJARO arch: x86_64 bits: 64
    Desktop: KDE Plasma v: 5.27.6 Distro: Manjaro Linux
  Type: Desktop Mobo: ASUSTeK model: PRIME B365M-A v: Rev X.0x
    serial: <superuser required> UEFI: American Megatrends v: 2208
    date: 07/09/2021
  ID-1: hidpp_battery_0 charge: 80% condition: N/A
  Info: 8-core model: Intel Core i7-9700 bits: 64 type: MCP cache: L2: 2 MiB
  Speed (MHz): avg: 1625 min/max: 800/4700 cores: 1: 800 2: 800 3: 800
    4: 3000 5: 800 6: 3000 7: 800 8: 3000
  Device-1: Intel CoffeeLake-S GT2 [UHD Graphics 630] driver: i915 v: kernel
  Device-2: USB C Video Adaptor driver: N/A type: USB
  Device-3: Microdia USB Live camera driver: snd-usb-audio,uvcvideo
    type: USB
  Display: wayland server: v: with: Xwayland v: 23.1.2
    compositor: kwin_wayland driver: X: loaded: modesetting dri: iris gpu: i915
    resolution: 1: 1920x1080 2: 1920x1080
  API: OpenGL v: 4.6 Mesa 23.0.4 renderer: Mesa Intel UHD Graphics 630 (CFL
  Device-1: Intel 200 Series PCH HD Audio driver: snd_hda_intel
  Device-2: Microdia USB Live camera driver: snd-usb-audio,uvcvideo
    type: USB
  API: ALSA v: k6.4.6-1-MANJARO status: kernel-api
  Server-1: PulseAudio v: 16.1 status: active
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    driver: r8169
  IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: a8:5e:45:e2:87:3c
  Device-2: Realtek RTL8153 Gigabit Ethernet Adapter driver: r8152 type: USB
  IF: enp0s20f0u3u1 state: down mac: 00:e0:4c:68:51:92
  Device-1: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) driver: btusb
    type: USB
  Report: rfkill ID: hci0 state: up address: see --recommends
  Local Storage: total: 2.26 TiB used: 751.92 GiB (32.5%)
  ID-1: /dev/sda vendor: Kingston model: SA400S37480G size: 447.13 GiB
  ID-2: /dev/sdb vendor: Toshiba model: HDWD120 size: 1.82 TiB
  ID-1: / size: 63.33 GiB used: 16.24 GiB (25.6%) fs: ext4 dev: /dev/sda6
  ID-2: /boot/efi size: 96 MiB used: 25.6 MiB (26.7%) fs: vfat
    dev: /dev/sda1
  Alert: No swap data was found.
  System Temperatures: cpu: 38.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 248 Uptime: 18m Memory: total: 16 GiB available: 15.49 GiB
  used: 3.06 GiB (19.7%) Shell: Zsh inxi: 3.3.28

I solved this by installing a minimal Xfce desktop environment. The printer wizard for Xfce just works.
Then after installing the printer, I removed all the packages I installed with

sudo pacman -Rsn xfce4 xfce4-goodies xfce4-terminal network-manager-applet xfce4-notifyd xfce4-whiskermenu-plugin tumbler engrampa

Very sloppy solution, but it worked.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.