Config issue - accent colors won't stick


  1. Go to color settings
  2. Enable colors from the current wallpaper or a chosen accent color
  3. See how the color of breeze folder icons changes
  4. Close Dolphin.
  5. Open Dolphin and see that the icons reverted to default blue on Breeze.

Colors from wallpaper are not applied to Dolphin. Moreover, on icon task manager on latte dock, the Dolphin icon also reverts to blue, although for a brief moment it is colored with wallpaper color, or at least it worked in previous session, now it won’t change the color at all. The same issue is with accent color. Close/open Dolphin and see the folder’s in default blue.

I suspect some config issue, but I don’t know where colors config is. I tried defaulting Dolphin’s config, but that didn’t help.
This is a 7 years old OS install, so if config is at fault, the update mechanism failed to update existing config. In my test user, it looks as if everything worked as intended, the wallpaper’s color sticks, which strongly indicates config issue.

Where are the color’s config possibly stored or named?

5.25 Easter eggs :slight_smile:.
I saw your upstream bug report.

First some questions because it might require some activity to fix it:

  • Which Global theme/ Plasma style / Color scheme are you using? Is it default Breeze?
  • Have you tried to switch to another global theme?
  • Are you using a heavy customized desktop, many widgets, etc?
  • When right click on desktop, do you still have the options to lock and logout at the bottom of the context menu?

A few things to try first:

  • Clear cache. I guess you did that already.
  • Run command plasmashell --replace in Krunner from desktop
  • Rebuild the cache:
kbuildsycoca5 --noincremental

Try that first and perform a new logon.

cannot reproduce on my side, try using the breeze theme instead of the manjaro breath theme.

  1. I tried defaulting to Breeze global theme, and it didn’t help. Folder colors won’t survive simple Dolphin restart.
  2. Yeap, tried that many times, nothing’s help.
  3. My desktop is customized but is it heavy? It’s just mac-styled latte setup, kvantum theme, whitesur aurorae theme, that’s all. No widgets on the desktop. Again, I defaulted to Breeze and it didn’t fix it.
  4. Yes and yes.

Because this is a config issue. On my test, default user, the issue is not there, so I expect that most people won’t have it as well.

I’ll let you know how it went.


  1. Deleted .cache
  2. Defaulted to Breeze global theme
  3. Defaulted to Breeze app look.
  4. Run plasmashell --replace in krunner
  5. Re-logged and then used in krunner: kbuildsycoca5 --noincremental

The issue is still there :frowning: .


I got idea! I run systemsettings in terminal and see what is the error while applying accent color. Here it is:

qt.svg: link #path2410 is undefined!
QQmlEngine::setContextForObject(): Object already has a QQmlContext
qt.svg: link #path2410 is undefined!
qt.svg: link #path2410 is undefined!
QQmlEngine::setContextForObject(): Object already has a QQmlContext
file:///usr/lib/qt/qml/org/kde/kirigami.2/PlaceholderMessage.qml:235:5: QML Heading: Binding loop detected for property "verticalAlignment"
file:///usr/share/kpackage/kcms/kcm_colors/contents/ui/main.qml:85:13: QML ColumnLayout: Cannot anchor to an item that isn't a parent or sibling.
qml: The item SubCategoryPage_QMLTYPE_103(0x561c32aa3bf0) is already in the PageRow

I this the explanation is probably there, but I just don’t understand it.

This is not an issue with the color scheme and I knew beforehand that the suggested above wont help, because it didn’t in my case.

What probably will help is:

  • Got to System Settings > Appearance > Global Theme

  • → Click on the the Global theme you are using (I suggest to do this with Breeze stock theme)

  • → With the popup select Desktop Layout

  • → Apply

  • Be aware: This will reset all your panels and desktop settings to the theme’s default settings.

  • If you want you can also re-apply the appearance settings again. Up to you.

After applying don’t change anything back to your likening, instead logout and perform a new logon.

First thing to check after login:
Are the 2 options of lock and logout gone from the context menu on the desktop. If yes you should be good to go, accent colour should work (please try), and you can start to customize your desktop again as you like.

Hope it helps and please report if you still have troubles with accent colours!

You got me intrigued @raguse. How the desktop layout is involved in this? The same with the option Lock/Logout? Why is it bad that I have this?

Anyway, I did as you asked. Applied Breeze Desktop layout (it turned off latte and added the default panel), applied breeze appearance (everything), logged off and on.

  1. I don’t see Lock/Logout on the desktop anymore - why?
  2. The issue with folder colors is still there. I open Dolphin and see the standard blue icons. If I apply any accent colors, they change but don’t persist after Dolphin restart.

FYI: Easter egg (media) - Wikipedia

It’s been removed by KDE.

Old theme config can interfere. There were new functions implemented. Your old config in user files might not respect new functions. A reset of desktop layout rearranges your desktop-appletsrc amongst others.

Dolphin might be different story. How about if you add your home folder with it’s subfolders onto the desktop (Folder view)? Do they apply the correct accent color? Does the accent color get applied correctly in system settings and from wallpaper now?

1 Like

I just discovered, that the accent colors are correctly applied in KDE dialog windows. It’s dolphin, that is causing the issue. However, deleting the dolphinrc config is not fixing the issue :frowning: .

How do I do that? There has been a desktop setting for that in the past, but I can’t see it anymore.

As far I can tell, accent color is applied correctly in most places. Only Dolphin has the issue with it. Hmm…

We get closer to the root cause.

  • Right click on desktop > Configure Desktop and Wallpaper > Wallpaper > Layout = Folder view
  • Right click on desktop > Configure Desktop and Wallpaper > Location > ‘Places panel item = “Home” (folder)’
    You should have folders appearing on your desktop.

Note: There is still an open bug report upstream at KDE where folders with files previews do have a different color than the one selected. A way to get around this is to deactivate previews on the desktop by right click > previews=off.

There is no Home folder option there. It only defines which folder will be used as a desktop.

However, I changed the desktop to my Home temporarily and saw all of my folders with correctly applied accent color. So that confirms that the setting works for everything, aside Dolphin.

I also tried renaming dolphin configs: (dolphinrc,, the same with .local/share/dolphin/ - nothing made any changes to colors. It reverted settings and all customizations, but the blue folders stayed.

Third option in the list I meant (Znane miejsce). You got it.

Any error when running it in terminal? Also try:

dolphin --new-window 

It’s certainly a user config files. Session folder also has a dolphin file. but nothing important.

It showed this:

Shows Dolphin with colored folders!

You mean it shows the correct color? Purple?

Yes. Konsole shows:

kf.kio.core: Malformed JSON protocol file for protocol: "trash" , number of the ExtraNames fields should match the number of ExtraTypes fields

Very nice.

I don’t get this or any error when I try in konsole.
Do you have any special configuration for the trash bin? How about resetting the trash configuration in Dolphin There is a Default button in Dolphin settings. Try that. Also maybe try a new logon.

When I clicked on “Default” it reset ALL of the settings… Now I have to set it all over again… Still, the issue persists.

The error in the konsole stays as well. It suggests issue with json file. No idea which one.

This looks like you have an environment variable set. Your blue dolphin looks more like something I see on a GTK rendering. Any exec command set in dolphin.desktop? This is suspicious:

1 Like

Yes! You hit the nail! The launch was set to:

QT_STYLE_OVERRIDE=kvantum dolphin %u

I deleted override and now it launches with the accent color!

Thanks! :slight_smile:

1 Like

Excellent! Finding something like this from remote wasn’t possible without the screenshot.
Thanks also to you!
Have a great remaining day.