Computer slow and stuttering

Hi all,

System info (inxi --admin --verbosity=7 --filter --no-host --width):

  Kernel: 5.10.70-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64
  root=UUID=7377a769-35b1-49d1-b913-848b2719db51 rw quiet apparmor=1
  security=apparmor resume=UUID=4d0749e4-14fc-4a90-9d29-1a44e4ccd4c5
  udev.log_priority=3
  Desktop: KDE Plasma 5.22.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1
  dm: SDDM Distro: Manjaro Linux base: Arch Linux
Machine:
  Type: Desktop Mobo: Micro-Star model: B450 GAMING PLUS MAX (MS-7B86) v: 3.0
  serial: <filter> UEFI: American Megatrends v: H.50 date: 11/07/2019
Battery:
  Message: No system battery data found. Is one present?
Memory:
  RAM: total: 15.64 GiB used: 12.56 GiB (80.3%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges required.
CPU:
  Info: 6-Core model: AMD Ryzen 5 3600 bits: 64 type: MT MCP arch: Zen 2
  family: 17 (23) model-id: 71 (113) stepping: 0 microcode: 8701013 cache:
  L2: 3 MiB bogomips: 86433
  Speed: 2200 MHz min/max: 2200/3600 MHz boost: enabled Core speeds (MHz):
  1: 2200 2: 2200 3: 2200 4: 2200 5: 2200 6: 2200 7: 2200 8: 2200 9: 2200
  10: 2200 11: 2199 12: 2200
  Flags: 3dnowprefetch abm adx aes aperfmperf apic arat avic avx avx2 bmi1
  bmi2 bpext cat_l3 cdp_l3 clflush clflushopt clwb clzero cmov cmp_legacy
  constant_tsc cpb cpuid cqm cqm_llc cqm_mbm_local cqm_mbm_total cqm_occup_llc
  cr8_legacy cx16 cx8 de decodeassists extapic extd_apicid f16c flushbyasid
  fma fpu fsgsbase fxsr fxsr_opt ht hw_pstate ibpb ibs irperf lahf_lm lbrv lm
  mba mca mce misalignsse mmx mmxext monitor movbe msr mtrr mwaitx nonstop_tsc
  nopl npt nrip_save nx osvw overflow_recov pae pat pausefilter pclmulqdq
  pdpe1gb perfctr_core perfctr_llc perfctr_nb pfthreshold pge pni popcnt pse
  pse36 rdpid rdpru rdrand rdseed rdt_a rdtscp rep_good sep sev sev_es sha_ni
  skinit smap smca sme smep ssbd sse sse2 sse4_1 sse4_2 sse4a ssse3 stibp
  succor svm svm_lock syscall tce topoext tsc tsc_scale umip v_vmsave_vmload
  vgif vmcb_clean vme vmmcall wbnoinvd wdt xgetbv1 xsave xsavec xsaveerptr
  xsaveopt xsaves
  Vulnerabilities: Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
  mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
  mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP:
  conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590]
  vendor: XFX Pine driver: amdgpu v: kernel bus-ID: 26:00.0 chip-ID: 1002:67df
  class-ID: 0300
  Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver:
  loaded: amdgpu display-ID: :0 screens: 1
  Screen-1: 0 s-res: 2730x1680 s-dpi: 96 s-size: 720x443mm (28.3x17.4")
  s-diag: 845mm (33.3")
  Monitor-1: HDMI-A-0 res: 1680x1050 hz: 60 dpi: 87
  size: 490x320mm (19.3x12.6") diag: 585mm (23")
  Monitor-2: DVI-D-0 res: 1050x1680 hz: 60
  OpenGL: renderer: Radeon RX 580 Series (POLARIS10 DRM 3.40.0
  5.10.70-1-MANJARO LLVM 12.0.1)
  v: 4.6 Mesa 21.2.3 direct render: Yes
Audio:
  Device-1: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]
  vendor: XFX Pine driver: snd_hda_intel v: kernel bus-ID: 26:00.1
  chip-ID: 1002:aaf0 class-ID: 0403
  Device-2: AMD Starship/Matisse HD Audio vendor: Micro-Star MSI
  driver: snd_hda_intel v: kernel bus-ID: 28:00.4 chip-ID: 1022:1487
  class-ID: 0403
  Sound Server-1: ALSA v: k5.10.70-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.19 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.38 running: yes
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
  vendor: Micro-Star MSI driver: r8169 v: kernel port: f000 bus-ID: 22:00.0
  chip-ID: 10ec:8168 class-ID: 0200
  IF: enp34s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
  broadcast: <filter>
  IP v6: <filter> type: dynamic noprefixroute scope: global
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
Bluetooth:
  Message: No bluetooth data found.
Logical:
  Message: No logical block device data found.
RAID:
  Message: No RAID data found.
Drives:
  Local Storage: total: 1.93 TiB used: 595.55 GiB (30.2%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Kingston model: SA400S37120G
  size: 111.79 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
  type: SSD serial: <filter> rev: 0002 scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST2000DM008-2FR102
  size: 1.82 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
  type: HDD rpm: 7200 serial: <filter> rev: 0001 scheme: GPT
  Message: No optical or floppy data found.
Partition:
  ID-1: / raw-size: 94.28 GiB size: 92.3 GiB (97.90%) used: 38.5 GiB (41.7%)
  fs: ext4 dev: /dev/sda2 maj-min: 8:2 label: N/A
  uuid: 7377a769-35b1-49d1-b913-848b2719db51
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
  used: 312 KiB (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1 label: N/A
  uuid: CA48-5CD6
  ID-3: /home raw-size: 1.82 TiB size: 1.79 TiB (98.38%)
  used: 552.37 GiB (30.1%) fs: ext4 dev: /dev/sdb1 maj-min: 8:17 label: N/A
  uuid: 40705119-8aed-4876-bb76-87e69f368671
Swap:
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 17.21 GiB used: 4.67 GiB (27.2%)
  priority: -2 dev: /dev/sda3 maj-min: 8:3 label: N/A
  uuid: 4d0749e4-14fc-4a90-9d29-1a44e4ccd4c5
Unmounted:
  Message: No unmounted partitions found.
USB:
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 10 rev: 2.0
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 1-3:3 info: Super Top microSD card reader (SY-T18)
  type: Mass Storage driver: usb-storage interfaces: 1 rev: 2.0
  speed: 480 Mb/s power: 100mA chip-ID: 14cd:1212 class-ID: 0806
  serial: <filter>
  Hub-2: 2-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.1 speed: 10 Gb/s
  chip-ID: 1d6b:0003 class-ID: 0900
  Hub-3: 3-0:1 info: Full speed (or root) Hub ports: 4 rev: 2.0
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-4: 3-2:2 info: Terminus USB 2.0 Hub ports: 4 rev: 2.0 speed: 480 Mb/s
  power: 100mA chip-ID: 1a40:0801 class-ID: 0900
  Device-1: 3-2.2:3 info: SHARKOON USB Mouse type: Mouse,Keyboard
  driver: hid-generic,usbhid interfaces: 2 rev: 1.1 speed: 12 Mb/s
  power: 100mA chip-ID: 1ea7:0011 class-ID: 0301
  Device-2: 3-2.3:4 info: SINO WEALTH USB KEYBOARD type: Keyboard,HID
  driver: hid-generic,usbhid interfaces: 2 rev: 1.1 speed: 1.5 Mb/s
  power: 100mA chip-ID: 258a:1006 class-ID: 0300
  Hub-5: 4-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.1 speed: 10 Gb/s
  chip-ID: 1d6b:0003 class-ID: 0900
Sensors:
  System Temperatures: cpu: 49.9 C mobo: N/A gpu: amdgpu temp: 41.0 C
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 718
Info:
  Processes: 488 Uptime: 23h 30m wakeups: 0 Init: systemd v: 249
  tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: 1890
  pacman: 1853 lib: 460 flatpak: 27 snap: 10 Shell: Bash v: 5.1.8
  running-in: terminator inxi: 3.3.07

This computer should not behave like this, with a fairly recent and ok processor and RAM…

Opening KRunner takes forever (sometimes), when I start writing something there’s a long lag between typed letter and it appearing on screen or a noticeable lag when changing from one application to another - or to the menu.

Any ideas? What should I look into?
Thank you for your time,
JS

Hi @jnsantos, and welcome!

I doubt if I’ll be of assistance, but let’s at see if we can locate the resouce hog, because yes, that doesn’t sound right to me. Open a terminal and please provide the output of:

sudo ps -eo pid,ppid,cmd,%mem,%cpu --sort=-%mem | head -n 20

That should give you the 20 biggest memory hogs. Also please provide the output of:

sudo ps -eo pid,ppid,cmd,%mem,%cpu --sort=-%cpu | head -n 20

Thi8s will give the list of the 20 biggest CPU hogs.

Hi and thank you @Mirdarthos.

The result from the first string (sudo ps -eo pid,ppid,cmd,%mem,%cpu --sort=-%mem | head -n 20) is:

 PID    PPID CMD                         %MEM %CPU
   1339       1 /usr/lib/baloo_file          3.6  0.0
   2234    1354 /usr/lib/opera/opera --enab  2.8  2.1
  76662    1354 /usr/bin/texstudio           2.8  0.2
   2261    2238 /usr/lib/opera/opera --type  1.8  3.1
  58224    1354 /usr/lib/zotero/zotero-bin   1.7  0.2
   2910    2241 /usr/lib/opera/opera --type  1.7  0.3
   1348       1 /usr/bin/plasmashell         1.6  0.1
   2484    2241 /usr/lib/opera/opera --type  1.6  0.1
  60565    2241 /usr/lib/opera/opera --type  1.6  0.2
  68819    2241 /usr/lib/opera/opera --type  1.4  0.6
   3405    2241 /usr/lib/opera/opera --type  1.4  0.2
   3444    2241 /usr/lib/opera/opera --type  1.3  0.6
  79554    2241 /usr/lib/opera/opera --type  1.3  1.5
  78309    2241 /usr/lib/opera/opera --type  1.3  0.3
   2556    2241 /usr/lib/opera/opera --type  1.3  1.5
   3522    2241 /usr/lib/opera/opera --type  1.2  0.0
    893     796 /usr/lib/Xorg -nolisten tcp  1.0  0.8
  71712       1 ./firefox.real --class Tor   1.0  0.1
   2982    2241 /usr/lib/opera/opera --type  1.0  1.4

and the result from the second string (sudo ps -eo pid,ppid,cmd,%mem,%cpu --sort=-%cpu | head -n 20) is:

    PID    PPID CMD                         %MEM %CPU
   2261    2238 /usr/lib/opera/opera --type  1.8  3.1
   2234    1354 /usr/lib/opera/opera --enab  2.8  2.1
  79554    2241 /usr/lib/opera/opera --type  1.5  1.6
   2556    2241 /usr/lib/opera/opera --type  1.3  1.5
   2982    2241 /usr/lib/opera/opera --type  0.9  1.4
  56781    2241 /usr/lib/opera/opera --type  0.7  1.4
   2451    2241 /usr/lib/opera/opera --type  0.7  1.2
  65829    2241 /usr/lib/opera/opera --type  0.6  1.2
    893     796 /usr/lib/Xorg -nolisten tcp  1.0  0.8
   2409    2241 /usr/lib/opera/opera --type  0.9  0.8
  75814    2241 /usr/lib/opera/opera --type  0.7  0.8
   3444    2241 /usr/lib/opera/opera --type  1.3  0.6
  68819    2241 /usr/lib/opera/opera --type  1.3  0.6
  88950    2241 /usr/lib/opera/opera --type  0.7  0.5
   2264    2234 /usr/lib/opera/opera --type  0.3  0.4
   1258       1 /usr/bin/kwin_x11            0.8  0.3
   2910    2241 /usr/lib/opera/opera --type  1.7  0.3
  78309    2241 /usr/lib/opera/opera --type  1.3  0.3
   2407    2241 /usr/lib/opera/opera --type  0.3  0.2

This makes me wonder if my - numerous - tabs are (s)tabbing me in the back…
My only issue is that I’m doing my PhD and have 3 windows (out of… 6) with frequent stuff… But I guess I’ll have to approach this differently, somehow (bookmarks don’t seem to work well for me in terms of work approach)

That might be it, have you given another browser a try?

Also, it looks like Baloo file indexer is having a ball with your resources. I know this can sometimes be heavy on the resources, and theoretically it gets better after the initial run. I turned mine off completely. If you want to do that, run:

balooctl disable

Then do a reboot and check if it helps. If it doesn’t provide the output to those commands again.

Done @Mirdarthos and without errors.

I’ll do the reboot later since I’m finishing up some work.

Funnily enough I used to use mostly firefox but one day it started acting a bit strange and I switched to opera… I guess I need to do some sorting work on my end and post as soon as I get it done

Cool!

I use Firefox myself, and it works like a charm. If you’d like to test, you can remove the your profile and try again. Then it’ll be like freshly installed Firefox:

mv ~/.mozilla ~/.mozilla.backup

That’ll move your whole ~/.mozilla folder and there won’t be any remnants for Firefox to pick up. Or else you can just delete it:

rm -fr ~/.mozilla/

DISCLAIMER: I don’t take any responsibility for lost information, time or life.

Hi again @Mirdarthos !

Now that I closed 256 tabs (and installed a session manager) things do look a bit snappier eheheh.

Thanks for all your help! I’ll edit the 1st post to mark it as solved!

Or the official way with a click of the magic button: :wink:

https://support.mozilla.org/en-US/kb/refresh-firefox-reset-add-ons-and-settings

@jnsantos The way we mark threads solved is marking the post that solved the issue by clicking show more button and using :white_check_mark: Solution. Please do so and edit your topic title to remove [Solved].

Hi @Yochanan

Done! Sorry. I marked one as the solution but it is more like that one and the one after… (in case someone reads this someday)I had no idea about the refresh Firefox, thank you!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.