Computer-Name Recognition Issue

One of my computers (named “Catalina”) broke down a few months ago and needed extensive repairs which took 4 months. In order get it up and running, I had to do a fresh install of Manjaro-Plasma. Afterwards, I was able to get all functionality back except networking. I tried to mount 3 shared directories on Catalina to directories in my main computer (“Excalibur”), using these 3 fstab lines:

//catalina/skyport /home/aragorn/net/CA/Skyport cifs [options] 0 0
//catalina/avalon /home/aragorn/net/CA/Avalon cifs [options] 0 0
//catalina/jungle /home/aragorn/net/CA/Jungle cifs [options] 0 0

That failed with these errors:

mount error: could not resolve address for catalina: Unknown error
mount error: could not resolve address for catalina: Unknown error
mount error: could not resolve address for catalina: Unknown error

However, when I used the numeric IP (reserved in my router specifically for Catalina), it works:

//192.168.135.72/skyport /home/aragorn/net/CA/Skyport cifs [options] 0 0
//192.168.135.72/avalon /home/aragorn/net/CA/Avalon cifs [options] 0 0
//192.168.135.72/jungle /home/aragorn/net/CA/Jungle cifs [options] 0 0

So, what could make the repaired computer (Catalina) become unrecognizable-by-name? Note that my other computers (“Ketch” and “Square-Rigger”), Excalibur can recognize by name (no numeric IP needed); but Catalina it now can’t recognize and needs the numeric IP. What could cause this?

  • Catalina’s hostname resolution is failing, likely due to a DNS or network configuration issue.
  • Ensure that Catalina’s hostname is correctly set and is included in your network’s DNS or /etc/hosts file.
  • Verify that Catalina is properly registered in the router’s DNS settings and try restarting the network services.
1 Like

Yep, that was it! I looked in my router’s settings under “Connectivity/Local Network/DHCP Reservations”, and the problem computer was incorrectly named. So I fixed that, saved changes to router, changed “/etc/fstab” back to calling it “catalina” instead of numeric IP, and did “sudo systemctl daemon-reload” and now it works! Thanks!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.