Compton in Manjaro i3 not working

Hi, recently I’ve switched to Manjaro i3 and so far i have not changed anything major in it other than Polybar and Pulseaudio. But when i tried to use Compton it doesn’t work and outputs :

[ 16/10/20 14:44:16.585 c2_parse_grp ERROR ] Pattern "class_g ?= 'i3-frame'_GTK_FRAME_EXTENTS@:c" pos 21: Unexpected expression.

I had the same problem with compton and nvidia cards, I change to picom and all works fine. i’m not sure but I think compton are deprecated.

Well i tried Picom but it still doesn’t work and the output is still the same.
Thank you for the reply though ^^

Is GTK3 installed?

I am sure you removed compton and its config.
How do you start picom?
Can you share your config here because it seems like a config or startup error.

Yes, GTK3 is installed. And i start compton and picom by just typing them in the terminal because starting them from dmenu doesn’t do anything. As for the config :

Here is the i3 config :

And the compton config is :
opacity-rule = ["85:class_g= 'Termite'"];

Oke why this line in your config?

exec --no-startup-id nitrogen --restore; sleep 1; picom -b

I mean you try to run picom as a daemonize process and your starting compton by terminal?

try removing
; sleep 1; picom -b in that line

set Picom as

exec_always --no-startup-id picom --experimental-backends

Remove your compton config and picom config (or set a backup like for instance mv .config/picom.conf .config/picom.bku

Start clean by copy the default config.

cp /etc/xdg/picom.conf.example ~/.config/picom.conf

check if works.

If it works go on and edit to your liking.


Ohh, god thank you so much. That seems to do the trick ^^

You can just copy the configuration file from manjaro i3 20.1.2 ISO. The position is ~/.config/picom.conf.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.