Compositor dies often

yes that would be the best to log out and do it from tty

1 Like

apparently, I have to log into a manjaro usb as you said.

didnt the commands work?
did you tried them from tty?
if it didnt work, then boot into manjaro usb, and run the check command from there:
sudo e2fsck -p /dev/nvme0n1p7

I did try them from tty but they didn’t work.
What I did was to boot on my GParted usb stick, and from there I didn’t need to unmount I just ran

sudo e2fsck -p /dev/nvme0n1p7

It told me that I need to run the check manually so I did that by removing the -p and then it asked for permission for fixes.
Anyways I ran them but I don’t have the code I took a couple of shoots with my phone camera but it’s too much to write so I am going just to put some samples of the major codes.

sudo e2fsck -p /dev/nvme0n1p7
/dev/nvme0n1p7 contains a file system with errors, check forced.
/dev/nvme0n1p7: Inodes that were part of a corrupted orphan linked list found
                        (i.e., without -a or -p options)
user@debian: ~$ sudo e2fsck /dev/nvme0n1p7
e2fsck 1.46.2 (28-Feb-2021)
/dev/nvme0n1p7 contains a file system with errors, check forced.
Pass 1: Checking inodes, blocks, and sizes
Inodes that were part of a corrupted orphan linked list found. Fix<y>? yes
Inode 1836514 was part of the orphaned inode list. FIXED.
// it kept on doing that for a couple lot more lines
Deleted inode 1848322 has zero time. FIX<y>? yes
// a couple more lines of the same one up.
Free block count wrong for group #168 (5887,, counted=5902).
Fix<y>? yes
//couple more lines like this again.
/dev/nvme0n1p7:   ****  FILE SYSTEM WAS MODIFIED *****
/dev/nvme0n1p7: 484707/5038080 files (1.6&) non-contiguous), 10307715/20141056 blocks

And these were all the lines.

yes your home partition was corrupted …
also check the smart status of your drive … you can do it via kde partition manager, select your drive, and under device select smart and check if its in a good condition and healthy …

Yea, it shows me that the condition is good and they are healthy (I have an SSD and an HDD) both with the same conditions.

ok, and how the crashing compositor looks like? it just notifies you that it crashes?
when did it happen the last time?
go to system setting/compositor and uncheck allow application to block compositor

1 Like

Okay, so, to begin with, there is no notification that it crashed, I find out after I see that the animations are no longer there and that the glass-like feel in the theme is just black and there is no glass.
I have to go to the settings then and check the compostior then I find a message saying that kwin crashed or something I don’t really remember.
I think the last time was a week ago.
Okay unchecked that. Also, there are a couple of options like scale method and latency, etc. what should I set those to?

Doesn’t seem like it to me.

You need to install video-hybrid-amd-nvidia-470xx-prime (or latest drivers, the one without 470 in the name) from MHWD.

so in the compositor setting you can set:
scale method: smooth
latency: force smoothest animations
click apply
so now, that you unchecked the allow application to block compositor setting, just use your system normally and see if it happens again…
and you have installed the proper drivers:

My bad I thought it was the output of the command I read, didn’t see there was two commands on the same line.

Alright, done that. Thank you for helping.