Complete is not a known entry point

After this update, when I open a new terminal window, I get the following message printed:

complete is not a known entry point. Choices are: icat, list-fonts, hold, runpy, launch, open, kitten, edit-config, shebang, edit

I’ve tried to search in the .config directory to see where this could come from but I couldn’t find anything.

Any ideas how to fix it?

Check your ~/.bashrc or ~/.zshrc, apparently there’s a syntax error.


Expanding on @Yochanan’s comment…

@narimiran if you have anything like this (it was in my .bashrc, don’t know what it may be in other shells):

source <(kitty + complete setup bash)

Comment out/delete the line.

Upstream issue

I didn’t have that line, but I had:

complete -cf sudo

I’ve commented it, restarted the computer, and — there was no change, still the same problem.

I’ve investigated some more and noticed that in the .fzf/shell/completion.bash there are some instances of using the complete command.
But I don’t want to touch those as I’m afraid I might break something.

This problem has been fixed in the latest update (Feb 12th).

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.