Common_interrupt: 1.55 No irq handler for vector: Failed to start Load Kernel Modules

Hi guys, I’m having this problem when logging in, although apparently it doesn’t affect booting at all and I can log in normally and it started when I installed auto-cpufreq; To optimize the use of the battery that discharges too quickly and did not work, I uninstalled it and then installed tlp-rdw for the same and it did not work and I uninstalled it And since that comes with that error, I’ve already added a screenshot, I hope with the necessary information, it should be added that I am just a user learning to use Linux. Thank you very much in advance, I will be attentive if you need more information.

This is the error when starting the PC:

0.0043761_common_interrupt: 1.55 No irq handler for vector /dev/sda3: clean, 359565/6553600 files, 3413380/26214400 blocks
[FAILED] Failed to start Load Kernel Modules.
[FAILED) Failed to start Load Kernel Modules.
[FAILED] Failed to start Load Kernel Modules.

These are the kernels that I have installed, today download linux61 and linux66

[aaa@aaa-80e1 ~]$ mhwd-kernel -li
Currently running: 6.5.13-7-MANJARO (linux65)
The following kernels are installed in your system:
* linux61 
* linux65
* linux66

They are the ones that appear in the grub

Manjaro Linux (Kernel: 6.5.3-1-MANJARO X64)

Manjaro Linux (Kernel: 6.5.3-1-MANJARO x64 fallback initramfs)

Moderator edit: In the future, please use proper formatting: [HowTo] Post command output and file content as formatted text

Please remove it.

But you want to make sure to be booted into another kernel first.

…Wait, so you only see 6.5 ?

Please reinstall, rebuild, update grub

sudo pacman -Syu linux66
sudo mkinitcpio -P
sudo update-grub


Does 6.6 become available?

If so … please select it.

If everything works well … then proceed to remove 6.5.

sudo mhwd-kernel -r linux65

IF that does not work

sudo pacman -Rns $(pacman -Qsq linux65)
1 Like

When entering the last command to update grub I get this

[aaa@aaa-80e1 ~]$ sudo update-grub 
sudo: update-grub: command not found

Ah, it used to be default.
It is equal to

sudo grub-mkconfig -o /boot/grub/grub.cfg

(or you could install update-grub from the repos)

1 Like

Thank you very much, I was able to update the kernel and eliminate the others that I had installed, update grub and only linux66 appears but this error still appears when loading the system

0.0043761_common_interrupt: 1.55 No irq handler for vector /dev/sda3: clean, 359565/6553600 files, 3413380/26214400 blocks
[FAILED] Failed to start Load Kernel Modules.
[FAILED) Failed to start Load Kernel Modules.
[FAILED] Failed to start Load Kernel Modules.

In order to guess at what modules you should have we should get some general system information:

inxi -Fazy

We might look at mhwd too:

mhwd -li -l

If you wanted to double-check everything that has been removed recently you might check:

grep -i removed /var/log/pacman.log
1 Like

[aaa@aaa-80e1 ~]$ inxi -Fazy
  Kernel: 6.6.10-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: hpet,acpi_pm
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.6-x86_64
    root=UUID=4b699c6a-9ffc-464d-9356-038b332f2bea rw quiet apparmor=1
    security=apparmor resume=UUID=51688546-82cc-45a4-b99f-4c651475d1d5
  Desktop: i3 v: 4.23 info: i3bar vt: 7 dm: LightDM v: 1.32.0
    Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: LENOVO product: 80E1 v: Lenovo G40-45
    serial: <superuser required> Chassis: type: 10 v: Lenovo G40-45
    serial: <superuser required>
  Mobo: LENOVO model: Lancer 4B2 v: SDK0H15299 WIN
    serial: <superuser required> UEFI-[Legacy]: LENOVO v: A2CN27WW(V1.09)
    date: 12/12/2014
  ID-1: BAT1 charge: 13.6 Wh (62.4%) condition: 21.8/28.5 Wh (76.4%)
    power: 11.3 W volts: 15.3 min: 14.4 model: LENOVO PABAS0241231 type: Li-ion
    serial: <filter> status: charging
  Info: model: AMD E1-6010 APU with AMD Radeon R2 Graphics bits: 64 type: MCP
    arch: Puma level: v2 built: 2014-15 process: GF 28nm family: 0x16 (22)
    model-id: 0x30 (48) stepping: 1 microcode: 0x7030104
  Topology: cpus: 1x cores: 2 smt: <unsupported> cache: L1: 128 KiB
    desc: d-2x32 KiB; i-2x32 KiB L2: 1024 KiB desc: 1x1024 KiB
  Speed (MHz): avg: 999 high: 1000 min/max: 1000/1350 boost: disabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 998 2: 1000
    bogomips: 5392
  Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Type: gather_data_sampling status: Not affected
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed mitigation: untrained return thunk; SMT disabled
  Type: spec_rstack_overflow status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, STIBP: disabled, RSB filling,
    PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: AMD Mullins [Radeon R2 Graphics] vendor: Lenovo driver: radeon
    v: kernel alternate: amdgpu arch: GCN-2 code: Sea Islands
    process: GF/TSMC 16-28nm built: 2013-17 ports: active: eDP-1
    empty: HDMI-A-1,VGA-1 bus-ID: 00:01.0 chip-ID: 1002:9853 class-ID: 0300
  Device-2: Bison Lenovo EasyCamera driver: uvcvideo type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 2-1.2:3 chip-ID: 5986:0652
    class-ID: 0e02 serial: <filter>
  Display: x11 server: v: compositor: Picom v: git-b700a
    driver: X: loaded: radeon unloaded: modesetting alternate: fbdev,vesa
    dri: radeonsi gpu: radeon display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1366x768 s-size: <missing: xdpyinfo>
  Monitor-1: eDP-1 mapped: eDP model: LG Display 0x0455 built: 2014
    res: 1366x768 hz: 60 dpi: 112 gamma: 1.2 size: 310x174mm (12.2x6.85")
    diag: 355mm (14") ratio: 16:9 modes: max: 1366x768 min: 640x480
  API: EGL v: 1.5 hw: drv: amd radeonsi platforms: device: 0 drv: radeonsi
    device: 1 drv: swrast gbm: drv: kms_swrast surfaceless: drv: radeonsi x11:
    drv: radeonsi inactive: wayland
  API: OpenGL v: 4.5 vendor: amd mesa v: 23.3.3-manjaro1.1 glx-v: 1.4
    direct-render: yes renderer: KABINI (radeonsi LLVM 16.0.6 DRM 2.50
    6.6.10-1-MANJARO) device-ID: 1002:9853 memory: 250 MiB unified: no
  Device-1: AMD Kabini HDMI/DP Audio vendor: Lenovo driver: snd_hda_intel
    v: kernel bus-ID: 00:01.1 chip-ID: 1002:9840 class-ID: 0403
  Device-2: AMD FCH Azalia vendor: Lenovo driver: snd_hda_intel v: kernel
    bus-ID: 00:14.2 chip-ID: 1022:780d class-ID: 0403
  API: ALSA v: k6.6.10-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PulseAudio v: 16.1 status: active with: pulseaudio-alsa
    type: plugin tools: pacat,pactl,pavucontrol
  Device-1: Qualcomm Atheros QCA6164 802.11ac Wireless Network Adapter
    vendor: Lenovo driver: ath10k_pci v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 bus-ID: 01:00.0 chip-ID: 168c:0041 class-ID: 0280
  IF: wlp1s0 state: up mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Lenovo driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1
    port: 2000 bus-ID: 02:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp2s0 state: down mac: <filter>
  Device-1: Qualcomm Atheros QCA61x4 Bluetooth 4.0 driver: btusb v: 0.8
    type: USB rev: 1.1 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 2-1.3:4
    chip-ID: 0cf3:e300 class-ID: e001
  Report: btmgmt ID: hci0 rfk-id: 2 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: <filter> bt-v: 4.1 lmp-v: 7
    status: discoverable: no pairing: no
  Local Storage: total: 465.76 GiB used: 12.27 GiB (2.6%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital
    model: WD5000LPCX-24C6HT0 size: 465.76 GiB block-size: physical: 4096 B
    logical: 512 B speed: 6.0 Gb/s tech: HDD rpm: 5400 serial: <filter>
    fw-rev: 1A02 scheme: GPT
  ID-1: / raw-size: 100 GiB size: 97.87 GiB (97.87%) used: 10.52 GiB (10.7%)
    fs: ext4 dev: /dev/sda3 maj-min: 8:3
  ID-2: /home raw-size: 357.75 GiB size: 351.06 GiB (98.13%)
    used: 1.75 GiB (0.5%) fs: ext4 dev: /dev/sda4 maj-min: 8:4
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) zswap: yes
    compressor: zstd max-pool: 20%
  ID-1: swap-1 type: file size: 512 MiB used: 0 KiB (0.0%) priority: -2
    file: /swapfile
  ID-2: swap-2 type: partition size: 8 GiB used: 0 KiB (0.0%) priority: -3
    dev: /dev/sda1 maj-min: 8:1
  System Temperatures: cpu: 51.2 C mobo: N/A gpu: radeon temp: 51.0 C
  Fan Speeds (rpm): N/A
  Processes: 158 Uptime: 14m wakeups: 0 Memory: total: 3 GiB note: est.
  available: 2.63 GiB used: 1.49 GiB (56.7%) Init: systemd v: 255
  default: graphical tool: systemctl Compilers: gcc: 13.2.1 clang: 16.0.6
  Packages: pm: pacman pkgs: 1078 libs: 304 tools: pamac,yay Shell: Bash
  v: 5.2.21 running-in: urxvtd inxi: 3.3.31
[aaa@aaa-80e1 ~]$ mhwd -li -l
> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
           video-linux            2018.05.04                true            PCI

Warning: No installed USB configs!
> 0000:02:00.0 (0200:10ec:8168) Network controller Realtek Semiconductor Co., Ltd.:
                  NAME               VERSION          FREEDRIVER           TYPE
         network-r8168            2023.09.12                true            PCI

> 0000:00:01.0 (0300:1002:9853) Display controller ATI Technologies Inc:
                  NAME               VERSION          FREEDRIVER           TYPE
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI

[aaa@aaa-80e1 ~]$ grep -i removed /var/log/pacman.log
[2024-01-09T22:37:23-0500] [ALPM] removed intel-ucode (20230808-1)
[2024-01-09T23:13:08-0500] [ALPM] removed kwindowsystem (5.110.0-1)
[2024-01-09T23:13:09-0500] [ALPM] removed kitemmodels (5.110.0-1)
[2024-01-09T23:13:09-0500] [ALPM] removed kauth (5.110.0-1)
[2024-01-09T23:13:09-0500] [ALPM] removed kcoreaddons (5.110.0-1)
[2024-01-09T23:27:03-0500] [ALPM] removed palemoon (32.5.2-1)
[2024-01-13T23:43:09-0500] [ALPM] removed onevpl (2023.4.0-1)
[2024-01-14T13:01:01-0500] [ALPM] removed xfce4-cpufreq-plugin (1.2.8-1)
[2024-01-14T14:29:55-0500] [ALPM] removed python-poetry-dynamic-versioning (1.2.0-1)
[2024-01-14T14:29:55-0500] [ALPM] removed python-poetry (1.7.1-1)
[2024-01-14T14:29:56-0500] [ALPM] removed python-virtualenv (20.25.0-1)
[2024-01-14T14:29:56-0500] [ALPM] removed python-distlib (0.3.8-1)
[2024-01-14T14:29:56-0500] [ALPM] removed python-shellingham (1.5.0.post1-4)
[2024-01-14T14:29:56-0500] [ALPM] removed python-requests-toolbelt (1.0.0-1)
[2024-01-14T14:29:56-0500] [ALPM] removed python-poetry-plugin-export (1.5.0-1)
[2024-01-14T14:29:56-0500] [ALPM] removed python-pkginfo (1.9.6-2)
[2024-01-14T14:29:56-0500] [ALPM] removed python-pexpect (4.9.0-1)
[2024-01-14T14:29:56-0500] [ALPM] removed python-ptyprocess (0.7.0-5)
[2024-01-14T14:29:56-0500] [ALPM] removed python-lockfile (0.12.2-12)
[2024-01-14T14:29:56-0500] [ALPM] removed python-keyring (24.3.0-1)
[2024-01-14T14:29:56-0500] [ALPM] removed python-secretstorage (3.3.3-2)
[2024-01-14T14:29:56-0500] [ALPM] removed python-jeepney (0.8.0-2)
[2024-01-14T14:29:56-0500] [ALPM] removed python-jaraco.classes (3.3.0-1)
[2024-01-14T14:29:56-0500] [ALPM] removed python-importlib-metadata (5.0.0-5)
[2024-01-14T14:29:56-0500] [ALPM] removed python-zipp (3.17.0-1)
[2024-01-14T14:29:56-0500] [ALPM] removed python-jsonschema (4.20.0-1)
[2024-01-14T14:29:56-0500] [ALPM] removed python-pyrsistent (0.19.3-3)
[2024-01-14T14:29:56-0500] [ALPM] removed python-jsonschema-specifications (2023.12.1-1)
[2024-01-14T14:29:56-0500] [ALPM] removed python-referencing (0.32.0-1)
[2024-01-14T14:29:56-0500] [ALPM] removed python-rpds-py (0.15.2-1)
[2024-01-14T14:29:56-0500] [ALPM] removed python-html5lib (1.1-13)
[2024-01-14T14:29:56-0500] [ALPM] removed python-webencodings (0.5.1-10)
[2024-01-14T14:29:56-0500] [ALPM] removed python-dulwich (0.21.7-1)
[2024-01-14T14:29:56-0500] [ALPM] removed python-cachy (0.3.0-9)
[2024-01-14T14:29:56-0500] [ALPM] removed python-cachecontrol (1:0.13.1-1)
[2024-01-14T14:29:56-0500] [ALPM] removed python-msgpack (1.0.5-1)
[2024-01-14T14:29:56-0500] [ALPM] removed python-filelock (3.13.1-1)
[2024-01-14T14:29:57-0500] [ALPM] removed python-tomlkit (0.12.3-1)
[2024-01-14T14:29:57-0500] [ALPM] removed python-jinja (1:3.1.2-4)
[2024-01-14T14:29:57-0500] [ALPM] removed python-dunamai (1.18.0-1)
[2024-01-14T14:29:57-0500] [ALPM] removed python-cleo (2.1.0-1)
[2024-01-14T14:29:57-0500] [ALPM] removed python-rapidfuzz (3.6.0-1)
[2024-01-14T14:29:57-0500] [ALPM] removed python-crashtest (0.4.1-2)
[2024-01-14T14:29:57-0500] [ALPM] removed python-poetry-core (1.8.1-2)
[2024-01-14T14:29:57-0500] [ALPM] removed python-lark-parser (1.1.8-1)
[2024-01-14T14:29:57-0500] [ALPM] removed python-wheel (0.42.0-1)
[2024-01-14T14:29:57-0500] [ALPM] removed python-installer (0.7.0-3)
[2024-01-14T14:29:57-0500] [ALPM] removed python-build (1.0.3-1)
[2024-01-14T14:29:57-0500] [ALPM] removed python-pyproject-hooks (1.0.0-5)
[2024-01-14T15:24:42-0500] [ALPM] removed auto-cpufreq (2.1.0-4)
[2024-01-15T19:51:14-0500] [ALPM] removed tlpui (1.6.1-1)
[2024-01-15T19:51:36-0500] [ALPM] removed tlp (1.6.1-1)
[2024-01-16T15:09:58-0500] [ALPM] removed linux419-tp_smapi (0.44-11)
[2024-01-16T15:10:31-0500] [ALPM] removed linux419 (4.19.304-1)
[2024-01-16T20:59:13-0500] [ALPM] removed linux65-tp_smapi (0.44-27)
[2024-01-16T20:59:45-0500] [ALPM] removed linux65 (6.5.13-7)
[2024-01-16T21:09:58-0500] [ALPM] removed linux61-tp_smapi (0.44-22)
[2024-01-16T21:10:23-0500] [ALPM] removed linux61 (6.1.71-1)
[aaa@aaa-80e1 ~]$ 

Now lets look at module places:

ls /usr/lib/modules-load.d
grep -E '^MODULES|^HOOKS' /etc/mkinitcpio.conf


You have 2 SWAP devices.
1 is a reasonably sized partition … the other is a rather small 512mb swapfile.

1 Like
[aaa@aaa-80e1 ~]$ ls /usr/lib/modules-load.d
bluez.conf  linux66-tp_smapi.conf
[aaa@aaa-80e1 ~]$ grep -E '^MODULES|^HOOKS' /etc/mkinitcpio.conf
HOOKS="base udev autodetect modconf block keyboard keymap consolefont resume filesystems fsck"


You have 2 SWAP devices.
1 is a reasonably sized partition … the other is a rather small 512mb swapfile.

I believe the 8 GiB one, the other partition, I don’t know where it came from, how can I correct this or does it not affect anything?

The only thing I could think of it doing would be to create some sort of bottleneck because of the small size of one of the SWAPs.
To get rid of the swapfile you can just disable and delete it;

sudo swapoff /swapfile
sudo rm -f /swapfile

Oh … ok … do you still have a tp_smapi package installed?
For 6.6, linux66-tp_smapi ?

From what I can find here:

I am not sure your machine is supported.

If you do have the package … please try removing it.
(this should also result in the related conf file at /usr/lib/modules-load.d being removed)

If you dont still have that package then that file should definitely not be there.

Lastly we can force-reinstall the open driver profile

sudo mhwd -f -i pci video-linux

We can do the rebuild thing again too;

sudo mkinitcpio -P
sudo grub-mkconfig -o /boot/grub/grub.cfg


I noticed another thing.

Its an older machine … but it does have missing BIOS updates.
If my search is correct

1 Like

I already deactivated swap and the file /usr/lib/modules-load.d cannot be removed, it says that it does not exist and it appears there, what should I do in this case?
I’m going to proceed with this:

If it is true, the machine needs a BIOS update.

On the other hand, I am just starting out in this world of Linux, all I have done is watch videos and research, what do you recommend to do inappropriate things that could generate more errors?

And on the other hand, the battery discharges too quickly more than when I had Windows. I don’t know if you can help me with this. I would be very grateful and sorry for the inconvenience, a warm hug for your kindness.

That path as written is a directory.
We were talking about the file located there. Full path:


If I understand you correctly … you are asking how these error occurred?
In this case I think it may have just been the installation of an incompatible package (currently linux66-tp_smapi)

At least for this message I believe that is the case

Failed to start Load Kernel Modules.

And that is why I was looking at that path above.

The other one is likely an unimportant message

No irq handler for vector

It may even be related to the old BIOS, but it may also mean nothing.
See related threads like this Arch one:

Look here at the file and the failed attempts to delete it, I don’t know if you can help me.

I don’t know that I have never noticed it as an error, I will investigate how to update the bios to see if that is what it is

You are mixing command syntax.

To remove the package

sudo pacman -Rns linux66-tp_smapi

To remove the file it would have been
sudo rm /usr/lib/modules-load.d/linux66-tp_smapi.conf
But you should not need to do that if its not there, which should happen after removing the package.

Some more explanation:

  • pacman is a command, a package manager
  • rm is a different command, to remove files and directories
  • sudo is yet another command that allows running things as a different user, by default root, so in this case we have been prepending it to the above commands to be allowed to run them
1 Like

Thank you very much, I’m going to restart to see if that error no longer appears, and I ask you if you can help me install a battery manager that drains very quickly or should I make another post for this case, thank you very much, I’ll tell you yes it worked

I was making you a graphic :sweat_smile:

Which wasnt supposed to be 100% nerd accurate, but instructive for what we were doing;

(again sudo is really for running things as another user in general, but it defaults to root and is largely used for admin purposes)

Youre welcome. :hugs:

I think a new thread for the battery performance and/or power-saving makes sense.


Yes, it was solved, thank you very much, I have no idea how that got there, it must have been when I downloaded auto-cpufreq or tlp tlpui but it is already solved, thank you very much for your collaboration

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.