Comment configurer fstab pour accéder à des partages réseau?

Bonjour à tous,
Venant du monde Windows et ayant décidé de le quitter, j’ai installé Manjaro en mode ‘Deepin’.
Fonctionnement en local impeccable.
C’est l’accès à mon serveur qui me pose problème.
Via le gestionnaire de fichier, aucun souci. A part que je doive monter mes partages à chaque démarrage.
Problème que fstab est sensé m’aider à régler.
Actuellement il contient la commande suivante :

//<serveur>/3d /media/serveurs/ne_3d cifs auto,user=<utilisateur>password=<mdp>,defaults 0 0

Au démarrage, j’ai les messages suivants:

Failed    : Failed to mount /media/serveurs/ne_3d
Depend : Dependencies failed for Remote File System

Comme je suis nouveau sous Linux, j’ai essayé avec avec l’adresse IP: même résultat.
Les répertoires ‘serveurs’ et ‘ne_3d’ sont bien présent.
J’ai essayé la commande ‘mount’ en mode terminal, ça marche impec. Je me suis donc résolu à vous demander votre aide.
Merci à tous.

Probablement tes disques réseau ne sont pas prets quand ça essaye de les monter au boot.

Il faut surement utiliser une autre méthode que fstab, par exemple systemd [root tip] systemd mount unit samples

bonjour et bienvenue

voir le wiki arch

auto est redondant car déjà inclus dans defaults.

Le problème vient peut-être du fait que le partage mette trop de temps à répondre pour le montage automatique. Parmi les options qui peuvent te permettre d’avancer:

  • noauto : permet de définir le montage sans avoir à le monter automatiquement, ça te permet de le monter plus tard
  • nofail : par défaut, un échec de montage via fstab est fatal ; avec cette option, tu dis au système qu’il peut continuer à démarrer même si le montage échoue, tu pourras toujours le monter ultérieurement

Pour l’anecdote, j’ai une partition de backup pour laquelle je dois préciser nofail parce qu’elle est un poil trop lent à se monter. Pourtant, une fois la session utilisateur ouverte, la partition est bien montée. :man_shrugging:


Bonus vu que tu n’en as pas fait mention : tu peux tester ta configuration fstab sans avoir à redémarrer, simplement avec mount -a.

Merci à tous,
Sympa de m’avoir accordé un peu de votre temps.
Même si c’est la réponse de maycne.sonahoz (nofail) qui a résolu mon problème, les essais des différentes réponses m’ont permis d’apprendre plein de trucs et à mieux appréhender Linux.
Encore merci!!

1 Like