Command execution instead of user manual output


Recently I tried one of Live CDs and realized that the
manjaro-live -h
manjaro-live --help
commands are immediately executes and modifying system state.

I think it is unexpected and sort of malware behavior, please review and fix.

I didn’t get details of package version and ISO image. If you want that additional pointers, let me know, I will collect that info and post it.


The manjaro-live tool does not have any help instructions. And it’s not meant for users to run manually.

I tried to figure out that is it by
man manjaro-live
but is was empty
and than tried to see manual via --help but got it’s execution.

Is it a user expected behavior as should be: to try to learn and to get an execution with system state modifications?

As I said, it’s not meant for a user to manually run.

It’s run by the system when it boots (I believe).

1 Like

Again, I report the issue while tried to figure out what is this: instead of expected manual output (or it absence) got an execution with modifications.

  1. If it is not right learning method, than could I ask another comfortable and fast method?
  2. What about a such fastest method during live cd session, where all stuff are by default?

If it is not right method to learn what command is and it’s settings, than all --help are wrong also.

If that learn method is right, than the manjaro-live have the pointed issue.
Enter your choice:

Not every executable in the system has a man page or a built-in help option.

man pages are for tools that can be executed via the command line without needing a GUI, and help options are at the discretion of the developer of each executable ─ it is up to them whether or not the executable will support it.

1 Like

agree, but before that stuff I never saw execution with modifications caused by --help

Oh, man. All developers has guide lines, styles how to design good apps. The --help is one of them.

It is about the choice:

  1. or --help is wrong learning method and most of apps with that functionality contains that junk
  2. or manjaro-live has the issue

Nothing third.

The --help option did not cause any “modifications” ─ whatever you mean by that. It is simply not a supported command line option on the manjaro-live executable, because said executable is ─ as @Strit said ─ intended to be run when the live USB/CD/DVD boots; it is not intended to be invoked manually.

here is that with --help execution:

If you need more details about which ISO it was and the package version, I can collect that info, just let me know.

I thought that both @Strit and I had been clear; the executable manjaro-live does not have a help option, because it is not intended to be run by a user.

In other words, what you are complaining about is completely irrelevant and stems from your lack of understanding the system.

This thread is going nowhere, so I’m closing it. :roll_eyes:

1 Like