Comet Lake PCH-LP cAVS sound card not detected after latest update

After updating manjaro a few days ago the sound card is not detected anymore. It was working fine before. Bluetooth headset and external webcam mic are working fine. I have tried to downgrade pipewire from 0.3.38 to 0.3.35 but nothing changed.

Output of inxi

System:
  Kernel: 5.10.70-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64 
  root=UUID=e5abb127-ddc9-428a-92ee-060744e41918 rw quiet apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: KDE Plasma 5.22.5 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM 
  Distro: Manjaro Linux base: Arch Linux 
Machine:
  Type: Laptop System: HP product: HP EliteBook 850 G7 Notebook PC v: N/A 
  serial: <filter> Chassis: type: 10 serial: <filter> 
  Mobo: HP model: 8724 v: KBC Version 06.37.00 serial: <filter> UEFI: HP 
  v: S73 Ver. 01.03.02 date: 11/04/2020 
Battery:
  ID-1: BAT0 charge: 52.3 Wh (100.0%) condition: 52.3/56.3 Wh (93.0%) 
  volts: 12.8 min: 11.6 model: Hewlett-Packard Primary type: Li-ion 
  serial: <filter> status: Full cycles: 44 
Memory:
  RAM: total: 15.41 GiB used: 6.81 GiB (44.2%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
CPU:
  Info: Quad Core model: Intel Core i7-10510U bits: 64 type: MT MCP 
  arch: Kaby Lake note: check family: 6 model-id: 8E (142) stepping: C (12) 
  microcode: EA cache: L2: 8 MiB bogomips: 36812 
  Speed: 800 MHz min/max: 400/4900 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 
  4: 800 5: 800 6: 800 7: 800 8: 800 
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_capabilities 
  arch_perfmon art avx avx2 bmi1 bmi2 bts clflush clflushopt cmov constant_tsc 
  cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms 
  est f16c flexpriority flush_l1d fma fpu fsgsbase fxsr ht hwp hwp_act_window 
  hwp_epp hwp_notify ibpb ibrs ibrs_enhanced ida intel_pt invpcid 
  invpcid_single lahf_lm lm mca mce md_clear mmx monitor movbe mpx msr mtrr 
  nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni 
  popcnt pse pse36 pts rdrand rdseed rdtscp rep_good sdbg sep smap smep ss 
  ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc 
  tsc_adjust tsc_deadline_timer vme vmx vnmi vpid x2apic xgetbv1 xsave xsavec 
  xsaveopt xsaves xtopology xtpr 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling 
  Type: srbds mitigation: TSX disabled 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: Intel CometLake-U GT2 [UHD Graphics] vendor: Hewlett-Packard 
  driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:9b41 class-ID: 0300 
  Device-2: Luxvisions Innotech Limited HP HD Camera type: USB 
  driver: uvcvideo bus-ID: 1-2:2 chip-ID: 30c9:000f class-ID: 0e02 
  serial: <filter> 
  Device-3: Logitech Webcam C270 type: USB driver: snd-usb-audio,uvcvideo 
  bus-ID: 1-4.3:11 chip-ID: 046d:0825 class-ID: 0102 serial: <filter> 
  Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: 
  loaded: modesetting alternate: fbdev,vesa display-ID: :0 screens: 1 
  Screen-1: 0 s-res: 3840x1080 s-dpi: 96 s-size: 1016x285mm (40.0x11.2") 
  s-diag: 1055mm (41.5") 
  Monitor-1: eDP-1 res: 1920x1080 hz: 60 dpi: 142 size: 344x194mm (13.5x7.6") 
  diag: 395mm (15.5") 
  Monitor-2: HDMI-1 res: 1920x1080 dpi: 93 size: 527x296mm (20.7x11.7") 
  diag: 604mm (23.8") 
  OpenGL: renderer: Mesa Intel UHD Graphics (CML GT2) v: 4.6 Mesa 21.2.3 
  direct render: Yes 
Audio:
  Device-1: Intel Comet Lake PCH-LP cAVS vendor: Hewlett-Packard 
  driver: sof-audio-pci alternate: snd_hda_intel,snd_soc_skl,snd_sof_pci 
  bus-ID: 00:1f.3 chip-ID: 8086:02c8 class-ID: 0401 
  Device-2: Logitech Webcam C270 type: USB driver: snd-usb-audio,uvcvideo 
  bus-ID: 1-4.3:11 chip-ID: 046d:0825 class-ID: 0102 serial: <filter> 
  Sound Server-1: ALSA v: k5.10.70-1-MANJARO running: yes 
  Sound Server-2: JACK v: 1.9.19 running: no 
  Sound Server-3: PulseAudio v: 15.0 running: no 
  Sound Server-4: PipeWire v: 0.3.35 running: yes 
Network:
  Device-1: Intel Comet Lake PCH-LP CNVi WiFi driver: iwlwifi v: kernel 
  port: 3000 bus-ID: 00:14.3 chip-ID: 8086:02f0 class-ID: 0280 
  IF: wlp0s20f3 state: up mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: noprefixroute scope: link 
  IF-ID-1: vboxnet0 state: down mac: <filter> 
  IF-ID-2: vboxnet1 state: down mac: <filter> 
  IP v4: <filter> scope: global broadcast: <filter> 
  IP v6: <filter> scope: link 
  IF-ID-3: vboxnet2 state: down mac: <filter> 
  IF-ID-4: vboxnet3 state: down mac: <filter> 
  IF-ID-5: vboxnet4 state: down mac: <filter> 
  IF-ID-6: virbr0 state: down mac: <filter> 
  IP v4: <filter> scope: global broadcast: <filter> 
  WAN IP: <filter> 
Bluetooth:
  Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8 
  bus-ID: 1-10:6 chip-ID: 8087:0026 class-ID: e001 
  Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends 
Logical:
  Message: Unable to run lvs. Root privileges required. 
RAID:
  Message: No RAID data found. 
Drives:
  Local Storage: total: 476.94 GiB used: 103.88 GiB (21.8%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Intel model: SSDPEKNW512G8H 
  size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s 
  lanes: 4 type: SSD serial: <filter> rev: HPS1 temp: 29.9 C scheme: GPT 
  Message: No optical or floppy data found. 
Partition:
  ID-1: / raw-size: 120 GiB size: 117.56 GiB (97.97%) used: 47.15 GiB (40.1%) 
  fs: ext4 dev: /dev/nvme0n1p6 maj-min: 259:6 label: N/A 
  uuid: e5abb127-ddc9-428a-92ee-060744e41918 
  ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%) 
  used: 90.2 MiB (35.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1 
  label: SYSTEM uuid: 5EB5-0094 
  ID-3: /media/dataHD raw-size: 212.99 GiB size: 208.59 GiB (97.93%) 
  used: 56.64 GiB (27.2%) fs: ext4 dev: /dev/dm-1 maj-min: 254:1 
  mapped: _dev_dm_0 label: N/A uuid: N/A 
Swap:
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 8 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/nvme0n1p5 maj-min: 259:5 label: N/A 
  uuid: ac04ceed-2cab-413e-bc71-0fed9ce40c64 
Unmounted:
  ID-1: /dev/nvme0n1p2 maj-min: 259:2 size: 16 MiB fs: <superuser required> 
  label: N/A uuid: N/A 
  ID-2: /dev/nvme0n1p3 maj-min: 259:3 size: 74.95 GiB fs: bitlocker label: N/A 
  uuid: N/A 
  ID-3: /dev/nvme0n1p4 maj-min: 259:4 size: 740 MiB fs: ntfs 
  label: Windows RE Tools uuid: 1AA051E9A051CC3F 
USB:
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 12 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Device-1: 1-2:2 info: Luxvisions Innotech Limited HP HD Camera type: Video 
  driver: uvcvideo interfaces: 4 rev: 2.0 speed: 480 Mb/s power: 500mA 
  chip-ID: 30c9:000f class-ID: 0e02 serial: <filter> 
  Hub-2: 1-4:9 info: Texas Instruments ports: 4 rev: 2.1 speed: 480 Mb/s 
  chip-ID: 0451:8044 class-ID: 0900 
  Device-1: 1-4.1:10 info: Logitech Unifying Receiver type: Keyboard,Mouse 
  driver: logitech-djreceiver,usbhid interfaces: 2 rev: 2.0 speed: 12 Mb/s 
  power: 98mA chip-ID: 046d:c534 class-ID: 0301 
  Device-2: 1-4.3:11 info: Logitech Webcam C270 type: Video,Audio 
  driver: snd-usb-audio,uvcvideo interfaces: 4 rev: 2.0 speed: 480 Mb/s 
  power: 500mA chip-ID: 046d:0825 class-ID: 0102 serial: <filter> 
  Device-3: 1-4.4:12 info: Apple Aluminium Keyboard (ANSI) type: Keyboard,HID 
  driver: apple,usbhid interfaces: 2 rev: 1.1 speed: 12 Mb/s power: 500mA 
  chip-ID: 05ac:024f class-ID: 0300 
  Device-4: 1-7:4 info: Synaptics type: <vendor specific> driver: N/A 
  interfaces: 1 rev: 2.0 speed: 12 Mb/s power: 100mA chip-ID: 06cb:00df 
  class-ID: ff00 serial: <filter> 
  Device-5: 1-10:6 info: Intel AX201 Bluetooth type: Bluetooth driver: btusb 
  interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA chip-ID: 8087:0026 
  class-ID: e001 
  Hub-3: 2-0:1 info: Full speed (or root) Hub ports: 6 rev: 3.1 speed: 10 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
  Hub-4: 2-1:3 info: Texas Instruments ports: 4 rev: 3.0 speed: 5 Gb/s 
  chip-ID: 0451:8046 class-ID: 0900 
  Hub-5: 3-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Hub-6: 4-0:1 info: Full speed (or root) Hub ports: 2 rev: 3.1 speed: 10 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
Sensors:
  System Temperatures: cpu: 38.0 C mobo: 25.0 C 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 357 Uptime: 1d 30m wakeups: 65 Init: systemd v: 249 
  tool: systemctl Compilers: gcc: 11.1.0 Packages: pacman: 1660 lib: 379 
  flatpak: 0 Shell: Zsh v: 5.8 running-in: yakuake inxi: 3.3.06 

Output of pactl list cards

        Name: alsa_card.usb-046d_0825_CE413E40-02
        Driver: alsa
        Owner Module: n/a
        Properties:
                device.enum.api = "udev"
                device.api = "alsa"
                media.class = "Audio/Device"
                api.alsa.path = "hw:0"
                api.alsa.card = "0"
                api.alsa.card.name = "USB Device 0x46d:0x825"
                api.alsa.card.longname = "USB Device 0x46d:0x825 at usb-0000:00:14.0-4.3, high speed"
                device.plugged.usec = "5837647"
                device.bus_path = "pci-0000:00:14.0-usb-0:4.3:1.2"
                device.sysfs.path = "/sys/devices/pci0000:00/0000:00:14.0/usb1/1-4/1-4.3/1-4.3:1.2/sound/card0"
                device.bus-id = "usb-046d_0825_CE413E40-02"
                device.bus = "usb"
                device.subsystem = "sound"
                device.vendor.id = "1133"
                device.vendor.name = "Logitech, Inc."
                device.product.id = "2085"
                device.product.name = "Webcam C270"
                device.serial = "046d_0825_CE413E40"
                device.form_factor = "webcam"
                device.name = "alsa_card.usb-046d_0825_CE413E40-02"
                device.description = "Webcam C270"
                device.nick = "USB Device 0x46d:0x825"
                device.icon_name = "camera-web-usb"
                api.alsa.use-acp = "true"
                api.acp.auto-profile = "false"
                api.acp.auto-port = "false"
                api.dbus.ReserveDevice1 = "Audio0"
                factory.id = "14"
                client.id = "31"
                object.id = "44"
                object.path = "alsa:pcm:0"
                alsa.card = "0"
                alsa.card_name = "USB Device 0x46d:0x825"
                alsa.long_card_name = "USB Device 0x46d:0x825 at usb-0000:00:14.0-4.3, high speed"
                alsa.driver_name = "snd_usb_audio"
                device.string = "0"
        Profiles:
                off: Off (sinks: 0, sources: 0, priority: 0, available: yes)
                pro-audio: Pro Audio (sinks: 0, sources: 1, priority: 1, available: yes)
                input:mono-fallback: Mono Input (sinks: 0, sources: 1, priority: 1, available: yes)
        Active Profile: input:mono-fallback
        Ports:
                analog-input-mic: Microphone (type: Mic, priority: 8700, latency offset: 0 usec, availability unknown)
                        Properties:
                                port.type = "mic"
                                device.icon_name = "audio-input-microphone"
                                card.profile.port = "0"
                        Part of profile(s): input:mono-fallback

Empty output for pactl list sinks

EDIT:
The sound card is working in windows

Installing sof-firmware solves the problem