Combi menu freezes out keyboard at random

Hi, this is for Sway on x86_64. I haven’t used ARM lately.

Since the 12-10-2021 Stable update to Sway, I’ve had a weird symptom on two different installs (internal disk and SD card, same machine). When I pop up the combi menu with $mod+d, the system becomes unresponsive to the keyboard, in or out of the menu, except for the $mod+shift+e reboot combination. The cursor and some buttons are still responsive to the mouse (for example, waybar buttons, the eject button for an external drive mounted in Thunar), but this does not go as far as Thunar menu displays.

Here’s my inxi when things are working normally:

  Kernel: 5.15.6-2-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
  root=UUID=57638ca8-527e-47cf-a70c-32258df32871 rw quiet apparmor=1
  security=apparmor udev.log_priority=3 ipv6.disable=1
  Desktop: sway 1.6.1 vt: 2 dm: N/A Distro: Manjaro Linux base: Arch Linux
  Type: Mini-pc System: IP3 Tech product: TX95 v: N/A
  serial: <superuser required>
  Mobo: IP3 model: AB1A serial: <superuser required> UEFI: American Megatrends
  v: 0.02 date: 06/30/2020
  RAM: total: 7.62 GiB used: 1.58 GiB (20.8%)
  RAM Report:
  missing: Required tool dmidecode not installed. Check --recommends
  Info: Quad Core model: Intel Celeron N3450 bits: 64 type: MCP arch: Goldmont
  family: 6 model-id: 5C (92) stepping: 9 microcode: 44 cache: L1: 224 KiB
  L2: 4 MiB bogomips: 8756
  Speed: 1461 MHz min/max: 800/2200 MHz Core speeds (MHz): 1: 1820 2: 2087
  3: 1630 4: 1865
  Flags: 3dnowprefetch acpi aes aperfmperf apic arat arch_capabilities
  arch_perfmon art bts cat_l2 clflush clflushopt cmov constant_tsc cpuid
  cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts ept ept_ad erms est
  flexpriority fpu fsgsbase fxsr ht ibpb ibrs ida intel_pt lahf_lm lm mca mce
  md_clear mmx movbe mpx msr mtrr nonstop_tsc nopl nx pae pat pbe pclmulqdq
  pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pts rdrand rdseed rdt_a
  rdtscp rep_good sdbg sep sha_ni smap smep ss sse sse2 sse4_1 sse4_2 ssse3
  stibp syscall tm tm2 tpr_shadow tsc tsc_adjust tsc_deadline_timer
  tsc_known_freq tsc_reliable vme vmx vnmi vpid x2apic xgetbv1 xsave xsavec
  xsaveopt xsaves xtopology xtpr
  Vulnerabilities: Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass status: Not affected
  Type: spectre_v1
  mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
  IBRS_FW, STIBP: disabled, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel HD Graphics 500 driver: i915 v: kernel bus-ID: 00:02.0
  chip-ID: 8086:5a85 class-ID: 0300
  Display: wayland server: N/A compositor: sway v: 1.6.1 driver: loaded: i915
  note: n/a (using device driver) display-ID: 1
  resolution: <missing: xdpyinfo>
  Message: Unable to show advanced data. Required tool glxinfo missing.
  Device-1: Intel Celeron N3350/Pentium N4200/Atom E3900 Series Audio Cluster
  driver: snd_hda_intel v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_apl
  bus-ID: 00:0e.0 chip-ID: 8086:5a98 class-ID: 0403
  Sound Server-1: ALSA v: k5.15.6-2-MANJARO running: yes
  Sound Server-2: sndio v: N/A running: no
  Sound Server-3: JACK v: 1.9.19 running: no
  Sound Server-4: PulseAudio v: 15.0 running: no
  Sound Server-5: PipeWire v: 0.3.40 running: yes
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
  driver: r8169 v: kernel port: e000 bus-ID: 01:00.0 chip-ID: 10ec:8168
  class-ID: 0200
  IF: enp1s0 state: down mac: <filter>
  Device-2: Intel Wireless 3165 driver: iwlwifi v: kernel bus-ID: 02:00.0
  chip-ID: 8086:3165 class-ID: 0280
  IF: wlp2s0 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
  broadcast: <filter>
  IF-ID-1: nordlynx state: unknown speed: N/A duplex: N/A mac: N/A
  IP v4: <filter> scope: global
  WAN IP: <filter>
  Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8
  bus-ID: 1-7:5 chip-ID: 8087:0a2a class-ID: e001
  Report: bt-adapter note: tool can't run ID: hci0 rfk-id: 1 state: down
  bt-service: disabled rfk-block: hardware: no software: yes address: N/A
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 235.56 GiB used: 76.48 GiB (32.5%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/mmcblk1 maj-min: 179:0 vendor: HP model: DF4128 size: 116.48 GiB
  block-size: physical: 512 B logical: 512 B type: SSD serial: <filter>
  rev: 0x8 scheme: GPT
  ID-2: /dev/sdc maj-min: 8:32 type: USB model: Genesys SD USB3 Reader
  size: 119.08 GiB block-size: physical: 512 B logical: 512 B type: N/A
  serial: <filter> rev: 1206 scheme: GPT
  Message: No optical or floppy data found.
  ID-1: / raw-size: 118.79 GiB size: 116.36 GiB (97.96%)
  used: 16.99 GiB (14.6%) fs: ext4 dev: /dev/sdc2 maj-min: 8:34 label: N/A
  uuid: 57638ca8-527e-47cf-a70c-32258df32871
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
  used: 288 KiB (0.1%) fs: vfat dev: /dev/sdc1 maj-min: 8:33 label: NO_LABEL
  uuid: 8111-0CB9
  ID-3: /run/media/rangle/OS raw-size: 83.32 GiB size: 83.32 GiB (100.00%)
  used: 59.49 GiB (71.4%) fs: ntfs dev: /dev/mmcblk1p3 maj-min: 179:3
  label: OS uuid: 7802BE5802BE1AD8
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 487.5 MiB used: 0 KiB (0.0%) priority: 32767
  dev: /dev/zram0
  ID-2: swap-2 type: zram size: 487.5 MiB used: 0 KiB (0.0%) priority: 32767
  dev: /dev/zram1
  ID-3: swap-3 type: zram size: 487.5 MiB used: 0 KiB (0.0%) priority: 32767
  dev: /dev/zram2
  ID-4: swap-4 type: zram size: 487.5 MiB used: 0 KiB (0.0%) priority: 32767
  dev: /dev/zram3
  ID-1: /dev/mmcblk1p1 maj-min: 179:1 size: 100 MiB fs: vfat label: SYSTEM
  uuid: C2B5-68AC
  ID-2: /dev/mmcblk1p2 maj-min: 179:2 size: 128 MiB fs: <superuser required>
  label: N/A uuid: N/A
  ID-3: /dev/mmcblk1p4 maj-min: 179:4 size: 957 MiB fs: ntfs label: Recovery
  uuid: 08B2BED7B2BEC888
  ID-4: /dev/mmcblk1p5 maj-min: 179:5 size: 512 MiB fs: vfat label: MBOOT
  uuid: 609E-BB1D
  ID-5: /dev/mmcblk1p6 maj-min: 179:6 size: 31.5 GiB fs: ext4 label: N/A
  uuid: 5d087308-b748-434c-81ab-de936c4d87fe
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 8 rev: 2.0
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-2: 1-1:2 info: Hitachi ports: 4 rev: 2.0 speed: 480 Mb/s
  chip-ID: 045b:0209 class-ID: 0900
  Device-1: 1-1.1:6 info: Genesys Logic All-in-One Cardreader
  type: Mass Storage driver: usb-storage interfaces: 1 rev: 2.1
  speed: 480 Mb/s power: 500mA chip-ID: 05e3:0748 class-ID: 0806
  serial: <filter>
  Device-2: 1-2:3 info: China Resource Semico USB Keyboard type: Keyboard,HID
  driver: hid-generic,usbhid interfaces: 2 rev: 1.1 speed: 1.5 Mb/s
  power: 98mA chip-ID: 1a2c:2c27 class-ID: 0300
  Device-3: 1-3:4 info: Microdia USB Device type: Keyboard,Mouse
  driver: hid-generic,usbhid interfaces: 4 rev: 1.1 speed: 12 Mb/s
  power: 100mA chip-ID: 0c45:8101 class-ID: 0301
  Device-4: 1-7:5 info: Intel Bluetooth wireless interface type: Bluetooth
  driver: btusb interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA
  chip-ID: 8087:0a2a class-ID: e001
  Hub-3: 2-0:1 info: Super-speed hub ports: 7 rev: 3.0 speed: 5 Gb/s
  chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 45.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 183 Uptime: 42m wakeups: 1 Init: systemd v: 249 tool: systemctl
  Compilers: gcc: 11.1.0 Packages: pacman: 1061 lib: 281 Shell: Bash v: 5.1.12
  running-in: foot inxi: 3.3.09

When I run

journalctl --catalog --priority=3 |grep combi

there are no responses, so what’s the cause I wonder?

Thanks in advance,


I’m going to mark this solved because this hasn’t happened once since the 12-16-21 update. Whatever solved it, thanks!


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.