Closing lid turns on aeroplane mode

While closing the lid Manjaro goes into lock screen and aeroplane mode turns on. I found a way to disable the lockscreen part, but cannot figure out a way to disable the aeroplane mode part .
sudo journalctl -f

This gave an output like
wlo1: CTRL-EVENT-DSCP-POLICY clear_all

nl80211: deinit ifname=wlo1 disabled_11b_rates=0
Help :pleading_face:

Hi @AghoraGuru, and welcome!

According to this page:

Basically, open your preferences using sudo gedit /etc/systemd/logind.conf and change the line starting with HandleLidSwitch to HandleLidSwitch=ignore

Hope it helps!


I tried removing the # and tried with it. It still cuts off wifi when i close the lid .
Sorry for late response.

Did you reboot afterward?


According to

So, Gnome has an “Airplane Mode”. Just like you, I bet your problem is related to that. The Airplane Mode might be configured to cut WiFi when the lid closes.

Using Google to search for “gnome airplane mode” finds stuff about how to disable it. If you don’t know what’s talked about in those search results, Gnome has a thing that’s a bit like the Windows Registry to save configuration settings. You need to tweak a setting in there to disable Airplane Mode.

You can browse that stuff by running this in a terminal:

gsettings list-recursively | less

You’ll find the entry about Airplane Mode by typing /rfkill. Copy that line and use it on a new command line with the gsettings “set” parameter, but change the “true” to “false”:

gsettings set org.gnome.settings-daemon.plugins.rfkill active false

Then run gsettings list-recursively | less again and see if that “…rfkill active” line is set to “false” now. If you find out that this wasn’t the problem, you can revert back to the original settings by doing:

gsettings set org.gnome.settings-daemon.plugins.rfkill active true

Hello there !
Again sorry for late response :frowning_face:
I tried this and it worked. Just copy pasted the numerical codes too. It worked !
Thank you for the time !