Cloning root partition with dd Input output error

I am trying to clone my system for a rotating HDD to a SSD.

I formatted the new drive creating the same partitions of the old one, with the exception that the new root and home partitions are larger than the old ones.

Thus, I am booting from removable disk and doing a dd of root partition into the target partition of the new drive.

At around half of the process I always get a input/output error.

I cannot understand where it could be coming from, since I did similar operations in the past. For instance, to backup the system and it always worked.

Thanks for any help.

You should not use dd if the sizes differ !

Use a Imaging-program that is made for this task

Welcome to Manjaro! :smiling_face_with_three_hearts:

  1. Please read the information behind this link. It will help you to post necessary information. [HowTo] Provide System Information
  2. Please press the three dots below your post and then press the :pencil2:
  • If you give us information about your system, we can see what we’re talking about and make better suggestions.
  • You can do this by using inxi in a terminal or in console.
inxi --admin --verbosity=7 --filter --no-host --width
  • Personally identifiable information such as serial numbers and MAC addresses are filtered out by this command
  • Presenting the information in this way allows everyone to be familiar with the format and quickly find the items they need without missing anything.
  1. Copy the output from inxi (including the command) and paste it into your post.
  • To make it more readable, add 3 backticks ``` on an extra line before and after the pasted text.
    (Wisdom lies in reading :wink: )

You can’t use dd to duplicate your OS because, they have different device names for start, which needs adjusting anyhow.

Instead of dd next time try to use rsync

The difference between a back and a duplication of your OS is, just to name the minimal diff, a backup is intended to be restored at same place it was taken from while a duplication is meant to be a working copy at a different target as the source.

You would still need to make adjustments to make the duplicate boot and work like the old one did…

I solved it somehow.

I could copy EFI, swap and root partitions using the copy function of Gparted.

However, I could not copy the home partition, since it was in XFS format. It seems that Gparted cannot copy that type of filesystem.

For that, I created a new XFS partition, copied the user folders and then create the new users with same name as root.

Adjusted fstab with the right UUIDs and repaired grub from pen-drive system.

The system works perfectly

You will keep running into problems when you keep using wrong tools for your end result…

Anyhow, glad your problem is solved now.