Clonezilla: "For GPT disk, there is no need to run this program."

I’m creating a bootable Clonezilla USB. I’m following the instructions from the website. I made a FAT32 partition on the USB with KDE Partition Manager. I ran into the following while running sudo bash /dev/[device]:

This program is for making a bootable disk with MBR partition table.
For GPT disk, there is no need to run this program. Just make sure the partition is FAT32 with ID=ef00 and all the files are copied on that. That's all.
Program terminated!

This isn’t mentioned in the instructions. Is this going to be a problem?
How do I check if the partition is “FAT32 with ID=ef00”?

  • open a terminal
  • locate the device path
  • run cgdisk and change the partition type to ef00
  • write the change and quit

I get the following:

Warning! Non-GPT or damaged disk detected! This program will attempt to
convert to GPT form or repair damage to GPT data structures, but may not
succeed. Use gdisk or another disk repair tool if you have a damaged GPT

Just let the program continue - it will fix the gpt structure - then change the type for partition - or delete the partition and recreate it - write the partition table and quit.

Then format the device (just remember - the device cannot hold files larger than 4GB)

mkfs.vfat -F32 /dev/sdy1

I’m in cgdisk, but I don’t see the type option. I see:


Also, Clonezilla is already copied manually into the partition I created.

I tried changing the ID in a different way, but I couldn’t make the USB bootable. Very frustrating.

EDIT I finally set up the bootable USB. I didn’t make a partition in the KDE Partition Manager this time. Instead, I wiped the existing partitions in the KDE Partition Manager and created a partition through the terminal, in fdisk.

Now I’m staring at the Clonezilla boot menu and the only thing left to figure out is everything.

Pretty much I just use the ‘defaults’. Then save parts NOT whole disc.

Why not the whole disk? That’s what I was about to do.

Takes up way too much space. Save parts will save the OS for future reinstall if needed.

Oh. I don’t care about the space. About the time, maybe.

I was going to follow this guy’s tutorial:

Have a look here>

First two sections is what I use, Once you have done it a few times it becomes much clearer.

1 Like

Finished my first cloning.

I was hoping I would be able to boot from the image, in order to make sure if it’s restorable. I set the USB hard drive as the priority boot device. I think the image didn’t boot, because it wasn’t mounted at /.

I also thought that the image will use the entire external HDD, but it doesn’t. It also left the previous data intact.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.