Clipgrab/yt-dlp no longer works on YouTube

I can enter the URL, and it reports downloading and converting the video, and it even asks you for a filename. Then the notification appears that the download and conversion was complete, but the file just isn’t there.

Is this a bug in clipgrab, in yt-dlp, or is it some kind of Google/YouTube copyright policing thing? :thinking:

It is likely google infamous protection system which has validated your system to be a bot.

1 Like

We hates Googleses, Preciousss. We hates them! :angry:

Have you tried youtube-dl?

1 Like

Yes, I have, and it gave me an error message that it couldn’t fetch the player, or something like that. :frowning_man:

Just tried yt-dlp myself, and it worked.

That said, the CLI feedback was…strange. It didn’t go from 0%-100%, but at some stages reversed a bit, and then continued. Something like 0% → 35% → 30% → 70% → 75% → 70% → 80% → 100%.

Additionally, when I played it with Dragon Player the progress bar moved to the end, and sataed there while the video played, within 5 seconds of opening the file.

1 Like

Hmm… Maybe it’s only on certain videos. :thinking:

That was my exact thoughts…

1 Like

Yeah, @linux-aarhus is probably right. Probably some copy protection thing.

We hates it! We hates it!


Ok, just installed clipgrab, downloaded a 3 minute Pixies video and it worked fine.

1 Like

Yup. a Region thing, because I just tested the video with smplayer and it worked fine…


Also just tried clipgrab. Had absolutely no problems

1 Like

smtube from AUR is maybe another alternative (I did try not myself, yet).

1 Like

If more than one download package is failing for everyone it would likely be from changes in youtube algorithm to block external downloads.
But yt-dlp is working no problem for me

1 Like
yt-dlp -f bestvideo+bestaudio CLIP

is the thing that always works. Clipgrab works on most of the clips. I have also tried YTDownloader and Open Video Downloader (Appimages)


Google is promoting their Web Environment Integrity (WEI) already dubbed DRM for web sites.

It could be they are testing the algoritms and you were the unlucky machine.

1 Like

In my case, Clipgrab has never failed until the last couple of days. Now 90% of downloads fail after starting. Once in a while, one will work.

Same result with other download tools that I installed to see if one works.

A couple of online tools do work:

One can also insert pp into the url, like:


Why (how) does that work? It did. With

Similarly says to put zp before the url, but that one does not wok for me.

These have existed for a long time… you can find various online ‘tutorials’, like for bypassing age restricted videos … instructing to add ‘nsfw’ before youtube …
There are numerous services/sites that deploy this kind of model where they are functionally ‘mirroring’ the domain addresses to their corresponding service.
A lot of these ‘alternatives’ make use of some from of an Invidious instance.

1 Like