Clicking on .desktop file opens in editor

I’ve purchased software, that was provided in form of .zip archive to extract. I’ve unpacked it into /opt/thatapp directory. There is .desktop file, that I’m supposed to double click to create desktop entry, but when I do, it opens gedit instead. I’ve tried gio launch command as well - and this one indeed opens the app, but does not create any shortcuts or whatsoever.

Maybe anyone had similar problem? There are several similar topics over the internet, but didn’t stumble across working solution so far.

Perhaps you could at least reveal the name of this apparently secretive software, to allow others to help more effectively.

Sure, no problem :slight_smile: It’s Wonderdraft - map making software for table top rpg games. It’s not secret, I just didn’t consider it to be important. Will post .desktop file content when I get home.

Is available on AUR:


So… pamac build wonderdraft

EDIT: Obviously, uninstall the *.zip file, before to proceed.

1 Like

Thank you :slight_smile: Didn’t thought to check in AUR, as it is paid tool and I don’t think there is much licensing besides the limited access to zip files. Most comments claim it to be broken and sadly it resulted in error as well when I tested it.

As far, as I understand, it’s not a problem with software itself - I’m able to start it using binary. Problem is with .desktop file, that opens in editor instead of acting like these type of files should. I stumbled across several similar topics relating to several different applications, sadly with no clear solution.

Content of the .desktop file looks like this. On the first glance I don’t see any mistake:

Comment=Wonderdraft is a powerful yet intuitive fantasy map creation tool.

A .desktop file is a desktop entry. :wink:

A desktop file is not executable by default. It only adds a menu entry.

This isn’t Windows where a .lnk shortcut on your desktop launches the program. GNOME does not have a traditional desktop unless one installs an extension.

1 Like

If you can access the properties of the the .desktop file – perhaps via the context menu (right-click) – you might find a checkbox somewhere that says make executable, or similar (I don’t use Gnome).

Check that, close, and save the .desktop file if prompted.
Then see if some magic happens.

Try to copy that .desktop file to ~/.local/share/applications/ and see if it appears inside GNOME apps’ launcher when you search for it, I don’t know if it still works since I ditched GNOME long time ago.

1 Like

OK, so solution was to execute command:

desktop-file-install --dir=$HOME/.local/share/applications Wonderdraft.desktop

This in fact, as suggested by @medmedin created entry in ~/.local/share/applications/
I don’t know, if this tool does anything else, but application is visible in app launcher and starts as expected. The .desktop file had an issue as well - Version parameter is redundant and should not point to the app version, as stated on the AskUbuntu forum. I removed it entirely.

Thanks everyone for your help, I really appreciate it :slight_smile:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.