Clicking on a mounted drive starts Visual Studio Code instead of Nautilus


I’m relatively new to Manjaro Gnome but it’s not my first Linux. So a little bit of knowledge is available :-).

I recently installed Manjaro Gnome and I’m really happy so far. The only annoying thing is when I click on a mounted volume that shows up e.g. in Dash to Dock. I expect to open the file’s manager (Nautilus) but Visual Studio Code will open. If I temporary uninstall Visual Studio Code then Double Commander opens (which I’ve installed a few days ago). If I reinstall Visual Studio Code again Code opens when I click on a volume.

Where I can I change this behavior? Nothing can be found in Standard Apps. If I go to Setting/Applications and select “Files” I can see Default Handles. In “Other Files” I can see the type folder. But only with the option “Unset”.

Thanks in advance


I have similar issue with text files. Cannot change default editor VSCode to Text Editor.

Had the same issue. Clicking the unset button in Applications/Visual Studio Code/Other Files/folders removed the association. Maybe also Reset the Applications/Files Default Handlers or select any Folder on Disk and choose Open With Other Application and select Files.

The Unset and Reset Button does not refresh the UI immediately, so navigate somewhere else and back and then it should be updated.

1 Like

This probably caused by wrong priorities in mimetypes. There might be a more proper fix, but it might be fixed by just installing nautilus after vscode is installed.

I had a similar issue with Places Status Indicator. Links was opening in EasyTag or Visual Studio as projects. Your tip helped me as well! Just opened random folder trough “Open With Other Application” with “Files”. So it was an association issue. Thanks!