Clean install chromium docker won't run

Installed it. Nothing doing.

Uninstalled it. Addef user name to docker group reinstalled rebooted. Nothing.

Adjusted paprefs. Nothing doing. Uninstalled. Added username to group again. Reinstalled. Rebooted. Nothing doing.

Pi4b 8gb xfce stable branch

Tried updating image from github. Nothing doing.

/usr/local/bin/chromium-armhf: line 4: hostname: command not found

Do you have inetutils installed ?

1 Like

I do now. Thanks. Tried running it after . Nothing.

Uninstalled. Added user to group. Reinstalled. Rebooted. Chromium docker gives the same message and doesn’t run

Is it really the same error about hostname missing?
Does the command run on its own?

1 Like

Sorry. You’re right

What is the output of

docker images -q hthiemann/chromium-armhf:latest | head -n 1

Because the other error is this:

Searching for Docker image …

Found and using

“docker run” requires at least 1 argument.

Where there should be an image listed after “Found and using” … and it fails afterwards, as that variable was used in the rest of the run command.

So if the above returns nothing, as I suppose it will … then please attempt listing docker images or similar to expand on the situation.

1 Like

Nothing was the output

Expand further? I know nothing about docker. I googled chromium docker won’t start Manjaro and found a couple web pages from the forums and tried to do what it says.

Sudo pacman -S chromium-docker is almost all I know other than adding user to docker group and flowing the picture of paprefs on the forum page

Please return

docker info

docker images
1 Like

Docker info

Docker images

Ty for your help

First off I do not maintain this package but I do know it works. It is increasingly looking like with out standing behind you and looking over your shoulder to see what you have or have not done it is going to be hard to diagnose your issue. Especially me since it is not my package and I never use it.

Everything seems to work here including sound.

[ray@pi4 ~]$ sudo docker info
 Context:    default
 Debug Mode: false
  buildx: Build with BuildKit (Docker Inc., v0.6.1-docker)

 Containers: 3
  Running: 1
  Paused: 0
  Stopped: 2
 Images: 16
 Server Version: 20.10.11
 Storage Driver: overlay2
  Backing Filesystem: extfs
  Supports d_type: true
  Native Overlay Diff: true
  userxattr: false
 Logging Driver: json-file
 Cgroup Driver: systemd
 Cgroup Version: 2
  Volume: local
  Network: bridge host ipvlan macvlan null overlay
  Log: awslogs fluentd gcplogs gelf journald json-file local logentries splunk syslog
 Swarm: inactive
 Runtimes: io.containerd.runtime.v1.linux runc io.containerd.runc.v2
 Default Runtime: runc
 Init Binary: docker-init
 containerd version: 1e5ef943eb76627a6d3b6de8cd1ef6537f393a71.m
 runc version: v1.0.2-0-g52b36a2d
 init version: de40ad0
 Security Options:
   Profile: default
 Kernel Version: 5.10.82-1-MANJARO-ARM-RPI
 Operating System: Manjaro ARM
 OSType: linux
 Architecture: aarch64
 CPUs: 4
 Total Memory: 7.628GiB
 Name: pi4
 Docker Root Dir: /var/lib/docker
 Debug Mode: false
 Experimental: false
 Insecure Registries:
 Live Restore Enabled: false

WARNING: No memory limit support
WARNING: No swap limit support
[ray@pi4 ~]$ 
[ray@pi4 ~]$ sudo docker images
REPOSITORY                 TAG       IMAGE ID       CREATED         SIZE
hthiemann/chromium-armhf   latest    23952b647d33   10 months ago   585MB
arm32v7/ubuntu             bionic    6129fe7526d5   12 months ago   45.8MB

1 Like

I have used it before and for whatever reason it isn’t. Its a fresh install. I followed all the steps to adjust groups and paprefs. I don’t know why it isn’t working I just know it doesn’t. Can’t get a browser window. But hey, if it works for everybody and not me so I just be full of crap huh? That seems to be the implied message.

@spikerguy just said it may need a new widevine. I never tested that part as I do not have any paid subscriptions. So looking like in the end it may not be useful at this time…

your files work not installed properly.
Remove it first
sudo pacman -R chromium-docker

Install it with
sudo pacman -S chromium-docker

Share the output of this install command.

Try using
sudo chromium-armhf

as dockers group was not added.

I just installed and everything went well except dockers didn’t start on first attempt.

I had to start docker service manually before the script tries to pull docker image.

I sold my pi and all of it I had ammassed with it. Someone got a screaming deal. Bought a roku for 30$ I’m done with PCs.

Thank you for helping. Have a nice life.j

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.