Clarification with Flutter

This is my first post, kindly be polite with me …

I have tried installing flutter from the Add/Remove app, but there was no success…

so i decided to use this command [ sudo pamac build flutter]to install it and from the first code that came it says:

Here is the output after everything

 ➜  ~ sudo pamac build flutter
Warning: Building packages as dynamic user
Warning: Setting build directory to /var/cache/pamac
Checking flutter dependencies...
Resolving dependencies...
Checking inter-conflicts...

To build (1):
  flutter  3.3.4-3    AUR

Edit build files : [e] 
Apply transaction ? [e/y/N] y

Cloning flutter build files...
Running as unit: run-u82.service
Finished with result: success
Main processes terminated with: code=exited/status=0
Service runtime: 4.388s
CPU time consumed: 72ms
Generating flutter information...
Running as unit: run-u83.service
Finished with result: success
Main processes terminated with: code=exited/status=0
Service runtime: 2.328s
CPU time consumed: 2.587s

Building flutter...
Running as unit: run-u84.service
Press ^] three times within 1s to disconnect TTY.
==> Making package: flutter 3.3.4-3 (Wed 19 Oct 2022 05:01:12 PM GMT)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Downloading flutter-3.3.4.tar.xz...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  604M  100  604M    0     0   944k      0  0:10:55  0:10:55 --:--:-- 1458k
  -> Found
  -> Found flutter.csh
==> Validating source files with sha256sums...
    flutter-3.3.4.tar.xz ... Passed ... Passed
    flutter.csh ... Passed
==> Removing existing $srcdir/ directory...
==> Extracting sources...
  -> Extracting flutter-3.3.4.tar.xz with bsdtar
==> Starting build()...
Downloading Linux x64 Dart SDK from Flutter engine c08d7d5efc9aa6eb3c30cfb3be6dc09bca5e7631...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  204M  100  204M    0     0  2106k      0  0:01:39  0:01:39 --:--:-- 2108k
Building flutter tool...

  ║                 Welcome to Flutter! -                  ║
  ║                                                                            ║
  ║ The Flutter tool uses Google Analytics to anonymously report feature usage ║
  ║ statistics and basic crash reports. This data is used to help improve      ║
  ║ Flutter tools over time.                                                   ║
  ║                                                                            ║
  ║ Flutter tool analytics are not sent on the very first run. To disable      ║
  ║ reporting, type 'flutter config --no-analytics'. To display the current    ║
  ║ setting, type 'flutter config'. If you opt out of analytics, an opt-out    ║
  ║ event will be sent, and then no further information will be sent by the    ║
  ║ Flutter tool.                                                              ║
  ║                                                                            ║
  ║ By downloading the Flutter SDK, you agree to the Google Terms of Service.  ║
  ║ Note: The Google Privacy Policy describes how data is handled in this      ║
  ║ service.                                                                   ║
  ║                                                                            ║
  ║ Moreover, Flutter includes the Dart SDK, which may send usage metrics and  ║
  ║ crash reports to Google.                                                   ║
  ║                                                                            ║
  ║ Read about data we send with crash reports:                                ║
  ║                         ║
  ║                                                                            ║
  ║ See Google's privacy policy:                                               ║
  ║                                        ║

Downloading Material fonts...                                    2,146ms
Downloading Gradle Wrapper...                                      183ms
Downloading android-arm-profile/linux-x64 tools...               1,118ms
Downloading android-arm-release/linux-x64 tools...                 801ms
Downloading android-arm64-profile/linux-x64 tools...             1,377ms
Downloading android-arm64-release/linux-x64 tools...               900ms
Downloading android-x64-profile/linux-x64 tools...                  3.2s
Downloading android-x64-release/linux-x64 tools...                 972ms
Downloading android-x86 tools...                                    9.4s
Downloading android-x64 tools...                                   20.8s
Downloading android-arm tools...                                   10.8s
Downloading android-arm-profile tools...                            5.5s
Downloading android-arm-release tools...                            3.4s
Downloading android-arm64 tools...                                  8.1s
Downloading android-arm64-profile tools...                          5.6s
Downloading android-arm64-release tools...                       2,401ms
Downloading android-x64-profile tools...                            6.6s
Downloading android-x64-release tools...                            3.9s
Downloading android-x86-jit-release tools...                        5.5s
Downloading Web SDK...                                             42.7s
Downloading CanvasKit...                                            4.9s
Downloading package sky_engine...                                  889ms
Downloading flutter_patched_sdk tools...                         2,095ms
Downloading flutter_patched_sdk_product tools...                 1,932ms
Downloading linux-x64 tools...                                     17.0s
Downloading linux-x64/linux-x64-flutter-gtk tools...               10.2s
Downloading linux-x64-profile/linux-x64-flutter-gtk tools...         4.6s
Downloading linux-x64-release/linux-x64-flutter-gtk tools...         6.1s
Downloading linux-x64/font-subset tools...                       1,304ms
==> Entering fakeroot environment...
==> Starting package()...
==> Tidying install...
  -> Removing empty directories...
  -> Removing libtool files...
  -> Purging unwanted files...
  -> Removing static library files...
  -> Stripping unneeded symbols from binaries and libraries...
  -> Compressing man and info pages...
==> Checking for packaging issues...
==> WARNING: Package contains reference to $srcdir
==> Creating package "flutter"...
  -> Generating .PKGINFO file...
  -> Generating .BUILDINFO file...
  -> Adding install file...
  -> Generating .MTREE file...
  -> Compressing package...
==> Leaving fakeroot environment.
==> Finished making: flutter 3.3.4-3 (Wed 19 Oct 2022 05:23:43 PM GMT)
==> Cleaning up...
Finished with result: success
Main processes terminated with: code=exited/status=0
Service runtime: 22min 35.891s
CPU time consumed: 4min 30.532s
Running as unit: run-u90.service
Finished with result: success
Main processes terminated with: code=exited/status=0
Service runtime: 1.639s
CPU time consumed: 1.814s

Checking keyring...                                                                                       [1/1]
Checking integrity...                                                                                     [1/1]
Loading packages files...                                                                                 [1/1]
Checking file conflicts...                                                                                [1/1]
Checking available disk space...                                                                          [1/1]
Installing flutter (3.3.4-3)...                                                                           [1/1]
Flutter was installed on /opt/flutter

In case you encounter problems using Flutter as regular user, add your user into the group flutterusers:
gpasswd -a ${USER} flutterusers

Re-login your terminal in to the group flutterusers:
newgrp flutterusers

Run the following command to see if there are any dependencies you need to install to complete the setup (for verbose output, add the -v flag):
flutter doctor
Running post-transaction hooks...
Arming ConditionNeedsUpdate...                                                                            [1/2]
Refreshing PackageKit...                                                                                  [2/2]
Transaction successfully finished.
➜  ~ 

After running Flutter doctor i got this feedback

fatal: detected dubious ownership in repository at '/opt/flutter'
To add an exception for this directory, call:

        git config --global --add /opt/flutter
rm: cannot remove '/opt/flutter/version': Permission denied

Even when i added the $USER to the grp
So now i want to know if those warnings can cause any issues on my system

thank you

Moderator edit: In the future, please use proper formatting: [HowTo] Post command output and file content as formatted text

please give the output of

ls -l /opt/flutter
➜  ~ ls -l /opt/flutter
total 88
-rw-rw-r-- 1 wisdak flutterusers 11500 Oct 19 17:01 analysis_options.yaml
-rw-rw-r-- 1 wisdak flutterusers  3636 Oct 19 17:01 AUTHORS
drwxrwxr-x 1 wisdak flutterusers    86 Oct 19 17:25 bin
-rw-rw-r-- 1 wisdak flutterusers  2924 Oct 19 17:01
-rw-rw-r-- 1 wisdak flutterusers   732 Oct 19 17:01 CODEOWNERS
-rw-rw-r-- 1 wisdak flutterusers 10728 Oct 19 17:01
-rw-rw-r-- 1 wisdak flutterusers  1829 Oct 19 17:01 dartdoc_options.yaml
drwxrwxr-x 1 wisdak flutterusers   412 Oct 19 17:25 dev
drwxrwxr-x 1 wisdak flutterusers   316 Oct 19 17:25 examples
-rw-rw-r-- 1 wisdak flutterusers  1731 Oct 19 17:01 flutter_console.bat
-rw-rw-r-- 1 wisdak flutterusers   296 Oct 19 17:01 flutter_root.iml
-rw-rw-r-- 1 wisdak flutterusers  1519 Oct 19 17:01 LICENSE
drwxrwxr-x 1 wisdak flutterusers   378 Oct 19 17:25 packages
-rw-rw-r-- 1 wisdak flutterusers  1107 Oct 19 17:01 PATENT_GRANT
-rw-rw-r-- 1 wisdak flutterusers  6058 Oct 19 17:01
-rw-rw-r-- 1 wisdak flutterusers 19915 Oct 19 17:01 TESTOWNERS
-rw-rw-r-- 1 wisdak flutterusers     5 Oct 19 17:50 version
➜  ~ 

i think i solve it now,
i have to change the user/owner from root to my name($USER)
after that i run flutter doctor without sudo and it works

So how will this warning affect my system
Warning: Building packages as dynamic user Warning: Setting build directory to /var/cache/pamac


As long as the packages build, I would ignore the warning, its just telling you where the packages will be built.

Alright…thanks for your time. :handshake:

Dynamic users is a feature pamac utilizes to allow you to run itself using sudo. Otherwise it would be a security issue as you are not allowed to build AUR packages as root.


Well said…thanks

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.