ClamAV-desktop-bin failed to build on 2023_11-3

I tried to find a solution to failed clamAV update on the web and on Manjaro site and forum, without success.

The 2023_11-4 update included clamav.

They updated successfully, but clamav gave an error due
to missing dependency Electron17.

The uploaded pamac update log file:
“1st attempt - clamav missing dependencies 2023_11-3 @ 10-10am”.
is the 1st attempt at yesterday’s update.

I tried to install “Electron17” by itself,
it failed to install as well.

The uploaded pamac update log file:
“2nd attempt - clamav update failed 2023_11-3-4”
(which has 23,663 lines of text)
is the 2nd attempt to update clamav after electron17 failure.

The uploaded picture “Clamav update info 2023_11-4.png”
is the pamac available updates listing of clamav.

I was able to install the other available updates by unchecking clamav.

So, is there a fix for the clamav error, or do I install an clamav alternative or something else?

Here is my system info:

[sudo] password for ultra: 
  Kernel: 6.5.9-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: hpet,acpi_pm
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.5-x86_64
    root=UUID=121a5a27-095d-4c7a-8853-3a2b6e097b5c rw quiet splash apparmor=1
    security=apparmor udev.log_priority=3
  Desktop: Xfce v: 4.18.1 tk: Gtk v: 3.24.36 info: xfce4-panel wm: xfwm
    v: 4.18.0 dm: LightDM v: 1.32.0 Distro: Manjaro Linux base: Arch Linux
  Type: Desktop System: Micro-Star product: MS-7B86 v: 3.0 serial: N/A
  Mobo: Micro-Star model: B450 GAMING PLUS MAX (MS-7B86) v: 3.0
    serial: <filter> UEFI: American Megatrends LLC. v: H.D3 date: 09/28/2021
  Device-1: hidpp_battery_0 model: Logitech Wireless Mouse serial: <filter>
    charge: 55% (should be ignored) rechargeable: yes status: discharging
  Device-2: hidpp_battery_1 model: Logitech K520 serial: <filter>
    charge: 70% (should be ignored) rechargeable: yes status: discharging
  System RAM: total: 16 GiB available: 15.54 GiB used: 2.17 GiB (14.0%)
  Array-1: capacity: 128 GiB slots: 4 modules: 2 EC: None
    max-module-size: 32 GiB note: est.
  Device-1: DIMM 0 type: no module installed
  Device-2: DIMM 1 type: DDR4 detail: synchronous unbuffered (unregistered)
    size: 8 GiB speed: 2933 MT/s volts: curr: 1.2 min: 1.2 max: 1.2 width (bits):
    data: 64 total: 64 manufacturer: G.Skill part-no: F4-3200C16-8GVKB
    serial: N/A
  Device-3: DIMM 0 type: no module installed
  Device-4: DIMM 1 type: DDR4 detail: synchronous unbuffered (unregistered)
    size: 8 GiB speed: 2933 MT/s volts: curr: 1.2 min: 1.2 max: 1.2 width (bits):
    data: 64 total: 64 manufacturer: G.Skill part-no: F4-3200C16-8GVKB
    serial: N/A
  Info: model: AMD Ryzen 5 2600 socket: AM4 bits: 64 type: MT MCP arch: Zen+
    gen: 2 level: v3 note: check built: 2018-21 process: GF 12nm
    family: 0x17 (23) model-id: 8 stepping: 2 microcode: 0x800820D
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 576 KiB desc: d-6x32 KiB; i-6x64 KiB L2: 3 MiB desc: 6x512 KiB L3: 16 MiB
    desc: 2x8 MiB
  Speed (MHz): avg: 1962 high: 3400 min/max: 1550/3400 boost: enabled
    base/boost: 3400/3900 scaling: driver: acpi-cpufreq governor: schedutil
    volts: 1.1 V ext-clock: 100 MHz cores: 1: 3400 2: 1550 3: 1550 4: 1550
    5: 1550 6: 2800 7: 1550 8: 1550 9: 1550 10: 3400 11: 1550 12: 1550
    bogomips: 81643
  Flags: 3dnowprefetch abm adx aes aperfmperf apic arat avic avx avx2 bmi1
    bmi2 bpext clflush clflushopt clzero cmov cmp_legacy constant_tsc cpb
    cpuid cr8_legacy cx16 cx8 de decodeassists extapic extd_apicid f16c
    flushbyasid fma fpu fsgsbase fxsr fxsr_opt ht hw_pstate ibpb irperf
    lahf_lm lbrv lm mca mce misalignsse mmx mmxext monitor movbe msr mtrr
    mwaitx nonstop_tsc nopl npt nrip_save nx osvw overflow_recov pae pat
    pausefilter pclmulqdq pdpe1gb perfctr_core perfctr_llc perfctr_nb
    pfthreshold pge pni popcnt pse pse36 rapl rdrand rdseed rdtscp rep_good
    sep sev sev_es sha_ni skinit smap smca smep ssbd sse sse2 sse4_1 sse4_2
    sse4a ssse3 succor svm svm_lock syscall tce topoext tsc tsc_scale
    v_vmsave_vmload vgif vmcb_clean vme vmmcall wdt xgetbv1 xsave xsavec
    xsaveerptr xsaveopt
  Type: gather_data_sampling status: Not affected
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed mitigation: untrained return thunk; SMT vulnerable
  Type: spec_rstack_overflow mitigation: safe RET
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, STIBP:
    disabled, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: NVIDIA GP107 [GeForce GTX 1050 Ti] vendor: Gigabyte driver: nouveau
    v: kernel non-free: 545.xx+ status: current (as of 2023-11; EOL~2026-12-xx)
    arch: Pascal code: GP10x process: TSMC 16nm built: 2016-2021 pcie: gen: 1
    speed: 2.5 GT/s lanes: 16 link-max: gen: 3 speed: 8 GT/s ports:
    active: HDMI-A-1 empty: DP-1,DVI-D-1 bus-ID: 26:00.0 chip-ID: 10de:1c82
    class-ID: 0300 temp: 49.0 C
  Display: x11 server: v: compositor: xfwm v: 4.18.0 driver:
    X: loaded: modesetting alternate: fbdev,vesa dri: nouveau gpu: nouveau
    display-ID: :0.0 note: <missing: xdpyinfo/xrandr>
  Monitor-1: HDMI-A-1 model: HP w2207 serial: <filter> built: 2007
    res: 1680x1050 dpi: 90 gamma: 1.2 size: 473x296mm (18.62x11.65")
    diag: 558mm (22") ratio: 16:10 modes: max: 1680x1050 min: 720x400
  API: EGL v: 1.5 hw: drv: nvidia nouveau platforms: device: 0 drv: nouveau
    device: 1 drv: swrast gbm: drv: nouveau surfaceless: drv: nouveau x11:
    drv: nouveau inactive: wayland
  API: OpenGL v: 4.5 compat-v: 4.3 vendor: mesa v: 23.1.9-manjaro1.1
    glx-v: 1.4 direct-render: yes renderer: NV137 device-ID: 10de:1c82
    memory: 3.9 GiB unified: no
  Device-1: NVIDIA GP107GL High Definition Audio vendor: Gigabyte
    driver: snd_hda_intel v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 16
    link-max: gen: 3 speed: 8 GT/s bus-ID: 26:00.1 chip-ID: 10de:0fb9
    class-ID: 0403
  Device-2: AMD Family 17h HD Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    bus-ID: 28:00.3 chip-ID: 1022:1457 class-ID: 0403
  API: ALSA v: k6.5.9-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 0.3.83 status: off with: pipewire-media-session
    status: off tools: pw-cli
  Server-3: PulseAudio v: 16.1 status: active (root, process)
    with: pulseaudio-alsa type: plugin tools: pacat,pactl,pavucontrol
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Micro-Star MSI driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: f000 bus-ID: 22:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp34s0 state: up speed: 100 Mbps duplex: full mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
  Message: No bluetooth data found.
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 2.5 TiB used: 617.94 GiB (24.1%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Crucial model: CT250MX500SSD1
    size: 232.89 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    tech: SSD serial: <filter> fw-rev: 043 scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST3500418AS
    size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 1.5 Gb/s
    tech: HDD rpm: 7200 serial: <filter> fw-rev: CC46 scheme: MBR
  ID-3: /dev/sdc maj-min: 8:32 vendor: Hitachi model: HUA723020ALA641
    size: 1.82 TiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    tech: HDD rpm: 7200 serial: <filter> fw-rev: A840 scheme: MBR
  Optical-1: /dev/sr0 vendor: HL-DT-ST model: DVDRAM GH24NSC0 rev: LI00
    dev-links: cdrom
  Features: speed: 12 multisession: yes audio: yes dvd: yes
    rw: cd-r,cd-rw,dvd-r,dvd-ram state: running
  ID-1: / raw-size: 232.59 GiB size: 227.88 GiB (97.98%)
    used: 108.64 GiB (47.7%) fs: ext4 block-size: 4096 B dev: /dev/sda2
    maj-min: 8:2 label: N/A uuid: 121a5a27-095d-4c7a-8853-3a2b6e097b5c
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 288 KiB (0.1%) fs: vfat block-size: 512 B dev: /dev/sda1 maj-min: 8:1
    label: N/A uuid: 2C95-A40A
  ID-3: /run/media/ultra/Ht1 raw-size: 550 GiB size: 540.3 GiB (98.24%)
    used: 509.3 GiB (94.3%) fs: ext4 block-size: 4096 B dev: /dev/sdc2
    maj-min: 8:34 label: Ht1 uuid: 48d40e11-d416-4079-9abd-c3115f9bdfc3
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) zswap: yes
    compressor: zstd max-pool: 20%
  ID-1: swap-1 type: file size: 512 MiB used: 0 KiB (0.0%) priority: -2
    file: /swapfile
  ID-1: /dev/sdb1 maj-min: 8:17 size: 232.88 GiB fs: ext4 label: DDrive1
    uuid: 6e4c97b7-826e-445e-8796-72d0e38f7e36
  ID-2: /dev/sdb2 maj-min: 8:18 size: 232.88 GiB fs: ext4 label: DDrive2
    uuid: 353601dc-0eb6-45f9-9475-50f8fb8def2c
  ID-3: /dev/sdc3 maj-min: 8:35 size: 640 GiB fs: ext4 label: Ht2
    uuid: db9f7c41-b09a-462e-a202-e0cd136c5ee7
  ID-4: /dev/sdc4 maj-min: 8:36 size: 673.02 GiB fs: ext4 label: Ht3
    uuid: dc1ff585-f270-4de5-ae19-45a09aa1bbb7
  Hub-1: 1-0:1 info: hi-speed hub with single TT ports: 10 rev: 2.0
    speed: 480 Mb/s (57.2 MiB/s) lanes: 1 mode: 2.0 chip-ID: 1d6b:0002
    class-ID: 0900
  Device-1: 1-8:2 info: Logitech Unifying Receiver type: keyboard,mouse,HID
    driver: logitech-djreceiver,usbhid interfaces: 3 rev: 2.0
    speed: 12 Mb/s (1.4 MiB/s) lanes: 1 mode: 1.1 power: 98mA
    chip-ID: 046d:c52b class-ID: 0300
  Hub-2: 2-0:1 info: super-speed hub ports: 4 rev: 3.1
    speed: 10 Gb/s (1.16 GiB/s) lanes: 1 mode: 3.2 gen-2x1 chip-ID: 1d6b:0003
    class-ID: 0900
  Hub-3: 3-0:1 info: hi-speed hub with single TT ports: 4 rev: 2.0
    speed: 480 Mb/s (57.2 MiB/s) lanes: 1 mode: 2.0 chip-ID: 1d6b:0002
    class-ID: 0900
  Hub-4: 4-0:1 info: super-speed hub ports: 4 rev: 3.0
    speed: 5 Gb/s (596.0 MiB/s) lanes: 1 mode: 3.2 gen-1x1 chip-ID: 1d6b:0003
    class-ID: 0900
  System Temperatures: cpu: 41.2 C mobo: N/A gpu: nouveau temp: 49.0 C
  Fan Speeds (rpm): N/A gpu: nouveau fan: 0
  Processes: 445 Uptime: 59m wakeups: 0 Init: systemd v: 254 default: graphical
  tool: systemctl Compilers: gcc: 13.2.1 clang: 16.0.6 Packages: 1441
  pm: pacman pkgs: 1411 libs: 364 tools: pamac pm: flatpak pkgs: 30
  Shell: Sudo (sudo) v: 1.9.14p3 default: Bash v: 5.2.15
  running-in: xfce4-terminal inxi: 3.3.31
[ultra@ultra-ms7b86 ~]$ ```

1st update attempt:
Synchronizing package databases...
Refreshing extra.db...
Refreshing AUR...
Checking clamav-desktop-bin dependencies...
Cloning freecad-linkstage3-bin build files...
Generating freecad-linkstage3-bin information...
Checking freecad-linkstage3-bin dependencies...
Resolving dependencies...
Checking inter-conflicts...
Cloning clamav-desktop-bin build files...
Generating clamav-desktop-bin information...
Download of c-ares (1.20.1-1) started
Download of nodejs (20.8.0-1) started
Download of c-ares (1.20.1-1) finished
Download of asar (3.2.4-1) started
Download of asar (3.2.4-1) finished
Download of nodejs (20.8.0-1) finished
Checking keyring...
Checking integrity...
Loading packages files...
Checking file conflicts...
Checking available disk space...
Installing c-ares (1.20.1-1)...
Installing nodejs (20.8.0-1)...
Installing asar (3.2.4-1)...
Running post-transaction hooks...
Arming ConditionNeedsUpdate...

Building clamav-desktop-bin...
==> Making package: clamav-desktop-bin 0.3.24-2 (Fri 03 Nov 2023 10:05:55 AM EDT)
==> Checking runtime dependencies...
==> Missing dependencies:
  -> electron17
==> Checking buildtime dependencies...
==> ERROR: Could not resolve all dependencies.```

I could not import the 2nd update attempt after electron17 install failed, because the update process log is too long, (23,663 lines of text).

I thank you guys for any help concerning this problem.

Maybe you should post the full log. I do not think clamav is in anyway dependend on electron, so you have something else going on. Like installing some clamav gui app from aur, for example

I thought I did post the clamav log - right above your post Teo.

Yes, I do. This uploaded pic is the only 2 clamav packages on my system. Thanks for responding.
If clamav is going to be a problem, should I uninstall the gui only or all of clamav?
Clamav installed apps

Is in the AUR.
I dont know why your build/dependency resolution is failing.
What commands did you use exactly?

I dont like pamac, and I wont assume what AUR helper you use … so …

sudo pacman -Syu git base-devel
git clone
git clone
cd electron17 && makepkg -sric
cd ../clamav-desktop-bin && makepkg -sric
cd .. && sudo pacman -Syu

My crystal ball is working well :slight_smile: A GUI from AUR. And it is not an update, it is building (or not). I edited the title and the tags accordingly.

AUR packages a generally “unsupported”. The problem is, they are meant for arch, and manjaro is close, but not exactly arch. The second problem is, it is USER repository. So the quality varies. Installing from aur is generally not recommended for inexperienced users. And for the stable branch, which is the furthest from arch code base, is considered even more no-go (that said…i do it i admit, but veeery carefully and only for 2-3 packages).

In that particular case, it fails to build because the gui needs an ancient version of electron (17, and the current is 25). Electron is i piece of sh…cupcake itself, essentially a stripped chromium browser for web apps. In theory, you can also install electron17 also from aur. It may or may not conflict with the current version if installed from the official repos. It may or may not depend itself on other unsupported stuff…it is a fast road to hell, i think you get the idea. Let’s just say your system will not get more stable that way.

So my personal advice is to leave it. Install the normal clamav (you have it) and a very primitive but working gui is for example clamtk. Then i see you use XFCE, so you can make a thunar custom action like this

There are some peculiarities with the realtime daemon and the autoupdate (they are not turned on by default), i cannot help there because i update and use it very rarely only on demand, but there are enough guides for that.

p.s. and it is a good idea to separate the core system updates from experimental aur building, which can fail for many reasons. I do not see in the log what command do you use for update, but for the non-aur stuff it can be sudo pacman -Syu. Then only for aur for example pamac update --aur or yay -Sua
That way if aur build fails it will not break the rest at least.

But that doesnt track.
Electron, in many versions, exists in the AUR.
Why, while building/installing/updating an AUR package can the package manager not likewise download/build/install another AUR package it depends on?
It doesnt make sense … except for just assuming its another eccentricity of pamac.

Though … I do agree that electron in general should be avoided, and its silly to be needed for this interface.

Heck I’ll go further and mention that clamav probably should be avoided by most casual users.

I didn’t read very thoroughly through his logs, to be honest. I saw the dependency problem and commented on that, there might be something else additionally.

Clamav…is not the best with its default definitions anyway…it all depends how much stuff is shared with windows fileshares or users. For occasional file scan… Virustotal does the job for me as a home user.

Its pretty straight forward

This AUR package:

Depends on this AUR package:

But for some reason their AUR helper cannot resolve that dependency:

Why? I dont know.
My best answer is just ‘pamac’.
But I suggested commands to do it using makepkg, and electron17 first for good measure. And that should work. Or at least wont fail to do its expressed job silently.

Don’t bother trying to build electron17, it will take hours and I would not be surprised if it failed.

electron17-bin (binary version) should provide and conflict with electron17, but it does not. If it did, then any decent AUR helper would prompt to choose between the two.

Electron 17 is deprecated, insecure and should not be used. It’s the equivalent of using Chromium 98.

There are other options like @teo mentioned above, however there’s really no point in having ClamAV installed unless you want to scan Windows installations.

1 Like

Furthermore this is what the developer says: I don’t advise you to use the old version which were based on Electron and were laggy as hell. Once released, the v0.4.0 will include full installation intructions and should work on most 64bits common platforms.

1 Like

I wasn’t able to respond more often than I did.

I was using clamav to check the windoze programs on WINE.
WINE was causing more problems than it was worth. So,
a month ago I said, (no more wine) excuse the pun. I reinstalled
Manjaro Xfce from scratch. So, if I need a windoze program I
will put in Virtuebox with a windoze OS, or not all.

I thank you ALL for taking the time and effort to respond to my situation.
You all gave good advice, so, I’m taking all of your advice and use Virustotal as TEO said he does and uninstall clamav.

Thank you ALL Very Much.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.