Cinnamon unknown vendor (monitor)

in the Cinnamon the monitor is shown as an unkown vendor

Can this be changed somewhere?

Moderator edit: Fixed image link to direct link for forums

If the monitor is not identified on Cinnamon it is likely not identified using other systems.

under linux mint it is identified with
there has to be an edit somewhere

It might be related to your Display-Manager settings that doesn’t use the info it should get from talking with your monitor…
(I never used Cinnamon)

PS: rename your topic to include “monitor”, because the title is misleading as-is now…

The vendor name is normally read by the edid file which is located in the monitor… Since Cinnamon uses xorg, try this:

xrandr --prop

If it is not there, then it is unlikely cinnamon can know it.

I almost thought you hit the nail @megavolt because i was thinking about that also but…
When i just tried that command on my system, the output didn’t mention the monitor’s vendor or model…
(While my monitor’s vendor/model is properly mentioned in my display’s info in KDE)

there must be a file responsible that the informartin delivers!?

Maybe check on your Linux Mint install?
Possibly in these folders and copy over to Manjaro?

/usr/share/X11/xorg.conf.d/ or

I’d rather say:
they have a tool (installed and configured - perhaps a script …)
which a standard Manjaro install does not have.

As it happens, I want to install Mint Cinnamon on my fathers laptop, because I never get around frequently enough to keep up with the Arch/Manjaro updates - so I do have an ISO and will boot it up next time I reboot - and check.

I just did a search using my fav search-engine and came-up with this:

  1. Install read-edid

    sudo apt-get install read-edid
  2. Read EDID info directly from SYSFS tree, it should show all detected monitors

    ls /sys/class/drm/*/edid | xargs -i{} sh -c "echo {}; parse-edid < {}"

Which returned me an X11-Config section: Section "Monitor" that included my monitor’s model/vendor names properly.
Hope that helps in someway.

This returned same info:

sudo get-edid -q | parse-edid
Section "Monitor"
	Identifier "LG ULTRAWIDE"
	VendorName "GSM"
	# Monitor Manufactured week 2 of 2019
	# EDID version 1.3
	# Digital Display
	DisplaySize 670 280
	Gamma 2.20
	Option "DPMS" "true"
	Horizsync 30-90
	VertRefresh 56-75
	# Maximum pixel clock is 240MHz
	#Not giving standard mode: 1152x864, 75Hz
	#Not giving standard mode: 1280x1024, 60Hz
	#Not giving standard mode: 1280x720, 60Hz
	#Not giving standard mode: 1600x900, 60Hz
	#Not giving standard mode: 1680x1050, 60Hz

	#Extension block found. Parsing...
	Modeline 	"Mode 11" 148.50 1920 2008 2052 2200 1080 1084 1089 1125 +hsync +vsync 
	Modeline 	"Mode 0" 185.58 2560 2624 2688 2784 1080 1083 1093 1111 -hsync -vsync 
	Modeline 	"Mode 1" 148.50 1920 2008 2052 2200 1080 1084 1089 1125 +hsync +vsync 
	Modeline 	"Mode 2" 148.500 1920 2008 2052 2200 1080 1084 1089 1125 +hsync +vsync
	Modeline 	"Mode 3" 74.250 1280 1390 1420 1650 720 725 730 750 +hsync +vsync
	Modeline 	"Mode 4" 27.027 720 736 798 858 480 489 495 525 -hsync -vsync
	Modeline 	"Mode 5" 74.250 1920 2448 2492 2640 1080 1082 1089 1125 +hsync +vsync interlace
	Modeline 	"Mode 6" 27.000 720 732 796 864 576 581 586 625 -hsync -vsync
	Modeline 	"Mode 7" 74.250 1920 2008 2052 2200 1080 1082 1087 1125 +hsync +vsync interlace
	Modeline 	"Mode 8" 148.500 1920 2448 2492 2640 1080 1084 1089 1125 +hsync +vsync
	Modeline 	"Mode 9" 25.200 640 656 752 800 480 490 492 525 -hsync -vsync
	Modeline 	"Mode 10" 74.250 1280 1720 1760 1980 720 725 730 750 +hsync +vsync
	Modeline 	"Mode 12" 74.25 1920 2008 2052 2200 540 542 547 562 +hsync +vsync interlace
	Modeline 	"Mode 13" 74.25 1280 1390 1430 1650 720 725 730 750 +hsync +vsync 
	Modeline 	"Mode 14" 27.00 720 736 798 858 480 489 495 525 -hsync -vsync 
	Option "PreferredMode" "Mode 11"

(Ofcourse on Manjaro you need to use another way to install said package because you don’t use apt, which is debian style…)


I don’t have mint installed, just trying it out.

i installed the package.
However, the command returns no result, it just loads all the time

Well, what DO you have installed?

The screenshot is from System Settings → Color Profiles in Mint Cinnamon.
And you asked why you could not see the Name of your Monitor there.

I don’t see my monitor there at all, neither the built in nor the external.

In System Settings → Display
both monitors are shown with their proper names.

In EOS Xfce4 as well as in Mint Cinnamon.

Did you just look in the wrong place and lead us on a wild goose chase?
You looked for color profiles.
That is where your screenshot is from.

→ “Farbprofile” vs. “Anzeige”

It was not my intention to send anyone on a “wild chase”!
I just wanted to know if you can change the unknown monitor somewhere. If not, that’s not too bad.

I installed Cinnamon and the screenshot is from Control Panel → Color.

I know.

What I tried to say:
Control Panel → Display
will (likely) show your monitor name

Du hast in den Farbprofilen den Namen vermisst.
Da hab ich auch keinen.
Aber unter “Anzeige”, da wo er u.U. wichtig ist, ist er da.

Yes, it is displayed correctly under Display.
I can live with that.

Color profile(s) are of no interest to me.
Never have used them.

You described your issue as a monitor recognition problem - which it was not.
It was actually a (even to you uninteresting) issue with color profiles.
That’s what I meant with “wild goose chase” - we and you where looking in the wrong place.

Oh well, it happens. All good.

Please close this topic due to user-error…

Stupid question: how do I close this topic?