Cinnamon unable to rename compressed files

Don’t know if it’s a Cinnamon issue specifically or what. But now anytime I try to compress a file, it no longer renames it, so no matter what I type it’ll still just try to keep whatever name it sticks with, usually the original folder name. So it’ll always ask to overwrite it even when it’s supposed to rename it.

I can confirm that this new bug in File Roller is also here on my Cinnamon Desktop…

I found a workaround!
You have to click on the directory symbol right to the name (and the pen symbol), then it will open a new small window to choose the destination of the file.
And only there, if you change the default name given, it will stay and be applied.

If this is actually a confirmed a bug in fileroller, will you please provide a link to it so that others can monitor its progress?

Of course, here you go:
Filename no longer changes when renaming and compressing.

But as one is still able to change the default name to another of his choice (even if you need now to go through one further step to do this, as shown in my post above), I’m starting to ask myself if it’s really a bug per se, or rather a new “feature”, as it is actually a program made for GNOME…
That wouldn’t be the first radical change made in it, to suit The GNOME Way :wink:
We shall see…

Edit: it seems I was unfair with GNOME’s devs on this one and it was indeed a bug, because I just noticed a commit with a fix was made (from what I can understand, as I’m not a programmer), and rather very quickly (4 days ago), which is nice!
Here it is: Fixed filename not changed when creating a new archive
Still, that doesn’t change my opinion on some other changes they made in the past, and why I choose to use Cinnamon on my main computer years ago, but to each their own…

1 Like

Indeed. Now, you just need to wait for the fix to filter down to the lower levels.

Aside:- Gnome was likely the first DE I used with Linux (many years ago); as no doubt it was for many; progressive design decisions ultimately soiled the user experience (for me). While there may arguably be valid reasons for Gnome’s walled-garden-esque approach, it tends to serve the developer perspective rather than that of the user, in my opinion.


Yes, and the waiting won’t be that hard: I wish every bug would have 2 easy workarounds (the one in my post above, or simply renaming the file once it’s done) and a fix commited in just 4 days! And once it’s available in Arch, it won’t be that long before it’s there in Manjaro, so that’s not much trouble…

I second that entirely! After testing Linux with a Knoppix Live CD in 2002, my first installed distro was with GNOME too (as I always found KDE to “messy” for my taste). I even liked the first iterations of the new “shiny” GNOME, compared to the “old” one (beside the fact that it was more ressources hungry), but the choices made version after version made me switch to Cinnamon, and I don’t regret it…
But that’s the beauty of FOSS: if you don’t like something, try something else, there are enough choices out there…

I used Enterprise Linux flavours back then; one always had a choice of using Gnome, Gnome or maybe even Gnome (not much else was stable on EL).

Aside:- In 2022/23, I began using Rocky Linux (EL9) in a VM for the sake of interest, and soon found a Rocky KDE distribution which was quite impressive (I use KDE mostly, no matter which OS I install).

KDE (today) is much better than it was in its early years. :sweat_smile:

Regarding the fileroller, since the last update I have the problem that I can no longer extract files via drag and drop. Does anyone else have the same problem?

For my job, I have to keep track of more distros than just Manjaro, and when done right, like in openSUSE and Mageia, I must admit that I find KDE almost bearable now :+1:

To be honest, I never used this method to extract a file and not even knew it was possible, but I just did the test, and indeed, that’s not working, neither in a file I received nor in one I created, and neither in a .tar.gz nor in a .zip!

But adding a file by drag and drop in the archive still works for both type of files, though…
So you might want to open a ticket for that, if lucky it will be solved as quickly as the renaming bug (link to GNOME’s GitLab in my post above).

Ok, thanks for your response

Everyone does.

There’s been one for 5 years:

However, there’s some progress:

So it certainly worked about a week ago…or rather, I’ve never done it any other way

By the way, the fix is included in file-roller 44.3. As soon as the Arch Package Maintainers have time to update it, we’ll have it synced in the Manjaro unstable branch.

Note to self: next time in such a case, using the sentence “So you might want to check if there already is a ticket for that, or else open one” :wink:

Thanks for the heads-up, on both subjects :+1:

1 Like