Cinnamon Desktop broke after trying to use a video wallpaper

I wanted to use a video wallpaper and tried komorebi, vlc, variety and other option that I don’t remember, that was 2 days ago and I just noticed that if I right click the desktop the menu doesn’t show up and the desktop icons are also hidden, if I install komorebi the trash bin and my files show again but I don’t want to use komorebi anymore because, already tried rebooting, updating everything, reinstalling and uninstalling the packages but can’t get it to work

I don’t have or use Cinnamon
Have you tried setting a different wallpaper(via the cinnamon settings)?
… like a simple picture from the standard collection that should be there?
I’d think so, but can’t be sure.
You also didn’t say how and from where you installed that wallpaper which you now don’t want anymore.
… and what you did to remove it …

Sorry if I didn’t explain myself well, I “tried” putting a video wallpaper using the mentioned apps, never got it to work and uninstalled them, for example, I installed komorebi, tried to setup the wallpaper, didn’t get convinced on how it looked/worked or didn’t even got it to work well and then I uninstalled komorebi, searched for a different solution (let’s say vlc) tried to do the same, etc…
And yes, I tried setting different wallpapers and they change, the problem is the icons, I can’t see them and if I try right clicking on the desktop the menu to create file/folder, open terminal, change wallpaper, etc doesn’t show up
And I installed the apps normally, sudo pacman -S variety/vlc, yay -S komorebi-bin and the last one I don’t remember if I used pacman or yay since I don’t even remember what I installed, removing them was the same at first, sudo pacman -R variety but I tried reinstalling them and uninstalling using sudo pacman -Rcns to see if the dependencies were causing an issue but no luck

The only thing I could suggest without being able to test it - because I don’t run Cinnamon - is:
look through the hidden files in your (also hidden)
directory - and look for cinnamon specific folders and names of the offending programs that you installed and then removed
and remove them manually
Uninstalling programs will not remove these.

The “nuclear” option would be:
reset to defaults (if there is such a thing available in cinnamon)
To achieve that manually:
look at the files and directories in
and use these to replace the corresponding files in your /home/$user directory
Can’t be more specific -
perhaps someone using Cinnamon will have something …

Have you tried using cinnamon themes option to apply a theme or change the icons to see if that works? It may recreate any folders/configs that are missing

I deleted the folders and rebooted but no luck sadly, also tried the nuclear option (manually) and still the same
Also tried using Themes and change through various themes (preinstalled ones and adpata nokto manually installed) but no luck
Maybe one of the programs I installed broke the desktop package? It’s the only thing I can think of rn

Edit: Used timeshift to restore all the backups I had and none of the solved the issue, not even the one I had with no modifications and is from the fresh install so the problem is probably in the configs inside home (/home and /root are not backed up), don’t know if the info helps

In Cinnamon, the background images are stored in /usr/share/backgrounds
But the configuration files (xml) are stored in /usr/share/gnome-background-properties
The XML files is what shows on the menu of wallpapers, they point to the images in /usr/share/backgrounds.

Verify those are there first.

1 Like

They are there, and like I said, the problem is not the background image, I can change it from the settings and all default backgrounds are still there, the problem is that icons, files and the menu that appears when you right click the background won’t show up, also, going to Settings → Desktop and trying to do anything doesn’t help, the layout is on “Show desktop icons on primary monitor only” but the other 2 options doesn’t change anything and I tried enabling “Show icons from missing monitors” but it doesn’t work

OK, first thing is to eliminate wether it is a system issue or a user account issue. Create a new user and see if everything is as it should be. If it is, then your issue is in your user config files, usually copying the contents of the /etc/skel to your home directory should fix the issue.

If the issue is still there in the new account, you will need to reinstall cinnamon dekstop.

1 Like

The new user has no problems with the desktop, I tried backing up all the files (only the ones that the test user also had) and copying the files from the test user and rebooting but the problem is still there in my user, don’t really know what to do know, I’ll try backing up the other files and deleting them to see if that changes anything

Don’t know the reason but copying the files from the test user didn’t solve the issue, but deleting everything did solve it, the folder for .mozilla, .java, .gradle, etc and other apps didn’t needed to be deleted so I can keep the configs for my apps, I made a backup of everything, deleted them, rebooted and it works now, don’t really know why copying them from /etc/skel or from a new user didn’t solve the issue but at least it works now

OK, the contents of /etc/skel/ are the template used to create user accounts. Since now you know something in your user directory is the issue, copy all of the hidden files and directories to your home directory or at the very least “.cinnamon”, “.local”, and “.confg” , but you will loose any modifications or configs from other applications.
As always, make sure you have a backup of your data.

If worst comes to worst, you can give your test user admin rights, delete your old user and then create the user again. Again, make sure you have a back up of your data!

Already solved it with “basically” the same thing you said, I made a reply with how I solved it in case you’re curious, thank you so much for the help, with how easy it was to diagnose I’m a little ashamed for not being able to solve it myself but just switched from windows to manjaro and I’m not familiar with how the O.S. works, also, thanks sawdoctor and Nachlese for the help <3

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.