Chuwi minibook x - Gnome/Bluetooth issues

Hi everyone,

Recently just purchased a chuwi minibook x to just have a play on linux, im really enjoying manjaro so far, definitely my favorited distro ive come across, especially with gnome!

I apologise for my lingo upfront im still coming to terms with the terminology!

Ok so i have no bluetooth essentially, i try turning the radio button on and it flicks right off and does nothing.

Ive tried a couple of things from forums but nothing. (rfkill unblock bluetooth) and tried restarting the service but nothing.

Wondering if it could be a limitation of my minibook hardware?


Probably check this:

sudo dmesg | grep -i bluetooth

Thanks for the reply, so i followed what was mentioned in that post, im getting this on the dmesg

[ 2444.663788] usbcore: deregistering interface driver btusb
[ 2455.038361] usbcore: registered new interface driver btusb
[ 2455.039811] Bluetooth: hci0: Device revision is 2
[ 2455.039817] Bluetooth: hci0: Secure boot is enabled
[ 2455.039818] Bluetooth: hci0: OTP lock is enabled
[ 2455.039819] Bluetooth: hci0: API lock is enabled
[ 2455.039820] Bluetooth: hci0: Debug lock is disabled
[ 2455.039820] Bluetooth: hci0: Minimum firmware build 1 week 10 2014
[ 2455.039822] Bluetooth: hci0: Bootloader timestamp 2019.40 buildtype 1 build 38
[ 2455.039848] Bluetooth: hci0: Failed to load Intel firmware file intel/ibt-0040-1050.sfi (-2)
[ 2455.040823] Bluetooth: hci0: Reading supported features failed (-56)
[ 2455.040827] Bluetooth: hci0: Error reading debug features
[ 2455.041794] Bluetooth: hci0: Failed to read MSFT supported features (-56)

Looks like the requested firmware for your device is not there.

When I read this: It seems that a symlink of

  • ibt-1040-4150.ddc → ibt-0040-1050.ddc
  • ibt-1040-4150.sfi → ibt-0040-1050.sfi
cd /usr/lib/firmware/intel
sudo ln -s ibt-1040-4150.ddc ibt-0040-1050.ddc
sudo ln -s ibt-1040-4150.sfi ibt-0040-1050.sfi

Make it work.

:warning: Or an upgrade to the kernel 6.5 could have a fix for that, as one mentioned that an upgrade to 6.4-rc7 fixed it.

Wow thank you, those commands fixed it, this might be naive of me but as a new guy would you mind explaining what that is actually doing?

It simply creates a symbolic link of each file. So when the module searches for ibt-0040-1050.sfi it will find it, but open ibt-1040-4150.sfi.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.