Chuwi herobook air rtl8723bu disable only bluetooth, but still allow BT dongle

I have a chuwi herobook air, a cheap netbook, that I use mostly for light browsing. The thing works pretty well (for the price), except for the constant struggle between bluetooth and wifi: With the internal card (a rtl8723bu wifi/bt chip, apparently), any bluetooth activity means no wifi, at all.
Since the rtl8xxu is already blacklisted, and using an USB BT dongle solve the problem, I mostly gave up on using the internal bluetooth for the USB one. Unfortunately, the netbook’s BIOS is a disaster (it’s a really cheap netbook) and does not allow to disable it.

My problem is somewhat simple: How can I permanently disable the internal BT in favor of the usb dongle without disabling the wifi with it?

Right now, connecting anything means manually activating bluetooth, erase the device I want t connect from the list, disable the internal card and add the device while the wizard complains it can’t connect (but yet still can).
(If I don’t, everything will try, and fail, to connect using the internal BT card. Hell, I can’t even choose which card I want to use when connecting a new device)

Anything I’ve found by googling is either disabling bluetooth entirely, using a hacky driver for an old kernel (and I’m not even sure it solve the same problem), or blacklisting rtl8723bu (Which I guess means losing wifi too).

I’ll try to dig up a wifi dongle, to see if the problem is easier to solve that way around…

Many laptops have the ability to disable the onboard wifi with in the BIOS. If you disable it there, you can use a USB dongle.


In terminal, type lsusb to give you output and details of your internal Bluetooth.

Then create a new file/udev rule to disable the internal Bluetooth via terminal or your favorite text editor; save, reboot.

This should just disable the device Bluetooth driver, not the entire device.

This is where I got the solution.

1 Like

Do you use the kernel driver from the repo? It was added years back to support a specific lowcost win-book.

Just tried it: It disables the whole chip, not just the bt part.

Yes, the alternate driver is also blacklisted, so it is the only one that could be used for the chip…

Ok so a modprobe later, and I see a (slight) improvement in bt/wifi cooperation (bt still hammer wifi down, but there is some data going though)…So, despite rtl8xxu never being loaded, I could “use” the thing while 8723bu was not loaded either…? That doesn’t seems logical. I added it to modprobe.conf anyway.

I still can’t connect more than one BT device at a time (no matter the device), but one step at a time…

Ok so now typing with my bt keyboard while using a bt mouse and bt headphone while listening to a video… and everything automatically works on the external BT dongle.
What did I do? No clue: I added 8723bu to modprobe.conf, installed bluez-tools and bluez-utils and somehow it not only decided to work, but it also set the “correct” bt device as the default one…
I’m thinking installing bluetoothctl was what did the trick (it can set the default adapter), but I wouldn’t bet on it.

This topic was automatically closed 3 hours after the last reply. New replies are no longer allowed.