Chromium won't launch on Xfce

Chromium will not launch on my Xfce guest. This is not my usual browser, so I can’t recall how well it worked before. I have tried updating, uninstalling and reinstalling, etc. via pacman with no change.

Trying to open it in the terminal shows this.

[edj@kase ~]$ chromium
[0201/] open /sys/devices/system/cpu/cpu0/cpufreq/scaling_cur_freq: No such file or directory (2)
[0201/] open /sys/devices/system/cpu/cpu0/cpufreq/scaling_max_freq: No such file or directory (2)
Trace/breakpoint trap (core dumped)

Running chromium --diagnostics shows it passes all tests.

For comparison’s sake, I also have it installed on my KDE Plasma guest. Those missing files don’t exist at those locations there either, but this doesn’t seem to be a problem on that client.

I have had issues with Chrome based browsers crashing due to some themes. If you have changed any themes from the default ones try reverting and see if the crashes still happen.

OK, progress. I removed Chromium with sudo pacman -R chromium. Then, I deleted the ~/.config/chromium directory. Upon reinstalling, it launched correctly.

Had some issues with not being able to resize the window until turning on the Appearance > Use system title bar and borders setting. Perhaps that’s some of the theme weirdness mentioned above.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.