Chromium should not change default browser

there is no automatic setting for this in the chromium options – the UI seems to be designed for setting default manually only. nevertheless it sets itself as default every couple of times i open it. this is not reproducible at every start of chromium.

i would like firefox to stay default and just need chromium for web compatibility testing.

i’m using kde plasma – default browser is correctly set to firefox in kde control center’s “default applications”

most browser installers has changes mimetypes - that includes chromium

chromium has a setting for checking on startup

I use a custom script when I need to set a browser. search for

thanks! i give the script a try.

how to keep chromium from changing this setting every couple of days? i did not update chromium recently. also there is no way to configure this behavior – chromium settings just have this:

maybe making ~/.config/mimeapps.list read-only? but that might break other things i guess

is there a bug tracker issue somewhere (upstream) about this?

found in a few places that modifying chromium’s starter (.desktop entry) and change its argument from %U to -no-default-browser-check %U should do the trick. i will try that as well.

anyways, if someone knows an issue tracker entry for this, please let me know. this is underhanded behavior that was annoying on windows as well until microsoft protected this setting to be only accessible from the system settings. in my opinion distributors could and probably should patch that out in their own browser builds to make sure this doesn’t happen without user interaction.

If you answered No - the first time around Chromium asked about default - then it will never show again.

If you modify system launchers /usr/share/applications - your launcher will be overwritten on next update.

To avoid that copy the launcher to ~/.local/share/applicaitons and modify the local file.

chromium just set itself default without asking for consent. i only realize that later when opening links from e.g. signal-desktop or thunderbird. i can’t easily reproduce it as it seems this behavior “sleeps” for a few days until it occurs again.

today i used the kde settings to change default browser back, not via firefox as usual, and chromium displayed this question banner, which i haven’t seen in a long time. there is no “no”, just an “x” button if i remember correctly.

thanks! i used kde’s menu editor to change the arguments and suppose that should create a local copy.

hopefully this will be solved for me now, but i’m not confident that this issue is solved in general, because it’s at least an UX issue. that’s why i am looking for a way to report an issue somewhere or give feedback on such, so that this gets solved for everyone once and for all.

i have the impression google is cheating in driving their browser usage up because at some point most people stop bothering in setting their default browser back to their preferred one.

I have Firefox as my default - with Vivaldi and Chromium as secondary - and I never get any queries on default browser.

If I install e.g. Microsoft Edge then the mimeapps.list gets modified to use microsoft-edge-dev - it is then just a matter of executing firefox.desktop

When you install a browser - the browsers installation scripts will assume you installed the browser to use it - thus it will change the associations required to launch as default.

Whether you want it to be default or not - the installation cannot know if it is the only browser - thus it assumes it is - otherwise users would complain that mime types was not associated despite they just installed the browser.

If you do not want the just installed browser to be default - you will have to change your settings.

How you do that - depends on you.

I created the shell script a long time ago to accomplish exactly that.

All the information you need, including bug reporting procedure, is at

Issue tracker itself is at

I will say that this is a very strange issue because Chromium should never change the default browser without asking first and if it was then I’d expect many people to be complaining very loudly…

Usually the browsers themselves have very little power and even if you use their interface to ‘Set as Default Browser’ it wont actually do anything and you would have to make those adjustments in your DE or manually in the configuration files.

this is getting weirder and more annoying now and it does not seem to be just chromium related. i recently installed vivaldi as alternative second browser (for web development i need a webkit browser for testing only), because of this problem and guess what i’m dealing with every day now

now i also have to change my default e-mail program every day back to thunderbird as well when setting firefox back as default browser. i did not even open vivaldi in the days since i installed it. something is manipulating the default settings periodically. how can i trace back the cause of this? maybe some tool to log access by processes to specific files?

that’s the behavior windows is following in recent years. it would be great if linux would behave the same. as it stands now there is no difference if i use kde system settings, @linux-aarhus script or the in-browser option to set default.

1 Like

it seems signal-desktop breaks .config/mimeapps.list in a certain condition. this is what the file looked like just now:

[Default Applications]
[Added Associations]

this condition occurs when you launch two instances of signal with different --user-data-dir=… path within a second (in my case using two custom .desktop files). if you have multiple phones with signal connected and have the habit to start the desktop apps more or less at the same time you might run into this. starting the two instances with a few seconds delay should be enough to avoid this.

signal-desktop is built by the manjaro arm team (@Darksky) so i don’t think upstream would even look into it if i report it on my own :thinking:
what’s the procedure here now?