Chromium: Can't enable Video encoding: Hardware acceleration

amd rx 550 and brave Version 1.34.81 Chromium: 97.0.4692.99 (Official Build) unknown (64-bit)

i cant enable Video encoding: Hardware acceleration

if i do using flag --enable-features=VaapiVideoEncoder it disables accelerated video decoding

any ideas?

Graphics Feature Status
Canvas: Hardware accelerated
Canvas out-of-process rasterization: Enabled
Compositing: Hardware accelerated
Multiple Raster Threads: Enabled
Out-of-process Rasterization: Hardware accelerated
OpenGL: Enabled
Rasterization: Hardware accelerated on all pages
Raw Draw: Disabled
Skia Renderer: Enabled
Video Decode: Hardware accelerated
Video Encode: Software only. Hardware acceleration disabled
Vulkan: Enabled
WebGL: Hardware accelerated
WebGL2: Hardware accelerated

Problems Detected
Accelerated video encode has been disabled, either via blocklist, about:flags or the command line.
Disabled Features: video_encode

@Omh Everyone has their own set of flags so here’s mine:

.config/chromium-flags.conf
--force-dark-mode
--enable-features=WebUIDarkMode
--enable-features=VaapiVideoEncoder,VaapiVideoDecoder,CanvasOopRasterization
--enable-zero-copy
--use-gl=desktop
--ignore-gpu-blocklist
--enable-oop-rasterization
--enable-raw-draw
--enable-gpu-rasterization
--use-vulkan
--disable-reading-from-canvas
--disable-sync-preferences
Related stuff

Full Report - https://0x0.st/oXaM.txt

Inspired by chromium: hardware video acceleration with VA-API (Page 26) / Applications & Desktop Environments / Arch Linux Forums

1 Like

Hardware acceleration for video encoding is not available in Linux, as far as I know.
Unfortunately, when searching for more information on that topic, Artificial Intelligences strikes and modifies your search, replacing encode by decode :frowning:

Here’s what chrome://gpu usually says in the Linux versions of chromium:

However, @ishaanbhimwal apparently has a solution:

1 Like

i use brave ,also cant see saturn on this page ,main window is black ,disabled vulcan to no avail

firefox without hardware accel renders page fine

Here’s my ~/.config/chromium-flags.conf:

--disable-software-rasterizer
--disable-gpu-driver-bug-workarounds
--disable-gpu-driver-workarounds
--disable-gpu-vsync
--disable-features=UseOzonePlatform
--disable-reading-from-canvas
--enable-accelerated-2d-canvas
--enable-accelerated-video-decode
--enable-accelerated-mjpeg-decode
--enable-features=VaapiVideoEncoder,VaapiVideoDecoder,CanvasOopRasterization
--enable-gpu-compositing
--enable-native-gpu-memory-buffers
--enable-gpu-rasterization
--enable-oop-rasterization
--enable-raw-draw
--enable-zero-copy
--ignore-gpu-blocklist
--use-gl=desktop
--num-raster-threads=6

Found something for brave:

Can you confirm if it’s working on chromium or not? Verify the settings for VA-API by running vainfo. Also install vdpauinfo to verify if the VDPAU driver is loaded correctly. More info.

1 Like

I use Brave

so i used these flags to brave launcher

--use-gl=desktop --enable-features=VaapiVideoDecoder --disable-gpu-driver-bug-workarounds --enable-features=VaapiVideoEncoder,VaapiVideoDecoder,CanvasOopRasterization

on brave://flags/

enabled these

#ignore-gpu-blocklist

#enable-gpu-rasterization

#enable-zero-copy

#enable-vulkan

#canvas-oop-rasterization

and brave://gpu/ reports

Graphics Feature Status
Canvas: Hardware accelerated
Canvas out-of-process rasterization: Enabled
Compositing: Hardware accelerated
Multiple Raster Threads: Enabled
Out-of-process Rasterization: Hardware accelerated
OpenGL: Enabled
Rasterization: Hardware accelerated on all pages
Raw Draw: Disabled
Skia Renderer: Enabled
Video Decode: Hardware accelerated
Video Encode: Hardware accelerated
Vulkan: Enabled
WebGL: Hardware accelerated
WebGL2: Hardware accelerated

edit disabled vulcan for now as some pages render with problems

Looks like it is not only the Artificial Intelligence but the natural one as well that is not able to cope with encoding vs. decoding :smiley:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.