Chrome: Cannot select mnt server connections for upload download

When I want to save something from chrome or upload I get this window:

However in Dolphin I have my mnt connections and can select them:

They don’t show up in the selection window of google chrome.

As A workarround I copy files first to desktop from the server and then to chrome which is quite annoying.

The weired think before I used Manajaro I had KDE Neon. There Chrome could directly access mnt paths.

Am I missing something here?

What happens if you click Other Locations? Does it show your mounts there?

I’m on Cinnamon and I agree, the file dialog (in Nemo too) not showing mounts by default is a bit annoying. Haven’t investigated, just worked around it, but I wonder if this is configurable…

Unfortunately It only show the hard drives there:

Inside “Computer/Filesystem/mnt/” should be your mount points.

You are right I found it there. Many thanks.

When you are using GTK based system then ensure you have the package gvfs installed. Then in your mount define - fstab or mount units - add x-gvfs-show to your options section - reboot or reload your mounts.

1 Like

It is a tad annoying… I set my ‘locations’ Downloads goes to my /mnt/SSD straight away if I select Downloads - set one of the default locations to your /mnt drive and it’ll work, then you can open the downloaded folder location and move it anywhere else.

It’s a bit annoying you don’t get the familiar Dolphin ‘places’ to choose from when initiating the download.

Maybe I am misunderstanding or there is some other issue, but this doesn’t quite work for me. I have a drive mounted through a mount unit. I have the x-gvfs-show option enabled. gvfs package is installed.

When I open Nemo, the drive is listed under devices, like so:

When I open the file dialog, for example saving in Firefox, it shows a limited number of default folders in my home folder, like so:

Yes, the mounted drive is available under Other Locations but doesn’t show up in the default folder list. So how would you get mounts to show up in the default file dialog? Or basically any folder other than the default ones?

[Edit: heh, that was dumb, of course you can add a folder to the bookmarks and it shows up. You can do this too with the folder where the mount sits. So I guess you need to manually tweak the bookmarks to make the file dialog quick to use…]

The file dialog is not part of nemo - it is part of the toolkit - in this case GTK.

Dolphin is based on Qt toolkit - which has a different implementation of the file dialog component.

You have limited options for adjusting the base file dialog and those option requires use of dconf. There is a GUI editor for dconf entries - available from the dconf-editor package.

When you have installed the package - launch dconf-editor either from terminal or your menu system - then explore your options by navigating to


Because the file dialog is not a part of Nemo itself it does not know about which devices are mounted and where - instead it requires you to know where to save the file - e.g. by using the +Other locations then navigate the structure of your system.

As you found - you can add the folder where your mount point reside to favorites/bookmarks - and if I recall correct those bookmarks/favorites are global to GTK - which will make then show up in the file dialog.

Ah, understood! However, I don’t see settings to tweak the default folder list in the dconf-editor GUI. That might be hidden somewhere else in the GTK settings…

that is - because that explicit property - doesn’t exist :slight_smile:

Adding bookmarks it is then. Thanks for clarifying! Learned some stuff which is always good. Now to find a way for my aging brain to remember it for the next time :wink:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.