Chrome and Discord crashes after sleep

I have just started transitioning from Windows to Linux. I have them set up in dual-boot with two separate disks.

I’m relatively new to Linux but want to try it for the higher level of customization.

The problem I’m facing is that when waking up from sleep I get the message:

Desktop effects were restarted due to a graphics reset

plus Chrome and Discord both crash. Discord is just not there, while Chrome is fully unresponsive. both of these work just fine when I start them again.

output of inixi --full

  Host: GLaDOS Kernel: 6.3.5-2-MANJARO arch: x86_64 bits: 64
    Desktop: KDE Plasma v: 5.27.5 Distro: Manjaro Linux
  Type: Desktop Mobo: Micro-Star model: MAG B550 TOMAHAWK (MS-7C91) v: 2.0
    serial: <superuser required> UEFI: American Megatrends LLC. v: A.C0
    date: 03/06/2023
  Info: 8-core model: AMD Ryzen 7 5800X bits: 64 type: MT MCP cache: L2: 8 MiB
  Speed (MHz): avg: 2641 min/max: 2200/4850 cores: 1: 3312 2: 3058 3: 2883
    4: 2200 5: 2200 6: 2200 7: 2200 8: 3026 9: 2912 10: 2200 11: 2200 12: 2200
    13: 2200 14: 2888 15: 3681 16: 2899
  Device-1: NVIDIA GP106 [GeForce GTX 1060 6GB] driver: nvidia v: 530.41.03
  Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.1 driver: X:
    loaded: nvidia gpu: nvidia s-res: 5760x1263
  API: OpenGL v: 4.6.0 NVIDIA 530.41.03 renderer: NVIDIA GeForce GTX 1060
  Device-1: NVIDIA GP106 High Definition Audio driver: snd_hda_intel
  Device-2: AMD Starship/Matisse HD Audio driver: snd_hda_intel
  Device-3: Razer USA Barracuda X driver: hid-generic,snd-usb-audio,usbhid
    type: USB
  API: ALSA v: k6.3.5-2-MANJARO status: kernel-api
  Server-1: PulseAudio v: 16.1 status: active
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    driver: r8169
  IF: enp4s0 state: down mac: d8:bb:c1:3c:ed:b1
  Device-2: Realtek RTL8125 2.5GbE driver: r8169
  IF: enp42s0 state: up speed: 1000 Mbps duplex: full mac: d8:bb:c1:3c:ed:b0
  Local Storage: total: 2.5 TiB used: 13.19 GiB (0.5%)
  ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 980 PRO 500GB
    size: 465.76 GiB
  ID-2: /dev/sda vendor: Western Digital model: WD2003FZEX-00SRLA0
    size: 1.82 TiB
  ID-3: /dev/sdb vendor: Crucial model: CT250MX200SSD1 size: 232.89 GiB
  ID-1: / size: 43.99 GiB used: 11.6 GiB (26.4%) fs: ext4 dev: /dev/sdb3
  ID-2: /boot/efi size: 511 MiB used: 300 KiB (0.1%) fs: vfat dev: /dev/sdb1
  ID-3: /home size: 143.02 GiB used: 1.59 GiB (1.1%) fs: ext4 dev: /dev/sdb4
  ID-1: swap-1 type: partition size: 41 GiB used: 0 KiB (0.0%) dev: /dev/sdb2
  System Temperatures: cpu: 51.8 C mobo: N/A gpu: nvidia temp: 54 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 0%
  Processes: 344 Uptime: 46m Memory: available: 31.27 GiB
  used: 6.65 GiB (21.3%) Shell: Zsh inxi: 3.3.27

Being able to use sleep is important to how I use my PC so disabling it is not an option sadly

If you need any other info please ask as I don’t really know what other information would be useful here.

Thanks in advance!

I have found the following errors after reading the output from journalctl --catalog --no-pager -S "2023-06-18":

jún 18 18:26:53 GLaDOS discord[1036]: [0618/] opendir /home/dpeter99/.config/discord/Crashpad/attachments/f4adbbab-db93-4b17-bc50-eb4846e53cd6: No such file or directory (2)
jún 18 18:26:53 GLaDOS discord[1415]: [1415:0618/] GPU state invalid after WaitForGetOffsetInRange.
jún 18 18:26:53 GLaDOS discord[946]: [946:0618/] GPU process exited unexpectedly: exit_code=512
jún 18 18:26:53 GLaDOS discord[946]: (electron) 'gpu-process-crashed event' is deprecated and will be removed. Please use 'child-process-gone event' instead.

probably an issue of the latest update. try the 2 commands below. it doesn’t harm anyway and might be a fix.

sudo pacman -Rdd xdg-desktop-portal-gnome
sudo pacman -S xdg-desktop-portal-kde

I had the same issues with my discord as well, same logs as well.

However, the 2nd command Olli listed worked for me.

Hope it works for you as well. Good luck!

Well, worked once…oh well.