Choppy & distorted video/audio in Manjaro VM

I recently got Manjaro set up in a virtual machine. Everything seemed to go fine until I started actually watching videos. First I went on YouTube and noticed the audio (and to a lesser extent, the video itself) was very choppy and sometimes distorted. I thought it may have just been YouTube so I tried on Odysee, but I had the same problem there. I thought it might be uBlock Origin being funny (since it’s the only extension I had) so I opened YouTube in an incognito tab where no extensions are used, but the problem persisted. I then opened a YouTube video as an MP4 within my browser using AllTube Download and it was still choppy. I then thought it may be an issue with my browser so I downloaded the MP4 instead and played it in MPV, but the video was just as choppy as it was in my browser.

I thought I might need to install Guest Additions, but I remembered that when I was starting Manjaro for the first time I could’ve sworn I saw the words “Guest Additions” fly by my screen as it was booting. To confirm it was in fact installed, I followed a guide which was supposed to show you if guest additions was installed. Unfortunately I’m unable to link it but it basically tells you to run $ lsmod | grep -i vbox and if you have guest additions installed, your output should look like this:

$ lsmod | grep -i vbox
vboxvideo              12612  1
drm                   264190  2 vboxvideo
vboxsf                 43659  0
vboxguest             214867  7 vboxsf

and that’s what my output looks like, so it seems like I do have guest additions installed.

To make sure this wasn’t just an issue with VirtualBox I tried out Lubuntu and Ubuntu virtual machines. I found that I also had audio issues with Lubuntu (though it was more distorted and less choppy than Manjaro) but didn’t have any audio issues with Ubuntu- and both of those VMs were without guest additions. I’m not sure what to make of Lubuntu since it’s odd I would also have audio issues there, but if that indicated that this was an issue with VirtualBox it doesn’t make much sense that Ubuntu ran perfectly fine.

I also asked this question on Reddit and the only response I got was to check how many resources I provided the VM with. But I provide my VM with 4GB of RAM, 2 processors, and maxed out video memory at 128MB- so I don’t think that’s the issue.

Here’s some software information in case it matters:

  • Host: Windows 10 Pro version 21H2
  • Hypervisor: VirtualBox 6.1.36
  • Guest: Manjaro XFCE Ruah 21.3.6 (minimal proprietary install)
  • Browser: Chromium 104.0.5112.79-1
  • Media player: MPV 1:0.34.1-5

open your manjaro, from there a console and install the guest-utils

sudo pacman -S virtualbox-guest-utils

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.