Chinese font fangSong-GB2312 font Garbled code after bold

Problem description

My work requires FangSong_GB2312 font. When I tried to make FangSong_GB2312 font bold in WPS, the font turned into garbled characters, which looked like black irregular squares. I would like to consult with you, thank you!

Other instructions

  • WPS software
yay -S wps-office-mui-zh-cn wps-office-mime-cn wps-office-cn wps-office-fonts ttf-ms-fonts  ttf-wps-fonts

It was solved with downgrade freetype2 (from 2.13.1 to 2.13.0). The reason for this is the use of fakebold(fonts that are not bold themselves are specified as bold).

Downgrading packages is not a solution. However, temporarily doing so to workaround an issue until upstream fixes it is fine. Please let us know when there is actually a solution.

1 Like

Just found out that someone has reported this problem, but I just know what can I do?

How do you know it’s the same problem? They did not provide enough information and never followed up, so the bug report was closed.

Perhaps you can answer the questions Toolybird asked since De-conf never did:

A reminder, AUR pkgs are not supported here. Can you reproduce with an official repo pkg?

Have you made any special font configuration changes on your system?

Which font is affected?

Bot Check and Jabber ID, these two fields I do not know how to fill in, always unable to register.

Since WPS is third-party commercial software, this issue is not officially supported by Arch Linux, and WPS has to actively adapt to the new changes. In fact, Libreoffice doesn’t have this problem.

I have reported this issue to the WPS and look forward to their further action.