Changing XFCE's Panel 'windows Buttons' list icon size and diming?

Hello,

I have a very poor eyesight and I’m looking for a way to make the list of opened windows/apps icons in XFCE’s Panel bigger.

I quickly found out how to do it for standard ‘launchers’ (if you take a look at my screenshot, you will see that bellow Manjaro/Whisker’s icon two icons looks bigger than the others) but no such luck for the others (and smaller) icons: the list of opened windows.

I looked for such an option in the “Windows Buttons” properties, also checked everywhere I could think of in Manjaro’s settings, to no avail.

Do you know if it can be changed and if so how?

Bonus question: when a window is hidden, its icon is greyed out. It certainly is a pretty visual effect but, having a very bad eyesight makes it much harder to see for me. Do you know if this effect can be turned of and where? Looked in Acessibility, Window Manager Tweaks, Window Manager, Panel, Appearence without any success…

Thx in advance for any help or suggestion :wink:

Hi,

Try this and see if the outcome is better than the one shown in the posted image:

Right-click on the panel > Panel > Panel Preferences > Appearance (tab) > increase the value of the option Fixed icon size (pixels) according to your needs.

Maybe 32-36 pixels would be OK in your case, depending on the height (or row size) you have set for your panel.

After that, open a terminal and run xfce4-panel -r to reload the Xfce panel.

2 Likes

Or you can set icon size to 0 in xfconf to auto-size it or in the same Panel Preferences as described by @bill_t :wink:

2 Likes

Hi bill_t,

Thx a lot! Icons are now as big as expected :slight_smile: :+1:

icons2

The only thing remaining is how to turn off diming, but since icons are now bigger it’s much less of an issue for me.

Once again, thank you very much :slight_smile:

1 Like

@megavolt,

I just tried it. What’s odd is that the opened windows/apps icons always look a little bit smaler than the standard Launchers — bigger than what they were though :wink:

For the icon dimming part, in the file ~/.config/gtk-3.0/gtk.css (if this file does not exist, create it) paste the following CSS rule:

* {
   -XfceTasklist-minimized-icon-lucency: 100;
}

After saving the file, run again xfce4-panel -r in a terminal window for the changes to have effect.

1 Like

Neat! It’s so much more readable like that, at least for me.

Thx a lot, again :wink:

Edit: too bad one can’t mark two posts as ‘solution’ in a thread.

1 Like