Changing theme resets task switcher

I’m mostly using the default Breath theme. I downloaded a task switcher I like better than the default, it’s name is MediumDefault and it’s one of the most downloaded task switchers according to the Settings Manager.

I have unticked System Settings > Window Management > Task Switcher > Show selected window.

The problem is that If I change theme, the Task Switcher is reset and I have to manually enable it again. However, the Show selected window setting is kept.

I want the task switcher to be persistent across themes, and just like changing theme does not affect the preferred Show selected window, I want to keep my preferred task switcher when changing themes.

How to achieve this?

EDIT: thanks to raguse for providing a solution! While waiting for Plasma 5.25 I did:
sudo nano /usr/share/plasma/look-and-feel/ and changed the line under [kwinrc][WindowSwitcher] to look like LayoutName=MediumDefault

Which one?

it appears that whichever one you picked
(and didn’t specify)
didn’t work as you expected.

hmm … :wink:

That’s the name of the task switcher.
Made by adhe, it’s one of the most downloaded switchers

ahh - so:
I’m out of here - I do not use, or know well enough, KDE
to be of help here

… what a strange name for a program like that …
or: a strange description of it? :wink:

Well, thank you anyway, I guess, for the time spent on commenting here…

I’m sure you can get in touch with the developer and suggest better names.

… or perhaps you could try to improve your post
so that the next person may know better what you are talking about
and thus is able to actually assist you …

I’ll not bother you again! That is for sure!

If you are changing global themes, ALL settings will get set to what that global theme had. (One reason I never use global themes, I want to know what I have changed from defaults).
SystemSettings->WindowBehavior->WindowManagement->TaskSwitcher. to set your main and alternative switchers how you like. Then go to SystemSettings->WorkspaceBehavior->ScreenEdges. Choose a corner and choose Task Switcher or Alternate task switcher. Either one is just a corner of the screen away.

Edit: Not a true answer to your question, but an easy alternative to getting both.

Thanks for that suggestion! It helps as a workaround, but it’s not as smooth as I wish.

So since you’re not using global themes I take it you’re using customised ones? How do I create a theme from my settings?

The better solution for you: Wait for Plasma 5.25 because with version 5.25 you can select to leave the task switcher unchanged when changing the theme.

Should you not want to wait another few weeks:
The Task Switcher in KDE is defined within the globals of each theme, for example for Breath you find the default in /usr/share/plasma/look-and-feel/org.manjaro.breath-dark.desktop/contents/defaults.

Whenever you change theme to Breath it will return to Breeze as task switcher. Should you want to change that you will have to adjust it manually there. Keep in mind that an update to the Breath theme will revert your changes and you will have to change it again manually.

For locally downloaded themes it will also be in the look-and-feel folder in ~/local/share/plasma/look-and-feel/.../.../. You can change it manually there.

1 Like

@al_F I just change what I want changed from the Appearance settings. I’m not too demanding of my themes.

@raguse Thanks - I tried to find where those settings were, but was not familiar enough to locate them.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.