Changing the appearance of application (hterm)

Hello there,

I got an annoying issue with the application “hterm”. It does not adapt properly to the dark theme (matchama) and assigning another theme to it in the kvantum manager does not change anything. Is there a workaround? It is hardly readable and I need it’s functionality for embedded development. Any help is appreciated, thank you very much!

All the best

What can’t you see ?

I use matchama dark azul

Welcome to the Forum!

According to its AUR page, hterm depends on gtk2, which means that its appearance isn’t configured from Kvantum Manager.

Try a different theme in Settings Manager → Appearance → Style (tab) and see if it gets any better. This will change the theme for all Gtk-based applications in your system.

1 Like

I am using the exact same theme and it is looking the same. I wanted to upload a screenshot but was not able to (probably because I am new here lol).

The data you are able to write for outgoing transmission is white with blue background, that’s unreadable… Incoming data is black on dark background… annoying aswell.

This works, thank you. Is it possible to enable this for only one application? I like it dark…

1 Like

Kvantum can’t change the theme for this app, and the theme manager change it at desktop level only.
So, in your case, you can’t do it.

gtk2 themes are read from ~/.gtkrc-2.0 so check that file to learn what theme are applied to gtk2.

And by the way - thank you for making me aware of this serial comm app.

1 Like

To open hterm using Adwaita-dark as an example, since it’s a Gtk2-based application, you can use this command in a terminal window:

GTK2_RC_FILES=/usr/share/themes/Adwaita-dark/gtk-2.0/gtkrc hterm

Or you can create a panel launcher in your panel (or even copy the .desktop file of hterm in the ~/.local/share/applications/ directory) and use this command in the launcher (or in the Exec line of the .desktop file):

env GTK2_RC_FILES=/usr/share/themes/Adwaita-dark/gtk-2.0/gtkrc hterm

Hope this helps!

1 Like

Hey Mr. bill_t,

Thank you for your solution - it kind of works. It changes something - the buttons, but sadly, not the background. Looks funny tho…

I tried a couple of themes, the outcome is roughly the same.


(wohoo I am able to publish imgs)

This inconsistency probably happens because you have selected a “light” theme in Settings Manager → Appearance → Style (tab) for your system in general and chose a “dark” theme for hterm.

If you select a “light” or a “dark” variant of any theme for both system and hterm, I think you’ll be OK.

In any other case you’ll have to tweak the file ~/.gtkrc-2.0 as @linux-aarhus already mentioned, in order to add new rules to it for hterm specifically.

It is the other way around, but I get your point. The file does not exist on my system, but I will create one and dive into the options I can configure with it. Thank you very much for your patience!

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.