Changing locales

Hi Guys,

I want to switch a Manjaro XFCE from German to English (with german formats):

  • so i used the Manjaro-Settings-Manager but nothing changed
  • locale still tells me LANG=de_DE.utf8
  • in locale.gen en + de ist active
  • i used localectl set-locale LANG=en_US.utf8 per sudo an su, no error message or other output
  • locale still tells me LANG=de_DE.utf8

What am i doing wrong?

Welcome to manjaro.

Do you have rebuild your locales?

sudo locale-gen

I did, en + de ist active in locale.gen and i ran the script.

I havent changed any config files manually, english and german were already configured. I tried to switch from one to the other via manjaro-settings-manager and nothing changed. Then i tried to change it via “localectl set-locale LANG=en_US.utf8” but the locale is still LANG=de_DE.utf8.

locale -a gives me the following output:
same as on my other system which is set to english.

Look in xfce4-keyboard-settings (menu - settings - xfce4-keyboard-settings (Tastatur))

log out/in or even reboot .

Thanks, but i want to set the general locale ($lang) to english so i get english menus and not these weird translation you will find in the german version. Other stuff like keyboard, dateformat, time zone and so on should stay in the german format.

My Problem is that i already did the reconfiguration but for whatever reason it didnt stick/work out. So either i did something wrong or there is a hickup in my system. I even tried to use the manjaro-settings-manger in root context (su) and it gave out a “locales set”, but still lang=de_DE.utf8.

First set it to english, then you set your individual formats in manjaro-settings-manager .

Have you even read what i wrote?
Are you on drugs?

You could have spared the second sentence.
What he said sounds perfectly reasonable to me.

If the GUI approach doesn’t work for some reason - command line will always work.

What is in /etc/locale.conf ?
(it should be an english locale)

There was already a link to the Arch wiki.

Ok, I’m out here.
I don’t waste my time with brazen idiots.