Changing HDD properties in KDE's Dolphin

Hi, all.

Have a question about Dolphin in Manjaro KDE, which I find puzzling. I want to modify some properties of a 1 TB drive I have on my desktop PC, and to that end, I open Dolphin, select the drive, right-click and select “Properties”. Then, in the “Permissions” tab, I change the Group to “sambashares”, then in the “Share” tab I tick the “share this folder with other computers on the local network”, tick “allow guests”, and give everyone full control. Then I click on OK, and if I again open these Property tabs, everything has reverted back to the previous values, so all the choices I previously made are discarded.

So, my question is, what is the purpose of making the user believe he can change these properties in this manner, when any and all changes are summarily discarded with absolutely no feedback to the user for why his choices are being ignored?

Thanks

Hello,

You have to make sure you installed manjaro-settings-samba and rebooted your system, then all that will work. Also mentioned in the wiki
https://wiki.manjaro.org/index.php/Using_Samba_in_your_File_Manager
Probably you want to use something else instead of WORKGROUP, so make sure you check that in /etc/samba/smb.conf after you install the mentioned package.

That is a loaded question, not going to answer it.

There are other sharing solutions that many users prefer over samba. Example:

2 Likes

manjaro-settings-samba is actually installed. See screen shot below:

Thanks anyway.

As you didn’t provide any technical information on the partition you’re wanting to share (there is no concept of drives in Linux, just the Linux file system and partitions who happen to reside on disks) so it’s hard to say what your real issue is, but it smells like an NTFS partition issue

NTFS partitions can be read and written to and you can even show the permissions but you cannot change them: that needs to be done under Windows and the way that the NTFS-3G userland driver copes with that is by not providing an error message.

So the answer to:

is: That’s by design!

However that’s just supposition and we cannot answer that question in depth without more information like the output to:

mount | grep "^/dev/.d"
parted --list

:wink:

In the hypothetical case it is an NTFS partition, you’ll benefit a lot from reading this:

1 Like

Fabby,

You’re absolutely correct, the HDD in question is a 1 TB WD drive formatted by me in Linux using the NTFS f/s. Typically, I exclusively format all my drives using EXT4, but since this smaller drive was to be used as a share in a mixed environment, I (apparently incorrectly) formatted it as an NTFS share. Incidentally, I had already read the article you linked to (How to become a Manjaro power user…).

Thanks much for the info.

2 Likes

I’ve marked the below answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (I just want to avoid even more subjective opinions being posted and confusing you even more)

:innocent:
P.S. In the future, please don’t forget to come back and click the 3 dots below the answer to mark a solution like this below the answer that helped you most :
Solution
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

1 Like

Thank you.