Changing from KDE to i3wm causes certain apps to randomly hang

I’ve had a stable Manjaro-KDE install for several months now, but was missing i3 so decided to install it and use it as the Window Manager for KDE. Everything seemed to have gone fine, but now certain programs will randomly hang. I’ve experienced it happen so far with Firefox and Dolphin file manager.

At first I thought the issue was Firefox, so I followed some advice on Firefox support pages, but I never had issues with Dolphin before so I believe the problem is widerspread than I originally thought.

Things I know do work: Falkon browser, Discord, Emacs, Alacritty, System Settings
Things I know don’t work: Firefox, Dolphin file manager

I just ran sudo pacman-mirrors -f 5 && sudo pacman -Syyu following the advice of another post on this forum. And if I run inxi -Fxxxza it outputs the following (ignoring what I think isn’t important):

System:    Kernel: 5.4.62-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.4-x86_64
           root=UUID=eb887475-bbaf-4f0c-a2cb-0aea32574e16 rw quiet udev.log_priority=3
           Desktop: KDE Plasma 5.19.5 tk: Qt 5.15.0 wm: i3 4.18.2 dm: SDDM
           Distro: Manjaro Linux
Machine:   Type: Convertible System: LENOVO product: 20EMCTO1WW v: ThinkPad Yoga 460
           serial: <filter> Chassis: type: 31 serial: <filter>
           Mobo: LENOVO model: 20EMCTO1WW v: SDK0J40697 WIN serial: <filter> UEFI: LENOVO
           v: R05ET68W (1.46) date: 11/23/2016
CPU:       Topology: Dual Core model: Intel Core i7-6500U bits: 64 type: MT MCP
           arch: Skylake family: 6 model-id: 4E (78) stepping: 3 microcode: D6
           L2 cache: 4096 KiB
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
           bogomips: 20810
           Speed: 500 MHz min/max: 400/3100 MHz Core speeds (MHz): 1: 500 2: 500 3: 500
           4: 500
           Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages
           Type: l1tf
           mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable
           Type: meltdown mitigation: PTI
           Type: spec_store_bypass
           mitigation: Speculative Store Bypass disabled via prctl and seccomp
           Type: spectre_v1
           mitigation: usercopy/swapgs barriers and __user pointer sanitization
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
           IBRS_FW, STIBP: conditional, RSB filling
           Type: srbds status: Vulnerable: No microcode
           Type: tsx_async_abort status: Not affected
Graphics:  Device-1: Intel Skylake GT2 [HD Graphics 520] vendor: Lenovo driver: i915
           v: kernel bus ID: 00:02.0 chip ID: 8086:1916
           Device-2: Chicony Integrated Camera type: USB driver: uvcvideo bus ID: 1-7:3
           chip ID: 04f2:b5c1
           Display: x11 server: X.Org 1.20.8 driver: intel unloaded: modesetting
           alternate: fbdev,vesa display ID: :0 screens: 1
           Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2")
           s-diag: 582mm (22.9")
           Monitor-1: eDP1 res: 1920x1080 hz: 60 dpi: 157 size: 310x170mm (12.2x6.7")
           diag: 354mm (13.9")
           OpenGL: renderer: Mesa Intel HD Graphics 520 (SKL GT2) v: 4.6 Mesa 20.1.7
           direct render: Yes
Info:      Processes: 195 Uptime: 5h 26m Memory: 15.53 GiB used: 2.33 GiB (15.0%)
           Init: systemd v: 246 Compilers: gcc: 10.2.0 clang: 10.0.1 Packages:
           pacman: 1481 lib: 385 Shell: Zsh v: 5.8 running in: alacritty inxi: 3.1.05

If anyone is able to help out with this it would be greatly appreciated.

tl;dr Everything worked fine until I installed i3 to use with KDE, now things hang randomly.


The “KDEWM” is called KWin, so how did you replaced it with i3 and most important how did you set the compositor now, as i3 will need picom = compton

Have you done it like this or differently ?

I followed the instructions to use another window manager with KDE from the KDE website (it won’t let me include a link to that page?)

I created a script called, with the following contents:


export KDEWM=/usr/bin/i3

and put that in my autostart settings to run before session startup.

Following the question that you linked, I added compton to that script using the same command as there: compton -cCFb --backend glx --vsync opengl. I logged out of my session and logged back in, opened Firefox, and I’m still getting the same issue. I click on a tab and it takes 20+ seconds to change tabs, it randomly freezes while scrolling, etc.

Try with
xcompmgr -C
If works better, then try some tweaks when using compton … also change that to picom as now is called so.

Okay, definitely not that. I don’t know what happened, but using xcompmgr -C made it so that whenever I booted into Plasma my screen would just be all grey and nothing would happen. Nothing getting displayed at least. Had to boot from a USB and remove that from the script to log back into Plasma.

Does it hang after a while or right away?

Can you provide a backtrace log via gdb to see why it hangs?
But please remove that compton line it is needless since compton =! picom

You could also try i3-plasma

i3-plasma 4.16.1-1 AUR
A fork of i3-gaps tiling window manager with default configuration for plasma