Change Wallpaper dialog does not open

About a month ago I noticed that the “Change Wallpaper…” dialog from the Appearance settings screen does not open when I click on the button. I tried to recreate my .cache directory from my home folder as suggested in this post but it did no good.

I do not see such a button anywhere in the Appearance section of the System Settings on my system. :thinking:

The normal way of switching wallpapers in Plasma is to right-click an empty spot on the desktop and then choose Configure Desktop and Wallpaper.

There it is:

Ah yes, I see now; you have the sidebar view enabled, whereas I use the icon view, which does not show that button.

Either way, it does work here on my system. Have you tried it the way I described above?

Yeah with dolphin’s context menu I can set a picture as my background.

That is not the method I described, but okay, that’ll work too. :man_shrugging:

Oh right sorry, yes the “Configure Desktop and Wallpaper” menu also works.

Then I guess the problem lies with your System Settings application itself, because as I wrote, I’ve tried it here on my system, and it does fully work here.

One possible reason — only one, and I don’t even know whether this applies in your case — could be that you’ve installed an incompatible and no longer maintained global theme, and/or that you’ve specified that your desktop must follow the theme’s layout.

Personally I avoid global themes like the plague, and instead I just theme the individual components separately — i.e. custom panel layout, Plasma theme, desktop wallpaper, window decorations, color scheme and application style.

What I see it’s an issue with multiple activities. I confirmed this with a new user because I experience the same.
@nicos Do you have 2 or more activities set up?
What I tested is that the Change Wallpaper button from system settings only launches from the initial activity. When I set up another activity or subsequent ones it’s not possible to launch the wallpaper configuration screen from settings.

Can someone confirm? It calls for a bug report at KDE.

Yes, I can confirm what you just said. It only works in the first activity, not in the second one.

1 Like

I confirm I have multiple activities indeed. Good catch !

@nicos I actually think it behaves as designed. The case is that the Change Wallpaper button in settings would have to open different wallpaper settings dependent on which activity is currently in use. In addition you can show the settings dialog ‘in all activities’ . Would the settings dialog then know which activities wallpaper should be called when pressing the button?

So it’s not so easy. I think KDE kept it simple and just offers wallpaper settings of the initial activity.

I disagree, an activated button that does nothing is at the very least very poor UX, and why not just simply implement the same functionality as when you use Dolphin’s context menu ? It has to be a bug, even though I agree that things might not be so simple.

@nicos I agree. It is a solveable ‘bug’. Do you want to open a bug report at KDE?
Otherwise I will do so.

Done: 452561 – The "Change Wallpaper..." button does nothing
My first bug open on kde ! :tada:

1 Like

@nicos You should mention in your bug report that the issue comes from different or several activities. It’s quite an important piece of information. It will also raise the chance of analyzing, confirming and solving that one. Up to you.

The thing is, I just deleted all my activities (except one that I can’t delete) but the issue is still there :confused:

I can’t confirm that. Even when I delete both config files for activities ~/.config/kactivitymanagerdrc and ~/.config/kactivitymanagerd-switcher the new Default activity allows to change the wallpaper from system settings. Deleting the config files resets the wallpaper/activity settings.

@nicos Just upgraded to plasma 5.24.5 and the issue seems fixed.
Thanks for your bug report!

1 Like