Change Pictures etc folder location (of ROOT user!)

I use custom locations for those with my normal user account, created symlinks (ln -s "/mnt/files_ntfs/Eigene Bilder" pictures) and as you see I also made them lowercase. Works good so far when you just use the home dir and go from there, until…

for example open LightDM GTK+Greeter Settings, change user icon, a dialog appears…

it has in the left panel locations like “Pictures” … I hover over them and the tooltip reads “root/Pictures”. Click on it and empty pane shows. Well that is weird.

What I did:
checked /etc/xdg/user-dirs.defaults here still the uppercase variants were in, I replaced with lowercase. Didnt help. I also tried not to reference the symlink but the target directly (PICTURES="/mnt/files_ntfs/Eigene Bilder"), didnt help
checked ~/.config/user-dirs.dirs - this already had XDG_PICTURES_DIR="$HOME/pictures"

edit: I relogged after each change so xdg-user-dirs-update should have run

edit: apparently this is for the root user because the greeter settings dialogue is elevated to root

the comment at the top of ~/.config/user-dirs.dirs says

This file is written by xdg-user-dirs-update
If you want to change or add directories, just edit the line you’re
interested in. All local changes will be retained on the next run
Format is XDG_xxx_DIR="$HOME/yyy", where yyy is a shell-escaped
homedir-relative path, or XDG_xxx_DIR="/yyy", where /yyy is an
absolute path. No other format is supported.

this sort of implies that xdg-user-dirs-update is run on some regular trigger, but not knowing that that is, have you tried running the command after editing the file?

I mostly re-logged and did one reboot. I tried to run that command and it did not help. I’m curious, when you open the dialog I mentioned, where do the dirs point to? I mean /root/Pictures makes no sense at all … probably ignores the ~/.config since the dialogue is elevated to root, but in that case I guess it should use the /etc/xdg/user-dirs.defaults which it doesn’t.

The /root indicates that at some point you ran the command as root where the $HOME variable resolves to /root