Change keyboard language/input in XFCE

Photo of a keyboard
https://sun9-13.userapi.com/impf/3C0fMPBvP5J_zKyE4WaFnsn6M6NpStEyXBeTIg/fSABQ_g7sFM.jpg?size=2560x1280&quality=96&proxy=1&sign=011d60d45865cc30de2c530833e677a1&type=album

Laptop : Lenovo Thinkbook G2
I am bilingual person(russian and english) and I have to keyboard layouts used
If we take button which has (?/.,) I should be able to use (?/) while using English layout and (.,) using Russian but when I press it it can only display (?/)
Next thing , at the right top corner you see 2 buttons to rewind a video but I am not able to use them in Youtube at all but when I use them in VLC all they do is rewind the video to its beginning
And there is some more things like these but I have already written a lot
Thank you in advance.

Hi ReTro, welcome to the forum :partying_face:

There should be a option to add input sources in your settings, look for Region and language, input methods
When adding a input sources there should be a icon in the taskbar to switch the input source.

I’m using gnome and when adding russian language the ?/ switches to ., so that seems to work.

If this does not solve your problem, or if this option is missing please add what edition you are using.

No, I dont have such option
I am using latest version of Mangaro XFCE

https://sun9-66.userapi.com/impf/Yw7h01zafPt1gTCpnyfHdQ0C_V1wlXaOlnQCvg/sESiOILdAI0.jpg?size=604x568&quality=96&proxy=1&sign=889fc9982678f3caef663fffb858054d&type=album
Hey ,I have found these options and I think that is what I am looking for but I am only able to choose only Russian or only English.
What can I do with that?

There is a option to add another languague in the setting for keyboard.
Tagging this post with xfce, maybe a regular XFCE user can help.

Ok,thank you

Found something, If I set the change layout option to a key I am able to switch on the fly between language inputs

In my case I’ve set it to alt+capslock and can switch on the fly.

Example below, please excuse my Russian. I’ve use the exact same letters as the line above.
image

1 Like

Really thank you for installing XFCE version ,I apreciate it a lot but I know that I can change layouts , problem is not in this
Look at the link above where I sent settings for a keyboard.
Manjaro sees my keyboard as Russian only but I use English too
Because of that key which contains ?/., is used only as ?/ for both layouts

Reread all I wrote above and sorry for my English)

I understand your question now, sorry for the confusion. If I recreate the same situation as in the pictures I have exactly the same problem, no solution yet tho…

Well ,thanks for your time, I didnt expect that someone will take this problem in serious
If I somehow find the solution I will write here

I have no clue how does this work but I have made a bootable usb with Gnome edition and there everything works perfectly
Every single key works as it should work
I didnt consider Gnome before because I thought that it is too heavy but now I really think of installing it.

Hello. Under Keyboard Layouts add a layout for Russian Serbian (Russia). It seems to correspond to the keyboard picture you posted. Including the ?/ key changing to ,. .

Furthermore if you want to edit individual keys in a layout you’ll find them in /usr/share/X11/xkb/symbols/ru (Make a backup of the file before editing, changes take effect after reboot)

Hope this helps.